Unable to see my grid or objects in editor

Please help. Just downloaded the unreal engine on the windows on the MAC running parallels, It fails to show me the grid and I can’t see the objects I place into the perspective viewer.

You installed on both the Mac and Windows? Did I read that right? Do both editors not display anything in the viewport? There are little eyes next to each item in the world outliner, are they shown clicked? (lite)?

Yeah the eye shows clicked. I can’t see any objects at all.

Hi jdd106,

Are you looking at a new empty level? Easiest solution: Open a new template project.

If this is not the issue, try dragging into the viewport a BSP cube and point light and build the level. I you can see these, but not the grid try the solution posted here:

After Create Empty Level Can’t See Grid Anymore

If neither of these work, please respond describing what you have tried and we will continue to troubleshoot.




I tried the BSP cube and point light and build but it nothing. I tried a new template project but again nothing

Kind regards,

Just to clarify, have you tried with a blank Third Person Project where lights, etc are already established?


Sorry yes I loaded a new third person shooter file but still having the same issue

Kind regards

Yes I loaded a third person template and still having the exact issue

Have you tried UE4 on your Mac while not in Parallels to determine if this is an issue with your hardware or conflict with Parallels itself?


Your picture did not upload correctly, please try uploading again. Also, please provide your Mac’s specifications. You can find this in the Apple menu >About This Mac>More Info> Add the information from this window (serial # not necessary). -Thanks

Hi jdd106,

Since we have not heard back from you in a while we are closing this post as “resolved” for tracking purposes. However, if you are still having problems seeing the grid and objects in the perspective viewer, please respond with the requested information and your Mac’s specifications and we will continue to investigate.



Hi , thanks for your help and trying to get this resolved, but still experiencing the issue with Unreal on Windows running through Parallels virtual machine, I installed unreal straight for Mac, but since there isn’t visual studio enterprise integration which is the IDE I wanted to use for the Mac version of Unreal it’s pointless. Even on the Mac I am also having issues with Xcode being recognised by the Unreal Engine. So I am not pleased with Unreal at the moment.

Mac Spec
MacBook Pro retina 15 inch mid 2014
2.8 ghz Intel core i7
Graphics Intel iris pro 1536MB invidia cuda

I’ve just discovered we do not support Parallels. Can you describe in greater detail the issue you are having with Xcode not being recognised by the Unreal Engine?

Hi jdd106,

While we do not support Parallels we do support the use of Xcode with UE4 in the OSX environment. Please review the solutions to the following AnswerHub posts and let us know if none of these resolve your issue: