Unable to package game 4.15.1

Hi Everyone,

I apologize if this is a redundant issue but I"ve been learning and developing for the past 6-8 months and now it is time to build and package. As of yet I have not created a successful build of my VR game. I am not even sure where to start haha! Any help would be immensely appreciated!

  1. I am attempting to build to Windows 64 bit
  2. It is a fairly simple game using the VR template
  3. I am not using a 3rd controller and I cant see where something like that would be set.
  4. The majority of errors began once I tried to Generate visual studio project

link text

The relevant bit of the error output is here:
LogStats: FPlatformStackWalk::StackWalkAndDump - 0.086 s
LogOutputDevice:Error: === Handled ensure: ===
LogOutputDevice:Error: Ensure condition failed: false [File:D:\Build++UE4+Release-4.15+Compile\Sync\Engine\Source\Runtime\Core\Private\Math\Matrix.cpp] [Line: 8]
LogOutputDevice:Error: FMatrix::InverseFast(), trying to invert a NIL matrix, this results in NaNs! Use Inverse() instead.

So in blueprint off the BeginPlay event for the MotionControllerPawn you are trying to invert a matrix which may not be valid. Likely you just need to put a check that it is valid and it will work - but without seeing the BP can’t say for sure.

Thank you so much that fixed it! I did apparently have an invalid beginplay event in one of the levels blueprints . Deleting it took away that error. Only one I am getting now is

LogUObjectGlobals:Warning: Failed to find object ‘Class None.’

I’ve tried looking this one up to avail. Back around 4.13 people were saying it was simply a bug but I cant find any work rounds. Have you seen this before perchance? Thanks so much again!

That warning should be fine to leave. If you find that the answer worked, please accept it so the question shows up as answered and others can see what helped find the problem.

Absolutely it helped that portion of the build fail! The package still fails though. Attached is the error log. I greatly appreciate it by the way. This is the part that is difficult to find answers on since each game is designed differently. Which Im sure you know haha.link text

It take a bit of practice working with the error output from packaging. The relevant bit is here:
UATHelper: Packaging (Windows (64-bit)): Program.Main: ERROR: AutomationTool terminated with exception: System.ArgumentException: An item with the same key has already been added.

I’ve not had that one, but searching answerhub with it, I found this:Same key error

Which I think will help you fix the problem.

Thanks for that! I figured out this bit I think…I had originally had the project named something else and tried to build it. I came across an error and after a bit of searching I had read a blank c++ class had to be made. So I made it and tried to build but failed again. So when I tried to open the project later it would not open. So I created a blank project and copied all of the folders over except for saved and intermediate I believe. This allowed the project to be opened with no error. Now when I search for .target it appears as if it is targeting the old file which is named differently. Question is should I change the name of where the code is pointing to in my source folder using visual basic or create another blank project and name it the original name and copy over the new non corrupt files?

I’d suggest that creating a blank project and migrating the content over is likely quicker and easier. Note: migrate the content, do not copy the folders. UE has an asset registry that is not updated correctly if you copy folders using explorer or similar. That may be part of the problem. Since your current project works aside from packaging I would suggest making a new project, then migrating the content to it - hopefully that should be fine.

Wonderful! Thank you sooo much! It totally worked!