Download

Unable to instantiate UnrealEd module for non-editor targets

I see this when packaging the project for windows 64 bit.
**Error: **Unable to instantiate UnrealEd module for non-editor targets

I understand this means I must be using something that should be editor use only, but I’m not sure where it’s coming from. I only have two Function Libraries which could be causing this. So I’ll list the headers in those that I’m using:

  1. I have a file that I’m using to clear cookies.


#include "Runtime\WebBrowser\Public\IWebBrowserSingleton.h"
#include "Runtime\WebBrowser\Public\WebBrowserModule.h"
#include "Runtime\WebBrowser\Public\IWebBrowserCookieManager.h"


  1. This file is used to decrypt some string from my server


#include "SecurityBlueprintFunctionLibrary.h"
#include <string>

FString USecurityBlueprintFunctionLibrary::DecryptMessage(const FString Message)
{
std::string s = "some salt";
std::string p = "some password";
std::string modMess = std::string(TCHAR_TO_UTF8(*Message));

// I've removed my actual decryption for obvious reasons.

return FString(modMess.c_str());

}


Maybe it could be some plugin? Here’s my plugins:


"Plugins": 
{
"Name": "SoundVisualizations",
"Enabled": true
},
{
"Name": "OculusVR",
"Enabled": false,
"SupportedTargetPlatforms": 
"Win32",
"Win64",
"Android"
]
},
{
"Name": "SteamVR",
"Enabled": false,
"SupportedTargetPlatforms": 
"Win32",
"Win64",
"Linux",
"Mac"
]
},
{
"Name": "VaRest",
"Enabled": true,
"MarketplaceURL": "com.epicgames.launcher://ue/marketplace/content/e47be161e7a24e928560290abd5dcc4f"
},
{
"Name": "WebBrowserWidget",
"Enabled": true
}
]

And my AdditionalDependencies only includes “Engine”

Okay I read through the logs and I see this:


UnrealBuildTool.Main: ERROR: Unable to instantiate module 'UnrealEd': Unable to instantiate UnrealEd module for non-editor targets.
UnrealBuildTool.Main: (referenced via Target -> **NativizedAssets**.Build.cs -> Blutility.Build.cs -> MainFrame.Build.cs)

NativizedAssets.Build.cs That’s where it’s happening.

This plugin is enabled by default: Enabling plugin ‘NativizedAssets’ (referenced via default plugins)

And I have my Blueprint Nativization Method set to inclusive. Probably this?

That was it, disabling nativization fixed the problem. Though I would rather use nativization… seems it has some bugs.