Packaging failed, how to find which file is refferencing 'UnrealEd'?

Iget this error when trying to package: > UATHelper: Packaging (Windows): ERROR: Unable to instantiate module ‘UnrealEd’: Unable to instantiate UnrealEd module for non-editor targets.

UATHelper: Packaging (Windows): (referenced via Target → Nemo.Build.cs → BlueprintGraph.Build.cs → KismetCompiler.Build.cs)

I have a bunch of cpp files in project, glanced through all of them and none references the ‘UnrealEd’ directly, nor the *.Build.cs, how do I find the culprit? Even tried copying all the source and plugins to empty project but then it packages fine so I guess this is somehow blueprint related.

PublicDependencyModuleNames.AddRange(new string[] { "Core", "CoreUObject", "Engine", "InputCore", "Paper2D", "NavigationSystem", "AIModule", "Landscape", "GameplayTags", "UMG" }); PrivateDependencyModuleNames.AddRange(new string[] { "Water", "Slate", "SlateCore"});

Thank you for posting this question.

A good start would be to look through your logs and see if there are any lines that pertain to anything being “Editor Only”.

As stated by Original Poster here.

there are exactly zero hints besides

(referenced via Target → Nemo.Build.cs → BlueprintGraph.Build.cs → KismetCompiler.Build.cs)

for some reason the .uproject had this thing attached:

“Modules”: [
“Name”: “Nemo”,
“Type”: “Runtime”,
“LoadingPhase”: “Default”,
“AdditionalDependencies”: [

and for no good reason, after removing those dependencies packaging worked

1 Like