Unable to fetch Player BP bools from Animation BP


my guess : check what asset you are visualizing, it’s probably the preview object for the animation blueprint.

The preview object doesn’t have any pawn attached obviously, as it’s not ingame and attached to an Actor.

Also, check your pawn bp, it’s SkelatalMesh should have AnimationBlueprint defined as animation mode, and said AnimationBlueprint defined as the value.

Yea since I’m keeping my scope small I am still learning things, I didn’t know about the visualizing aspect of the anim bp. It is set to preview or no debug instance.

I double checked my character bp as you suggested and found my animation blueprint however it wasn’t strictly char_anim_bp, the name listed is char_anim_bp_C.

Perhaps this info can help assist anyone if they needed more info, I can also provide more.

So, are you in simulation with said pawn spawned when you try to check it’s bp ?

Simulation mode have to be in editor ( either “selected viewport” or new editor windows" ) to be able to live check the data .

_C mean it’s the compiled version of the blueprint, so that’s normal :slight_smile:

So what your saying is that I need to remove my PlayerStart, place an instance of my Player_BP into the level and then in the visualizer component select that BP and then Fetching the pawn will work?

I’m going to try some more while I wait to hear back, I am unfamiliar with how to get sim mode to work and was planning on looking up docs at some point.

Just tried to PIE test with different debug filters set. When dragging another instance of my BP I don’t play from it, I play from the cameras position. Still not able to fetch the owner however I feel like I’m getting closer.

Didn’t think something like this would be so difficult, but thanks for your patience and replies

Ok so after escaping PIE and changing my anim BP’s debug filter to the pawn BP, the execution flow appears to be working correctly.

However I’m still unable to see the simple jump animation play when I jump. Are the values not being read? My flow was fetch bPressedJump from C++ → assign in AnimBlueprint to isJumping? and that is the rule for the transition state.

ok, good ! :slight_smile:

Can you right click on the PressedJump ( in the anim bp you showed at the begining, and select “watch value” then do the simulation thing again;

this will show us the value of the variable durring the simulation, to check if the problem comme from that or not

I’ll just get right to the point.

Attached is an image of my Event graph inside my Animation blueprint. I think for the most part it will work, the issue is that I cannot test it because my Try Get Pawn Owner call is not returning a valid AnimInstance. I’ve tried other functions and always end up with the same result, to name a few (Get Player Pawn, Get Player Character, Get Owner, etc).

I’ve look at sample projects as well as other problems of a similar nature and haven’t been able to come to a fix. If there is an alternative to reading boolean variables from my C++ class and using them to throttle states in the Animation Blueprint as opposed to this, I would greatly appreciate a pointer in the right direction.

Some additional information:

  • My game mode is set correctly in the settings with default pawn set as the CharacterBP
  • My Character class is written in C++ and the blueprint is derived from it, game mode is NOT (I suspect there is a complication character)

If there is more I can think of over the next day or two I’ll update this question with any other information and be checking back periodically.


No, you should keep your player start, as long as the good player blueprint is spawned.

When you are in PIE, simply go to your anim BP, and instead of preview, you should be able to select the one from your unit . To get your mouse control back without ending the simulation ( world should still play ) , you can do shift+F1

if ever you still don’t have the choice of the AnimationBlueprint instead of “preview instance”, there might be a wrong setting on your unit blueprint. Choice should display something like " SCharacter_AnimBP_C_0 in yourUnitBP"

I apologize for the late response, busy day. So thanks for basically teaching me how to debug blueprints, everything appears to be in working order now.

My problem was assuming MyCharacter class was able to read bPressedJump which I assumed was inherited from the base parent Character class, I watched my other values and saw they were responding correctly.

I really appreciate the help and the responses, I usually don’t have much faith in forums/hub but hopefully that changes, Cheers!

No worries !
You might not always get answers but most of the time yes :slight_smile:

Have a good day !