Unable to duplicate static mesh?

Okay, so my problem is exactly the same as the following post: https://answers.unrealengine.com/questions/42961/after-patching-i-cant-duplicate-my-mesh.html

Except that the problem occured as I was working on the project, it didn’t actually happen after updating the engine, I did however try updating to a newer version but it did not fix the problem I was having, any help would be appreciated!

Hi Choczy123,

I have a few questions:

What version of the editor are you using?

Can you reproduce this behavior in a new project?

Also, how exactly are you duplicating the meshes (Alt+dragging or right-click menu > Edit > Duplicate)?

I was using 4.6.1, but I upgraded to the preview 4.7 and no luck, I tried a different project and it worked, the problem is specific to this project, and I tried all three methods, all the same result, thank you for the quick reply!

Could you post your dxdiag (or system specs if you are using a Mac)?

link text

Here you go, hope this helps

Everything looks good there. This seems to be an isolated issue. Is your project small enough to send a copy for us to test in-house? You could send me a link by private message on the Forums to download it if you aren’t comfortable posting it here.

It’s part of a university project we are working on, but I can archive it and send the link I don’t mind, one moment while it uploads

It is however around 1.2GB large, would it be easier to post screenshots of some of the interfaces? Or would waiting for the files to upload be better?

Okay, the project can be downloaded here https://dl.dropboxusercontent.com/u/23835248/INV%204.7v1.rar Thank you for all of your help so far, this problem is tearing my hair out

Still having the problem, any help is honestly appreciated!

I’m still unsure of exactly what is going on but it seems that the only assets that won’t duplicate correctly is the Static Meshes that you added. If you look in the Scene Outliner they are duplicating but are loosing the referenced static mesh in the Details panel.

Your blueprints duplicate fine, as well as the blueprints and static meshes from the Starter Content.

I’ll continue to look into this and post back here when I have something. Make sure to post back too if you find anything.

They all duplicated fine until a random point that I cant remember, even the meshes that worked before suddenly stopped working :S

I opened an earlier backup of the project, and have just reimported the Meshes into that, Ive lost a few hours of work but it seems to be working okay now, not sure what caused it… Its a good thing I save in versions

Yes it is, I’m glad you got it working. If it starts happening again post back here and let us know. I spoke with one of the other techs here and he seems to think it could have been caused by the import process. So re-importing them may be the proper fix.

I have same problem, too. Looks like the duplicate command creates an note in World Outliner, but it has wrong mesh name in Static Mesh Window. For example: The mesh name suppose be ST_Mesh. I will turn into ST1, 2, etc.

found an interesting cause for this bug.

made some objects containing special characters in max > export to fbx > unreal 4.15.1.
object name “wk_bank_left_15°_a”

imports fine, drags into the viewport for creation fine.
duplicating it generates a null static mesh actor with the mesh slot unable to be occupied.
renaming the object in content browser to “wk_bank_left_15_a” re-enabled proper duplication.

if a dev could have a look at squashing this and supporting special characters it’d really help my naming conventions!