Download

Unable to create Emissive Material

Hey All,

I am trying to create a simple emissive material.
I am following this simple tutorial Unreal Engine 4 Tutorial - Emissive Lighting - YouTube.
For some reason i don’t get the desired effect when trying it locally on my machine (I am using UE4.5.1)
I have attached the material into this post.

cd47d25696922f9a13b72efcf3729c13793701a3.png

What am i doing wrong?

Thanks,
Boaz

For that you have to use the 4.6 -> there they have added emissive light :slight_smile:

Silly me :slight_smile:
Thanks for the quick response - I’ll check this right away

I just tried it out with 4.6.1, and I still get the same behavior :frowning:

On your Multiply node, connect a Vector1 into B and start with a value of 10 :slight_smile:

Didn’t work either :frowning:
Just for my general knowledge isn’t it the same as a setting B to a constant value in the multiplier itself?

I know I am doing something wrong, because the Emissive material demo that comes with the ContentExample demo works just fine.

Interesting, I have migrated the Emissive material from the ContentExample demo into my project and suddenly the emissive effect was lost!
Now I am completely confused.

What exactly is not working? -> the light or the “shiny” effect? :slight_smile:

Sigh, I finally understand what is going on.
My project was configured as Mobile / Scalable 3d or 2d.
Once I changed the setting to Max quality the emissive effect started working.

I don’t know whether this behavior is intentional, what do you think?

Yeah, the “shiny” emissive effect. I was able to isolate the reason. See my post below

I personally think that they made it like that because of performance reasons…but unfortunately there are nearly no information about that on the internet :slight_smile: (so you will have to wait till you get an answer from epic games)

I found solution, I had same problem before. Try to open Project Settings > Rendering > And press uncheck Bloom and check it again (re-enable) after that restart editor, that helped to me. This info if someone will had same problem.

If you want the emissive material to actually cast light into the world you must be running the 4.6 or newer build of the engine.

Make sure your material setup has the **Emissive **port going into a Multiply which has A as a 3Vector (Color) and the B as a 1Vector (Intensity) - Make your intensity something like 10 or higher, i would recommend creating an instance and parametizing the Vectors for easier adjustment.

Also make sure that in your Material properties you have Emissive (Dynamic Area Light) checked.

The last thing to do is select your Mesh and under it’s properties go to Lighting > Lightmass Settings and check Use Emissive for Static Lighting and make sure your mesh is set to the default transform mode of Static under the Transform tab of the mesh properties.

Now build your lighting and once it’s built click the tab in the top of the view port that says Lit and change it to** Lighting Only** then back to Lit, your Emissive material lighting should now be there - Once you do this for the first time you do not have to go back and change the lighting mode from Lit to Lighting only again.