Unable to connect to listen server if GameMode is specified in url

How to reproduce:

  1. Create MultiplayerShootout project (so you don’t have to set up networking)
  2. Go to MyGameInstance and open HostGameEvent
  3. Specify gamemode in the Options parameter of Open Level node (e.g. “listen&game=/Game/Blueprints/MyGameMode.MyGameMode_C”)
  4. Package, create a server and try to connect to it

Hey Женёq,

Thanks for the report! In theory that should work, but I was able to reproduce an inability for clients to connect to the server with that Options string. I’ve created a bug report for the issue (UE-23787), and I’ll let you know if I see any updates on it.