Unable to build debug editor

I’m getting these errors from the linker when I try to built Debug Editor.

error LNK2001: unresolved external symbol "void __cdecl operator delete(void *,unsigned __int64)" (??3@YAXPEAX_K@Z)


error LNK2001: unresolved external symbol "void __cdecl `eh vector destructor iterator'(void *,unsigned __int64,unsigned __int64,void (__cdecl*)(void *))" (??_M@YAXPEAX_K1P6AX0@Z@Z)


unresolved external symbol __std_terminate

I have no Idea what this is all about. Any ideas?

Well, now I can’t build my project at all… HELP!

Hello JoSilver,

I have a few questions for you:

  1. What version of Visual Studio or XCode are you using?
  2. Are you using a Binary (from the launcher) version of the editor or one built from source code?
  3. Is this a project converted from a previous version of the engine?
  4. Can you try to see if this same issue occurs with a brand new project?
  5. Have you been able to launch in debug in the past?

UHG… I feel like an idiot.

When I installed visual Studio 2015 It never created a shortcut on my desktop so I was opening 2013 and building my project in it rather than 2015.

Well Time to uninstall 2013.

Thank you for the rather speedy response but unfortunately I solved the problem. I feel like a big old dummy. After I rebuilt the project in 2015 everything was working again.

The editor should default to building a project for 2015 in 4.10. Have you tried opening the .sln directly from windows explorer by navigating to the project’s location?

As I mentioned I’ve been opening 2013 from a desktop shortcut, Once I realized what I’ve been doing I made a shortcut to 2015.