Unable to add Landscape actor to project

Hi all,

I am working on a test project with mobile settings.
I’ve turned Mobile HDR off if that could be any concern.

The issue that remains is that I added a new level to the project.
To this level i am wanting to add a landscape actor.
On creating new nothing renders as visible.
I don’t know any settings that could get it back.

I tried to start a new project and was able to successfully add and mod the landscape, but not to this project.
Can anyone help me with what i could have done wrong or can change to bring in the landscape.

P.S : Also attached the screenshot of editor and settings.


– bump –

Please anyone on this