Download

Unable to Access Gear VR in Blueprint Nodes

Has anyone had success in access the nodes mentioned here:
https://developer3.oculus.com/documentation/game-engines/latest/concepts/unreal-blueprints/

and here:
https://docs.unrealengine.com/latest/INT/BlueprintAPI/GearVR/index.html

I disabled and re-enabled the Gear VR Virtual Reality plugin in both 4.14 and 4.15 Preview 2 but still do not see the Gear VR nodes available in Blueprints.

I saw that too. It is weird that both oculus and unreal give reference to it when it doesn’t seem to be in the latest version (4.15 preview 2). None of the nodes show up and my gear vr plugin was always checked on. On the oculus page it also refers to a gear vr class blueprint. Maybe it is something for the future, but then again i don’t know why they would both have it up now if that is the case.

It’s probably only available in the latest mobile SDK in the Oculus branch - the Epic SDK version is always behind. See: https://developer3.oculus.com/documentation/game-engines/latest/concepts/unreal-engine/

Which means UE 4.14 uses 1.0.3 and those nodes should be available.

Bumping this thread. I also want to know why these blueprint nodes are supposedly there but nowhere to be found!

I’m also having this same issue. Just updated to 4.14 from 4.13. The blueprint notes we were using for Gear VR are not being found while working in the engine, although the code definitions still exist in the source code. Still investigating…

Hi all. This information is passed along from another developer.

Cheers

Tried it with 4.14.3 - UE4 can’t load Gear VR plugin after that.

I’m guessing it can only be done in the source version of the engine not the binary version - did you try source? (I’ve not tried it in either yet)

No, I haven’t :confused:

Yeah any engine code modification means doing it in source as the engine needs to be recompiled then. Real pity this was not fixed in 4.15 binary? Or was it?

If I find time to build the source, I’d just go with Oculus branch since it has everything up to date for Gear VR :slight_smile:

GearVR specific BP nodes ARE present in UE 4.15.1 binary (launcher) version! Hoorah!