Download

UMG Inventory Tutorial by Epic problem/s

Hello,

Engine Version I used: 4.8.3, 4.9.0
I am reffering to this tutorial: A new, community-hosted Unreal Engine Wiki - Announcements and Releases - Unreal Engine ForumsUI-_Inventory_Tutorial_Playlist

I am adjusting it to third person and have encountered the following problems:

  • if the pickuptext code is called too many times it will eventually not show the text any more
  • If the character gets close to the object and make a turn around rotation with the mouse, the text disappears and it will never appear again
  • The pickup text displays for a split second elsewhere than the intended position where is adjusts after that split second

Important note:
For the above I have added a print string on my sphere trigger blueprint to see if the collision stops working but as it seems the collision is working but something weird is going on with the pickuptext which stops showing after being called many times.
May I add that with the following blueprint(see pic below) I got to extend the life of pickuptext when you call it many times, but eventually it fails too. In the video there was **one **pickuptext widget node which had 2 wires, one going to “add to viewport” and the other one to “remove from parent”.
8947beace0ebe55b2761bc8b898e24db3c27182a.png

Also note that:
In version 4.8.3 and in 4.9.0 on the sphere details tab, in order to display the text you must go to “collision enabled” and in the drop down menu choose “No physics collision”(or query for 4.9.0) as by default it has no collision. I was trying to figure out 2 days why my pickuptext was not displaying…
In the video it has “No physics collision” by default so many users who are watching it may encounter the same problem

If you need images showing the problems I listed, let me know

Would be glad if you could post how to fix the above problems

Hello Innos,

We apologize for the fact that you’ve encountered some hiccups in the tutorial. I will try to do my best to help clear up some of the issues and offer up some suggestions.

Regarding the displaying of the text over the pickups, the method provided in the video is a little outdated actually and is based off Nick D’s setup here:

While it works, as you can see it is not without is problems. Doing this over, I would suggest using a Widget Component to handle the pickup text.

  1. In your Pickup Blueprints, add a new Widget Component and call it something.

1.png

  1. In the Details panel for the Widget Component, set it to Screen space, select the PickupText as the Widget Class, and adjust the Draw Size and Pivot as you see fit.

eec1ca4e4ceb284b6125224ee7242ae50d2a6f0b.png

  1. In the PickupText Widget Blueprint, create a new property of the ESlate Visibility type and set it to hidden by default. (This will help with the popping of the text into position).

Since we are using a Widget Component, we won’t need to “add it to the viewport” anymore. All of the script connected to the Event Construct and Event Tick can be removed as well. We will just turn on/off this visibility setting to display or hide it.

  1. On the Designer tab for the PickupText Widget Blueprint, select the Text (which I called DisplayText) and make the following adjustments.

Set it to Fill and center it up (along with justified center), then set its Visibility to Hidden by default and Bind it to the ESlate Visibility variable you created.

  1. Back in the Pickup Blueprint, drag the Widget Component into the graph, drag off it and Get User Widget Object and cast to PickupText upon Event Begin Play.

This will replace the previous Create Widget Blueprint Script but should still populate the PickupTextWidget variable and Pickup Text as shown above.

  1. Finally, for the trigger script, instead of adding/removing the widget… turn on/off the ESlate Visibility property.

Setting it up in this manner should address your 2nd and 3rd bullet points (popping into place and disappearing when turning around). I’m not quite sure why the text is disappearing after triggering it multiple times. I’m curious to see if it still occurs if you try the method above. I’m currently unable to reproduce this but will recreate this using the 3rd Person Blueprint Template to see if it occurs there.

Please let me know if you continue to have issues with this or if you need more clarification (I can post a video of the setup as well and will add an note to the existing tutorial).

Thanks!

-W

That totally fixed all the problems I was having!

Thanks Epic for being so awesome!

Good to hear! We will work on getting an annotation to the video to point users to this thread for an updated fix as well!

Thanks for bringing it to our attention!

-W

Hi,
I’m trying to follow the mentioned tutorial, but I’ve got an issue : the Pickup text doesn’t pop up when playing, and I can’t pick up the item.
I’ve checked my different blueprints and all is similar to the video tutorial (except some adjustments due to the 4.9.1 I’m using).
Also I juste take note of this thread, but it doesn’t work better with.
I’ve got an error in the message log when going in/out the trigger volume :

00c587a31bdc94cf5f94619c4fe8c4bcd7397b08.jpeg

Looks like the variable is inaccessible or something like this, but could this block all the pickup mechanism ?

Any idea how to correct this ?
Thanks a lot.

Hello,

Seems like your pickuptext widget doesn’t get updated
Have you done this?
e682f414a35254a26b6786d733bd3833424232b2.png

Hi,
yep I did, here is the blueprint part :

Ooookay, I missed to set the WidgetClass of the DisplayPickupText to “PickupText”.
Thanks for the help, though :slight_smile:

Dammit, I don’t understand. It worked well, and as I progress through the tutorial (duplicate the can pickup and add the fire effect when dropped to the new pickup), the PickupText doesn’t pop up anymore.
And this time, no error message ! I didn’t change anything to my previously created Can Pickup and don’t figure if there’s a conflict or so since I duplicated it. I deleted the new one and all his references, but the text stays invisible :confused:

Any idea ?

Try to double check everything you’ve done with the pickup text, something must be missing for sure.

Well I’ve just redo all the PickUp stuff, and i’ts always the same issue.
I think the problem comes from the trigger not activating for some obvious reason…I’ve made a customized Object Type to ignore projectiles, I probably missed up something in there. Which responses should I Ignore/Overlap/Block in there ?

Okay. Here it was.
The collision presets of my FirstPersonCharacter were false, set to Custom instead of Pawn.
Now it works much better :slight_smile: Sorry for spamming problems I resolve so fast ! I’ll try to be more persevering next time before posting.

Glad you solved it :slight_smile:

Hi, all! People help me please! Third day can’t find problem in my BP which i create like in this inventory tutorials. I press E to pickup item and it’s don’t appear in my inventory. I test - place 6 items in scene and collect all of them. And my inventory is full and i see a message on screen. Can anyone help me? (Unreal Version 4.11.0)

same problem please help with inventory system tutorial - Blueprint Visual Scripting - Unreal Engine Forums

Hello Tetsuya,

I’m not quite sure why you are getting this result. I do know that this tutorial series is outdated as UMG has undergone several changes since this was first released over a year ago. I plan to update this series in a couple weeks after GDC to implement the drag-and-drop method that was demonstrated during our Twitch Stream and this project will be updated on the Learn Tab as well. Thank you for your understanding and I will get to this as soon as I can.

-W

In relation to your 2nd problem - in the CanPickup BP - details - transform - change the mobility from static to movable. Your Can should now drop at the DropLocation point

i have same problem with you… (+ third day can’t find problem. me too…ㅜ_ㅜ) do you solve this problem?? help me plz… this tuto is so hard for beginer. i think more than 50th issue fix by update or someting mistake…

I agree. I’m a beginner trying to follow this as well and I’m completely lost. I can’t figure out how to get the first “Set Pickup Text Widget,” which is between the Cast to PickupText and Set PickupText and Target nodes, to show up at all. I’m kind of at a loss.

Same problem. Is there any sort of a reference on how to implement SET to take on both “Pickup Text” and “Target?” Also with the Set member in inventoryStructure I have having the same issue. Am I missing something? Well, apparently so… -_-