Download

UMG Image Alpha Not Working

I am busy creating the UI for my project and I am having some issues with the Alpha on an Image in UMG. I have tried to use both PNG and TGA and it is just not displaying correctly.

This is what the Image looks like in my Image Editor:

This is what it looks like in game:
7100922e360128e25a717542d14d40d135009a09.jpeg

This is what it looks like in the editor:
4ba58204c2b331dd43ea0aa58c1298fc2f20a221.png

I am not sure if this is the dreaded Alpha from GiMP issue that I come across all the time. If it is, can anyone suggest a decent Image Editor that I can use that doesn’t cost an arm and a leg. I am in South Africa … the Dollar/Pound exchange rate is pretty intense for us.

Any help or guidance will be greatly appreciated.

Thanks

Okay I solved this … used a 15 day trial of Nuke to export the image … problem is solved. sigh Guess my entire Christmas bonus is going to buying this tool now … just for TGAs to work properly with Alphas. 8-{

Here is the result:

Did you try some other free tools first? Nuke is nice for all kind of stuff, but if you just want to export images it seems like it’s worth it to first try other options if your budget is tight. For example Paint.net is quite good. Although I haven’t used it with UE4 so I don’t know how it handles alpha.

@Arnage: You sir are a gentleman and a scholar … thank you very much for your suggestion, it worked like a charm. This community rocks. 8-}

Here is the menu using the image save from Paint.NET … as a thank you to them, I will be donating some of the money for Nuke to their worthy cause after PayDay.

Thank you, thank you, thank you. 8-}

Wait, in other thread you said problem was with photoshop. So it is photoshop or gimp?

GIMP Exports Alpha Channels in a different format. I used to have this issue years ago when I used it. If you open a GIMP export in a viewer like XnView, you’ll notice weird Alpha artefacts.

For the best results, use .TGA and Export from Photoshop as 32-Bit.

Just to add to TheJamsh’s comment, I have found that grey-scale PNG’s with alpha from Photoshop do not import properly into UE4. Convert them to an RGB color space before your UE4 import.