UMG crash after exiting PIE

Hey,
I have a UMG HUD that gets added and removed (like in the docs page) OnBeginPlay and OnEndPlay. Everytime I exit the PIE (both own window and editor viewport) the engine crashes.
Any idea why? I’ve read that it’d crash if I switched levels, but I’m not doing anything like that.

Hi Schlechtwetterfront,

Which version of the editor are you using? Have you been able to reproduce this in a clean project with no additional content? Thank you!

The version is 4.4.2 built from source (using the Wwise integration code and 4.4.1 dependencies).
I’ll try to replicate it when I’m back home on Sunday evening/Monday.

So, I created a new project from the FP Code template, no crash (I can’t test the exact same BP because it has some binds). I did test the BP without binds and functions in the original though, which still causes a crash. Actually it seems any type of UMG BP causes a crash.

Depending on if I remove the widget or not I will either get a report of the RemoveFromViewport function or a brush still being referenced in PIE.

Do you still have a reference in your level to the widget anywhere or have all widgets been removed and all references to the widget in your blueprints been removed? Additionally, if you have streamed levels are you calling your widget in any level other than the persistent?

The widget gets created/added and removed in the Character blueprint (I don’t have any bots or multiplayer in my testing sessions so there shouldn’t be more than one?). I’m using Sanctuary from ShooterGame (which my project is also based on in terms of code and some assets) as the testing level.
I have a variable I store the UserWidget in but I just tested without that variable and it still crashes.

:If you are comfortable with it, can you post a link to your project so I can take a look? If I can see what is occurring I might be able to see what is causing the crash. Additionally, can you post your logs and callstack from the crash here?

Log, callstack included. The project uses the UE4 Wwise integration, but I guess you have access to that, too and stuff. I’ll see how I can make it accessible in the easiest way to you.

Project zip (removed the link, tell me if you need it again).

Does the project have any problems when you are not using the wwise plugin?

Hi Schlechtwetterfront,

Did this project work on a previous build?

Well, Wwise is sadly directly integrated into the engine, not a plugin, so we can’t easily test without changing source code (we also didn’t think that we’d change back a lot so we didn’t do any #ifdef stuff).

The project worked fine (it seems so atleast) on any build until now. I of course couldn’t test out UMG before so I have no data for that.
I did test on the same build of the engine (with Wwise) on a clean project (from one of the templates) and had no crash.

I just tested with a clean ShooterGame on my engine build, it has the same crash, so it must be something to do with the ShooterGame code? We’re using that as a base.
ShooterGame has a “custom” Viewport class so maybe the fault lies there.

Hi Schlechtwetterfront,

The engine build you use, did that have wwise implemented? If so can you try shootergame on an engine build without wwise?

Yes it had Wwise implemented.
I tested it on the precompiled version of UE 4.4.2 and the 4.4 ShooterGame now. I also get a crash. Here’s the Callstack: http://pastebin.com/xEv2HC72

Hi Schlechtwetterfront,

Unfortunately we tried on our source build as well as the standard launcher build on both viewport and standalone games to get this crash without any success. Try re-installing the github without wwise and re-installing a fresh copy of shootergame and see if you get the same crash. It may also be beneficial to contact Audio Kinetic to discuss a possible error with their plugin.

Weird. I have a fresh installation of UE 4.4.2 (downloaded from the UE Launcher) and a fresh installation of ShooterGame 4.4.

  1. Enabled UMG.
  2. Created Widget BP.
  3. Drop a few UMG items into the Widget BP.
  4. Add the Add to Viewport/Remove from Viewport logic to player pawn.
  5. Start PIE.
  6. Close PIE.
  7. Crash.

What specific UMG items are you adding to the widget? Also which widget bp are you using when you create them. Make sure you are specifically going to new>User Interface>Widget BP. There is a second selection that is broken and not useful (it will appear right as you open the “New” category in content browser).

I’m using New>User Interface>Widget BP.
The latest test was the default Widget BP (Canvas Panel is the root I think) and either buttons or circular throbbers just drag&dropped onto the designer viewport…