Ugly dark shadows on character model, Skylight doesn't work

Is this just a mesh issue, a material issue ( a lot of the texturing doesn’t come through on the face as intended) or is this an engine issue. I’m making a PS2 type game but it seems UE4 is unable to properly recreate this look without unnecessary amounts of effort. I can’t get the Skylight to work unless I put in a Directional Light but that makes everything ugly. What do I do?


The Sky Light captures the distant parts of your level and applies that to the scene as a light. That means the sky’s appearance and its lighting/reflections will match, even if your sky is coming from atmosphere, or layered clouds on top of a skybox, or distant mountains. You can also manually specify a cubemap to use.

Sky Light | Unreal Engine Documentation

Skylights usually only work when there is a skysphere or HDRI backdrop in the level. It says here that you can try a manual cubemap as well. Do you have a skysphere in your level?

No because whenever I added it the only lighting that would be affected would be outside of the interior scene

Did you set the sky sphere to not cast shadows and have the material be two sided?

No option for that, I’m using the BP_Sky_Sphere blueprint as that’s all that comes up

Did you set the DirectionalLight intensity to something like 20 or 50 lux? Additionally, you can find the “Cast Shadows” checkbox in the blueprint itself.

By default, It should be disabled. If not, disable that.

It should look like this

If that doesn’t work, try adding a SkyAtmosphere to the scene.

Oh yeah, don’t forget to scroll down and click on Recapture on the details panel on the SkyLight, Screenshots will be greatly apricated if possible

Top one is with the directional light as you said
Bottom one is with the SkyAtmosphere (does nothing)
Recaptured scene and see no changes. I don’t see what the problem is and why it’s so hard to get nice lighting on the characters face. I just want to shadows to be much softer and smoother instead of being pitch black because nobodies face looks like that ever.

Well my second best option is to lower the shadow amount value on the Directional Light. Other than that, I’m lost.