UE5P2 - r.ScreenPercentage not working for me

Hello guys,

As stated in the title, the command r.ScreenPercentage isn’t working for me anymore in UE5 P2. And i repeat “for me” because, as you can see in this video from a member of the UE community discord, it’s working fine for him :

I’m using TSR and a cine camera but tested with TAA, FXAA and a regular camera.

What’s weird is that in UE5 P1 and UE4 it was fine.



Yeah, I’m getting the exact same thing - so you’re not alone.
Will do some more digging and report back if I find anything.

Failing that, we should probably revert back to Early Access 2 or Preview 1.

OK, for now I’ve found that running the game in ‘Standalone Game’ mode will apply the screenpercentage settings correctly.

There must be some in-editor veiwport setting changes that are overriding these console variables when playing in editor.

Hopefully it gets fixed for the full UE5 release.



With some more digging I also found that it worked in standalone mode.
Very weird nonetheless that the editor doesn’t recognize the command.

Thanks for your reply.

1 Like

Editor Settings → Performance → Viewport Resolution → Override game screen percentage settings with editor settings in PIE.

This is enabled by default intentionally that you don’t accidentally run out of GPU memory and loosing unsaved editor work if the game settings’s screen percentage are configured wrongly.


Hey everyone,

I struggle with the same issue, so please allow me to quickly c&p my post from another thread regarding the screen percentage topic. Cheers!

“I noticed the same issue with r.screenpercentage in Unreal 5 as well. I know it’s not an ideal solution for super sampling, but used to be quite useful for recording high res videos. I can set it up via the viewport in the editor, but the console command doesn’t work for me as well (works in UE5 preview build and UE4 builds, though) - plus it’s not showing up as an option/feature in the PP volume.”

Thanks for any help there!

/Edit: Unfortunately, changing PIE settings in the editor didn’t help regarding console command response or setting it up for recording.


The official release of UE5 fixed the problem, now everything is working fine.

This still does not work in the official UE5 release for me :confused:

Same, it’s not working for me on 5.0.1

In case none of this methods work, check this other post, AMD FSR 1.0 for Unreal Engine 5 - (AMD FidelityFX Super Resolution) - #9 by lucoiso, here the user lucoiso links to a github page with a compiled plugin of AMD FSR for UE5 (a plugin for rendering at lower resolutions and upscaling the screen), it can give you extra performance and is GPU vendor independant , a guide can be found here How to use AMD FidelityFX Super Resolution (FSR) 1.0 Unreal Engine 4 Plugin - GPUOpen , or try DLSS if you own nvidia hardware and if it’s UE5 compatible.

For TSR (r.TSR.History.ScreenPercentage 50) does work

I manage to make it work by disabling TAA upscaling (r.TemporalAA.Upsampling 0) and by then using (r.ScreenPercentage), also tried the previous method, so I’m not sure if it influenced the outcome.

UE5 uses some AutoScreenPercentage,
you can try changing it in your Project Settings:
Project Settings > Editor - Performance > Viewport Resolution,
change it to Manual and adjust your ScreenPercentage and Minimum Resolution.

Or try these values, they worked on my Project:
r.Editor.Viewport.OverridePIEScreenPercentage 0
after that you can use r.Screenpercentage again in your Playtest.

Hope this somehow helps.


Hi Guys,

we have improved the editor UI in 5.3 to help diagnostic rendering resolution and where it is set from in editor viewports and PIE:

Anyfeed back apreciated!

Looks awesome to me. It would be cool(as an option) if we could set the resolution to an exact pixel count like 1920x1080 instead . If would benefit more accurate performance monitoring during environment building.

Even if I put the editor in fullscreen, it’s still not the full resolution because it takes into about the Windows OS taskbar. (Please don’t respond with an indefinite loop hole/workaround for that one lol)

Also, a check box showing play in editor screen percentage is being overridden by same screen percentage shown inside the pop-up window. It’s more convenient than editor settings.

Also, I sent you a private DM. Please check it, or atleast give it a like so I know you read it.