UE5 World Partition can not delete landscape

Well, the bug is still there.

Anyone from Epic themselves can address this thread??? It seems we have a system that writes files to the HD and autoloads them but then cannot be deleted from within the editor and ALSO encrypts them with unreadable filenames so they also can not be deleted manually!

What a great idea…

Ok I did manage to remove them eventually - but be warned it takes a LONG time. I quit the editor a few times thinking it had crashed as there’s no feedback - but on loading the level back in I noticed pieces of the terrain were no longer loading in. So I guess it does work but my god it’s slow…

Probably not going to happen if you didn’t submit an official bug report.

You have to highlight the landscape, along with every single streaming proxy related to it. Only then will you be able to right click on it, select Edit, and then Delete it.
Hopefully they’ll fix it one day.

You have to highlight the landscape, along with every single streaming proxy related to it.
Only then will you be able to right click on it, select Edit, and then Delete it.
Hopefully they’ll fix it one day.

Turn of “enable streaming” in world partition and delete

I’ve tried this, but it still will not delete my landscape :frowning:

You have to highlight and delete all of the streaming proxies related to the landscape first. Only then can you can delete the landscape itself.
(I know; it’s retarded. :laughing:)
Hopefully they’ll fix that one day.

1 Like

I just solved this problem.
Even if it was deleted twice and reopened, the Landscape was still there.
The name of Landscape was then changed from Landscape 2 to Landscape, which was resolved.
Afterwards, it was deleted and did not come back to life.

Go to the outliner, select the landscape object you want to delete, select all the child components in the dropdown (if some can’t be selected just pin them), delete all the components/chunks in the dropdown, you should now be able to delete the main landscape component

This is correct. Thank you

Hi There, Happy new year to everyone
In my case it get gray out after I deleted them, now none of method above’s worked,
so if I deleted the entire map and create a new one, does some temp or trash remained file and node relevant to this broken landscape patches still remain in my project?
How to clear them from hard in that case?

Firstly load them by holding LMB in “World Partitioning” and select all cells, then right click and choose Load Selected Cells, see this post: World Partition Cells not unloading properly - #5 by L.F.A

Hello, to those who are having this issue, including myself. The path to the assets most likely responsible for the issue are ghost assets, as in they don’t exist in the filepath dictated by the engine. Which is most likely why this issue is causing so much trouble to fix.

D:/Unreal Engine 5/UE_5.1/Engine/Content/ExternalActors/Maps/Templates/OpenWorld/0/IT/MHSUN7EJKDAAL8CVT31B9U.uasset

D:/Unreal Engine 5/UE_5.1/Engine/Content/ExternalActors/Maps/Templates/OpenWorld/0/CC/WDYA7H76HHF9UENRUYXBJA.uasset

So my guess is the issue lies somewhere within this problem, but I’m only theorizing. Please Epic Games, get this bug fixed. Its unbelievably annoying, particularly now since the above solution no longer works for 5.1

I landed here recently, so just for future inquiries, here’s my take on this (Blank, C++ project):

  1. I created a new Landscape, then
  2. I set it, that second Landscape, as project’s default, then
  3. I deleted all children of the old default Landscape, and finaly
  4. I was able to delete the old Landscape member itself
    Hope that helps

Except delete is greyed out.

You need to load every singe region first.

This looks like lazy developers didn’t even care on including enough functionality so the landscape can be handled properly.

2 Likes

I wanted to confirm if people are having the same issue I have importing a heightmap over the open world default landscape layer?

UE 4.27 importing the same heightmap.

Similar issue, but my landscape has been deleted everywhere and I only know it still exists because the level is still reportedly drawing the triangles. Fun Fun. Can’t wait to rebuild all of this logic on a new map. For as much as they talk about “making things easy so creators can create,” they skip all the stuff that actually matters, like game breaking bugs like this …or say documentation, but whatever. Just add this to the pile of delays my company has to pay for, but hey, can I interest you in a lifetime, experimental feature?

1 Like