UE5 Projects Not Showing

I also encountered this problem. My solution is to create a UE4 project in the same directory. At this time, Epiclauncher will recognize this project, and then you create your UE5 project in this directory. At this time, the UE5 project will be displayed in Epiclauncher is in. It may be delayed by a few seconds

2 Likes

Yeah, got this problem as well, can manually find and launch the *.uproject files though.

EDIT: OK, made a brand new ue4.26 project in my ue5 projects folder, and all my previous ue5 projects have now shown up in the epic games launcher, and even the ue5 project selector as well, neat.
I wonder why this is a fix. Thank you LingHyun

1 Like

Exiting and restarting the launcher worked for me.

Had this problem, opened the project by launching the Engine and after a restart it was displayed in Epic launcher.

I’m not too sure, it’s a bit like specifying a folder for your UE project.

Right. I haven’t encountered an issue there though. I guess because I have my UE5 projects in the same folder as my UE4 projects. No doubt it is an issue that will be ironed out in an update.

I was able to find a fix that worked for me:

  1. Create a blank UE4 project and call it “DeleteMe” in the same folder with your UE5 Projects
  2. Open up UE5 and all your projects will be there
  3. Close UE5 and Delete the temp project
  4. Re-open UE5 and everything works

worked for me anyway
hope this helps

1 Like

Here’s the solution, UE4/5 projects show in launcher and in add content menu.

15 Likes

Hi,

Create a temp Unreal 4 project to delete right a way.
or
Restart the Epic Launcher (little annoying is need to enter again the email and password)

Both take just few seconds and force the Epic Launcher to refresh the projects list.

Not a huge problem, Epic will obviously fix that in the next iteration of the Launcher.

Thanks mate, this fixed it for me.

1 Like

Thanks will worked perfectly. There are also so other interesting paths you can cleanup and organize there.
Make sure to properly shutdown Epic Games Launcher first.

Just posting to confirm that I have experienced the same or similar bug. UE5 projects do not show up in the launcher OR “recent” projects dialogue box when opening UE5 direct. Can open the UE5 project manually.

Also note that even when UE5 shows in the launcher or dialogue box, this does not guarantee it will stay there. On some occasions I have reopened the launcher or UE5 only to find the UE5 project has disappeared and has to be manually opened again.

Have noted the work around suggested in this thread so will try it.

Oops. I thought my reply didn’t get nested.

This worked. Make sure you quit EGL from your system tray completely before editing, and put the folder above the one that has your project file in it.

1 Like

Mannn thanks a lot that worked for me, I changed my unreal project backup path by making a folder in it and saving it. I corrected it and it’s working fine.

1 Like

Worked for me.

I had the same problem when I relocated my Dev folder to a new drive. I couldn’t understand why those projects in the Dev folder I relocated no longer showed up in the Launcher under My Projects. The solution was just to make another Unreal Engine 5 project in the same Dev folder as my other projects and once I exited the new project, all my other projects reappeared.

1 Like

I had the same problem when I relocated my Dev folder to a new drive. I couldn’t understand why those projects in the Dev folder I relocated no longer showed up in the Launcher under My Projects. The solution was just to make another Unreal Engine 5 project in the same Dev folder as my other projects and once I exited the new project, all my other projects reappeared.

Just to say I had the same issue, the above way of editing the GameUserSettings.ini didn’t work for me, but this method did. Thanks!

This is the solution because “CreatedProjectPaths” tells the launcher what folder to look for your projects in.

Also, need to remember to navigate to that folder in Windows Explorer to Click “View” and put checkmark in “Hidden items” otherwise you won’t see the hidden folders.

And remember to uncheck “Hidden items” when you’re done editing and saving the GameUserSettings.ini file.

There really should be an option to add a list of folders to look for projects in then this problem wouldn’t exist.

I have the same issue and no matter what i write unt the GameUserSettings, the projects are still missing, i’ve tried to create a new preject in any unreal version but they also don’t show up.

On the left side of the engine launch button click on the drop-down button → Options → Enable ‘Templates &Features’ → Apply

Done.