UE5 mirror material is blurry

Hello, i’m new to UE5, and so I was trying to create a mirror, based on tutorials (watched at least 6 of them telling the same thing) it did work for them, doesn’t for me. The picture taken is from the very basic Third person world, only made the mirror. In the mirror the third person mannequin can’t be seen either. Also get a crash 10 out of 10 times when try to build all levels but thats for another question.

The mirror itself doesn’t actually (necessarily) capture the scene around it, something else needs to do that. There are three ways to do this:

  1. Place a Sphere Reflection Capture right in front/center of the mirrror.
  2. Place a Planar Reflection right in the plane of the mirror.
  3. Turn on ray tracing.

If you already have a sphere capture, then turning up the resolution in settings will make the quality better. (There’s some cost associated of course.)

Hello, thank you for your answer, but the problem is still present. I tried all three methods and all of them looked exactly the same, as if they didn’t even change on it. I am a new user so for some reason i can only add 1 picture per post, so here is with planar reflection enabled and placed in front of the mirror. If I look at the mirror from the very side of it, it is more clear than from the front but still not good either.

ray tracing is on, resolution is on epic, tried sphere reflection capture as well, looked exactly like with planar.

Have you tried playing with the reflection settings in your post-process volume? There are lots of different options in there

As far as I know you cannot get high quality mirror reflections with Lumen. You can get much better quality reflections if you enable hardware raytracing with Lumen, but you can’t get high quality mirror reflections.

Hopefully this will be improved in the future, but that is simply seems to be the reality right now. If you need high quality mirror reflections, your only real option is to use Lightmass (instead of Lumen) with raytraced reflections or planar reflections.

1 Like

You can only get high quality mirror reflections with Hardware Raytracing enabled in Lumen, especially with the more expensive “Hit Lighting” mode. Software RT traces the reflection against global distance fields which look pretty blobby in mirror reflections.

Increasing distance field resolution can help to some extent. But without a raytracing capable GPU, there’s not much that can be done.
Left: Software RT against Global DF
Middle: Hardware RT Lumen against Mesh DF (“Surface Cache”)
Right: Hardware RT Lumen Against the actual material (“Hit Lighting”)

You can improve the result further by increasing the Lumen Scene Quality to 6 in the post process volume.

In general, anything that is lit directly will render cleanly in raytraced lumen reflections. Indirect lighting is where the quality falls down, even with the Lumen scene quality set to 6 (which I believe is the max)

Another big part of the problem is that raytracing currently doesn’t support Nanite, so the proxy geometry is what is rendered in the reflections which results in potentially quite a lot of detail loss.

The sphere pictured is entirely in indirect light. It is my understanding that Hardware Lumen RT supports GI in reflections. Non Lumen RT reflections, however, do not support GI so indirectly lit scenes look bad. In all examples, Lumen settings were at default quality with nanite enabled.

Here’s an example with both direct and indirect lit spheres.
Left: Lumen Hardware RT Hit Light Reflection
Right: Standalone Hardware RT

It also is a scene with zero detail in strong indirect light. Here’s Lumen compared to the path tracer:

Note the extreme loss of detail in the walls, the sharp seam where screen traces switch to the Lumen Scene on the sphere, and the noise from the Lumen scene on the floor. (This is with Nanite’s fallback triangle count at 100% and 0% error)

Deprecated raytraced reflections DO render GI in reflections: Lightmass GI. Which is why it was part of my recommendation.

Don’t get me wrong, I love Lumen, it’s incredible that we can get dynamic gi in reflections at all. I’m just saying that this is not what I would consider “high quality mirror reflections”… Passable quality in some use cases, yes.

My point is just that without hardware RT, lumen reflections look like blobs. One’s definition of high quality really depends on what you’re comparing it to. A pathtracer? Yeah I guess not. SSR, Cubemaps, or Software Lumen? Hell yes.

But hopefully it’ll continue to improve. We’ve come a long way compared to EA 1.

Planar reflections being a conspicuous omission from this list :stuck_out_tongue: But yes, like I said, acceptable quality in some use cases.

On the topic of planar reflections though, it appears that if you’re willing to pay the (steep) performance cost you actually can get Lumen to render in planar reflections and scene captures as generously explained by a user here.


You know, I was actually looking for a way to get lumen working in scene captures the other day so I’m really glad you linked that. I’ve been experimenting with using fallback cubemaps within lumen to fake a second bounce and that was one of the biggest quality issues with my result.

1 Like

I am experiencing the same issue, however, what I find odd is that I can see reflections but only at very sharp angles. You would think that the reflections would either work or not work. I have no RT hardware.

The reason that angle looks good is because it can fully utilize screen tracing. Anything that can be seen in the scene can be reflected accurately. If the screen trace fails (such as needing to render geometry that isn’t on the screen), only then does it fall back to Raytracing (software RT against global distance fields for those without Hardware RT capabilities). It’s the software raytracing that looks blurry/blobby.

Hello, at the first go to project settings from Edit menu
1- Engine-> Rendering-> Global Illumination: sit on [Screen Space(Beta) ]
2- Engine-> Rendering-> Reflections: Support global plane for Planar Reflection: set On
3- Search [motion]: set Off
4- Make mirror material and search Reflection, set On: High quality Reflection & Planar Reflection
5- Put Planar Reflection in front of mirror,
6- Go details, set value of Normal Distortion Strength & Prefilter to [ 0 ]
7- Set value Screen Percentage to [100]
**Congratulation **
use link blow

1 Like

Hello, the mirror reflection can you find over under: UE5 l Mirror Effect Material with Planar Reflection l Tutorial l Unreal Engine 5 - YouTube
I have another question about the reflection, but not the reflection of a mirror. I try to make a metal ball in a room. And the Reflection is not clean. I turn the Lighting Quality Lumens already of 20. It does not work. Does anyone kown, how can i make it better?

Without using hardware raytracing, it isn’t going to get much better than that. Software Lumen works by raytracing against a low quality representation of the scene, which is how it can manage raytracing on machines that don’t support hardware RT.

If you have post-processing, you need to change its global illumination’s setting as same as the rendering setting in your project setting. I had the same problem and used this method to fix it.