UE5 Lumen Light Leakage From Offscreen Geometry

There’s a note inside the UE5 Documentation for Lumen…

Lumen Technical Details

It reads:

Issues like this can be fixed by increasing the number of Cards used with Max Lumen Mesh Cards, but that may not solve all issues. Alternatively, breaking the mesh into less complex pieces can resolve these types of issues as well.

This is something I glossed over during my original reading of the topic. I put together a scene from existing assets and noticed at certain angles on these pillars I would get light bleeding as seen below.

No bleed at this angle, but at a more extreme one…

You can see the light on the pillar is bleeding out of the lips near the bottom. This is definitely because the mesh is large and complex and not in smaller modular form.

So upon a second reading I saw that and figured I should try their advice. So I made the pillar it’s own mesh.

Then I placed that pillar adjacent to the one with all the leakage and tried the same extreme angle.

Problem solved. So definitely a lesson learned for me, this is a big deal for accurate lighting and now I gotta rework the whole scene to see how it works with small modular pieces.

Definitely use the debug views and make sure you have good mesh distances fields with the assets broken up into piece with more simple shapes.

1 Like

I should have specified, I’m using hardware ray tracing. I don’t think hardware ray tracing uses Mesh Distance Fields? I was thinking it used traces against the actual triangles in the meshes instead. I hadn’t looked at the debug view “Surface Cache” before, it seems to show trouble areas in purple/pink.

It used the nanite fallback mesh or your highest LOD number in Preview 2. How does the pathtracer look on your scene?

@Braitenbug Path Tracing looks decent, although the denoiser wrecks the finer detail with the settings I have.