UE5 - Lumen difference between viewport and playmode

Hello everyone,

So we are working on a game since a while and we switched up to Unreal Engine 5 since the release (we were with 4.27 before).

We are trying to tweak our lighting with the Ultra Dynamic Sky and recently I figured out that when in playmode, the exposure/Lumen/Lighting is different. The screen is brighten by something in the play mode.

I turned off everything:

Post Processes (in the level and in the character)
All the lights, except one
Auto exposure in the project settings
Auto exposure anywhere it can be (post processes, cameras)

I am at the point where I really wonder if it could be that Lumen act differently in the viewport than in play mode base on some setting in the config.

Here’s some screenshot



Anyone has this issue before ?

Thank you!

1 Like

I found it will stay the same if you put a PP on the player camera, and set exposure compensation to zero.

Thank you so much for the fast answer!

Unfortunately, I tried with the basic player and our custom player, with a post process set to exposure 0 in the player blueprint, and the shadows are still brighter in the game than in the viewport.
image

I tried to deactivate everything within the player blueprint, removing all the post processes - except for one that has exposure turned off - and there was still a different calculation

1 Like

Try combining it with

image

Yes same thing, this is what I was talking about with turning off the exposure. I killed all the post processes - from the level and from the player - and placed only one PP in the level with exposure deactivated (as you shown) and it’s still giving different result

I’ll admit that its very subtle with one light. But the whole process is to achieve a similarity between the two so that I can work and estimate correctly the lighting I am doing in the world.

For the whole project, we’ll want to use eye adaptation (Auto exposure) but its hard to tweak it within the editor, when there is a difference in play mode. So in wondered that maybe Lumen is acting differently in the viewport - tried to make it screen percentage 200 (which give a result in quality, but that is not the solution) - and that when we hit play it calculate more, or wider. I don’t know…

But thank for your help, much appreciated!

The PP doesn’t work if it’s in the level, it has to be on the player camera ( at run time ). Do you have that?

( Usually, obviously PP works in the level. But not at the moment with exposure in UE5, for some reason ).

I think it getting closer and closer! Thank you!

So I turned off the exposure in the player camera
image

But now its darker in play mode

So PP does not work for the exposure in the level in UE5 ? Because it does work in our project for the auto-exposure - so I’m a little confused.

There’s something up with auto exposure at a project level, I’m not quite sure what.

You can’t set it with a PP in the level, and you can’t turn it off in the project settings.

This is the only way I’ve found so far.

This is a known problem and is scheduled to be fixed in 5.1, or it was last time I looked.

You should be able to fix the darkness by tweaking the exposure compensation ( in the player cam ).

:slight_smile:

2 Likes

So it is an issue of the version and not a project issue, this is reassuring, it will allow us to continue working and expect a change in the next version of the engine!

Can’t wait for the release of 5.1 then :smiley: I’ll try to work with it until then. Thank you very much for your help :slight_smile:

Should I mark it as resolved ? (Because technically it is not, but we can’t fixed it)

1 Like

Hey so, I think I found out the issue.

I think the culprit is the raytracing that act differently in the game.
image

Hope it might help someone, I’m not at the point where I understand completely the issue, but I’ll this trace here just in case :slight_smile:

2 Likes

So now it’s ok, even with auto exposure running? :slight_smile:

1 Like

Yes, its way better without raytracing. Might be an issue when both are enabled.

Anyway, thank you very much for your time sir!

1 Like