Ue5 jittery/choppy mouse camera input during movement (Default ThirdPersonCharacterBP)

Jittery camera input while moving in unreal engine 5. I compared it to ue4 with a constant 60 fps capped, and no issue in ue4. Here is the video showcasing the lag in ue5
[ 2022-05-29 12-56-34.mkv on Vimeo ], the mouse camera input is smooth at an idle stance. As soon as the player character starts moving, the mouse camera input behaves erratically despite the smooth 60 locked frame rate. Here is an example of smooth mouse movement while idle/moving in ue4 [ 2022-05-29 12-57-00.mkv on Vimeo ] , the mouse camera movement remains smooth at both scenarios. Any ideas on what could be causing this ?

2 Likes

I have also observed the same issue…

I am not too sure why the behavior changed between ue4 and ue5, but I found an acceptable workAround.

Add a USpringArmComponent on top of your UCameraComponent and activate:

  • bEnableCameraLag
  • bEnableCameraRotationLag

It greatly reduces/eliminated the jittery camera behavior.

Hope this helps!

Hi, I was wondering if someone found a solution to this as I am also experiencing it ?

I’m using the first person camera with a spring arm and enable lag but still getting the jerky movement. Anyone got ideas?

Had the exact same experience. The only thing that seemed to fix it was playing in standalone or packaged version of the game. Otherwise, playing in editor just seems buggy.

I’m having the same problem. The weird thing is the lag disappears as soon as I press a random keyboard button. Can you guys also try this? Try moving in the game and press random keyboard button such as H or G key, and see if it’s still choppy? It will get better till you stop moving. At least this is my experience.

1 Like

I experience a very similar issue but only in 2 projects created with UE5 and using my own custom movement component. The stutter/lag is only barely noticeable and default character movement is not affected. Another project which uses the same custom movement but was created in UE4 and converted to UE5 is also unaffected.

For my situation, enabling Camera Lag Speed and Camera Rotation Lag Speed from the spring arm (Camera Boom) fixes it

This is quite strange, but it works for me as well, so yeah, looks like playing in the editor is still buggy :frowning:

P.S.
I’m using enhanced input systrem

1 Like

I updated to 5.1 that uses the enhanced input actions by defualt and now i’m experiencing this issue too in the editor. I don’t have the issue when it’s an older project that doesn’t implement that new feature.

1 Like

I can confirm that it’s a problem with enhanced input. It even appears in First Person template.

1 Like

Hello, i have this jittery choppy mouse/camera movement problem in almost every UE4 games, Hellblade… and today with High on Life trying to find the solution, please help.

Demonstration:https://youtu.be/I9rYuGLVKAw

I add to Input.ini of the game
[/Script/Engine.InputSettings]
bEnableCameraLag=1
bEnableCameraRotationLag=1
also try =True didnt help :frowning:

https://www.reddit.com/r/Wonderlands/comments/tna9be/anyone_else_having_mouse_stutter/?sort=new

The games would have to be coded to do this. and the variables are not available to ini.

This is a developer’s forum. Try a forum for the game themselves.

Thanks, will try. I think this is a similar problem.

https://imgur.com/a/JHHTwvI

I’m still having this weird problem. Here’s a video from my project. Anybody here found a solution yet?

You need to give more info.
What is the input device, how is the movement set up, etc.

As it stands, the issue could range from rotations looping between positive and negative values, or animations being choppy, or bad parenting of the camera… or really almost anything.

Test in a base project with the mannequin first. Change the character out bit by bit until you hit the problem.

The problem appears in virgin clean First Person template. Keyboard+mouse or Xbox controller, doesn’t matter. It also doesn’t appear if I switch camera controls to legacy input system, so the only solution I see at the moment is not to use Enhanced Input for camera movement.

Are you guys using the setting “Use Fixed Frame Rate” in the Project Settings? I have noticed this issue as well, however when I turn of the fixed framerate or make it a higher value the issue doesn’t seem to pop up.

Can anyone corroberate?

2 Likes

You can make a seperate camera actor that’s not a child of character then you could set camera actor location and rotation based of your character, make sure camera component tick is set to post physics and character movement is set to pre physics.

1 Like