[UE5] How To Fix UE5 "Dimming" Emissives in Daylight?


Noticed Emissive Dimming when moving into certain areas of the UE5 City Map in my speedster tech demo. Look closely at the Lightening Particles emissiveness dimming when moving between areas in daylight and illuminating in covered/shadowed (No Daylight).

Summary: Emissives glow properly areas without Daylight but, and are dimmed in the Areas with Daylight.

How To Fix UE5 “Dimming” Emissives in Daylight?

Emmisives do work in Daylight on other maps:

I’m hoping theres a simple postprocess change needed. Any and all assistance is appreciated. Thanks in advance.

Looks like bloom is the problem, not the emissive. I would try messing with the bloom settings in the post process volume and compare them between the two projects.

1 Like

Thank You @BananableOffense I appreciate the prompt response. I will give a try and post my results.

This is due to the exposure change, when you go into a dark area the exposure drops but the emissive output stays the same, so it is now relatively brighter than the surroundings and the bloom kicks in and lights it up.

In UE5 we now have the “EyeAdaptationInverse” node in the material graph that will keep the emissive consistent with the exposure. You’ll still see fading saturation at extreme exposures, so you’ll need to be careful of that.

2 Likes

Hi @Arkiras. I Truly Appreciate You. This is significant change if needed for all materials using emissive. I’ll modify the materials and ill figure out how to apply to Niagara Particles. I post my results.

SOLUTION:

RESULT:

1 Like