UE5 for M1 Apple Silicon

Hello Chris,
I can tell you that since UE5.0.2, Lumen and Nanite (quality is degraded on MacOS compares to Win10PRo) are ‘working’ on a MacPro 5.1 with an old RX580 AMD GPU booting on BigSur.
Performances are not as good as on Windows10Pro on the same machine but it works !
Same basic map with Lumen on and few Nanite meshes ->> BigSur : 23 fps vs Win10Pro : 38fps.
UE5.0.2 BigSur 11.6.4 MacPro 5.1 Xeon 12 cores 3.33Ghz AMD RX580


UE5.0.2 Windows 10 Pro MacPro 5.1 Xeon 12 cores 3.33Ghz AMD RX580

Lumen visualization feature works but the Nanite one doesn’t.
I can’t wait for UE5 to be nanively supported on Intel and Apple Silicon Macs !
Keep the good work you guys at Epic !

3 Likes

Wait. Nanite is working on Mac now? How has this not been announced somewhere? Has anyone tested it with billions of polys yet?

I was developing on Macs for 8 years. It’s just waste of time. They constantly change something. They change os, hardware, API. They are doing it on purpose. It means, that even if UE5 will follow full compatiblity - Apple will STILL change macOS API or sth, and UE5 will NOT follow.

Call Windows old, but they understand power of mature solutions.

6 Likes

Have you seen the new Metal 3 API Apple released? It has far better Ray Tracing features than before, could this possibly help Unreal Engine 5 to come to Apple Silicon?: Metal Overview - Apple Developer

2 Likes

As a “cherry on top” maybe. The editor doesn’t run natively on the ARM chips still, which would most probably come before extending the Apple-specific render target.

I wouldn’t put much hope in Epic allocating significant resources towards the Apple ecosystem though, considering how vocal the CEO is regarding his (justified, IMO) distrust.

2 Likes

Epic silently released ARM support for the editor yesterday but you have to compile UE5 from source. Everything seems to work and it’s way faster than before!

6 Likes

Could this be the commit that turned the on switch?

https://github.com/EpicGames/UnrealEngine/commit/50fd0a8994ac67c74db2e4bd6ea177556ab9f936

1 Like

Nice! Any numbers, by any chance? Medieval Village Environment would be a nice (non-Nanite/Lumen) stress test. Don’t think you would be able to handle Valley of the Ancients unless you have a very top of the line MBP.

3 Likes

I will not say Nanite is fully working on MacOS as the quality doesn’t match the one when using the same map on Windows10Pro. And the Nanite visualisation is not supported yet.
Hopefully with Metal 3 and the very efficient Apple Silicon CPU/GPU/unified memory we will soon have the choice to use a silent power efficient more compact design computer like the Mac Studio or an upcoming smaller Mac Pro to do everything on one machine only.
I use both MacOS and Win10Pro on the same Apple hardware but I am more efficient on MacOS that I find more reliable.
Hardware/software are just tools to help you achieve our work in the end.
But I can’t afford AMD RX 6xxx/Nvidia RTX 30xx graphic cards sold for the price of a computer plus the computer.
Nuke, Maya, RenderMan, Arnold, etc… are fully supported on Mac OS/Win/Linux so I am sure the talented people at Epic Games will succeed in making Unreal Engine supported by the 3 main operating system people enjoy using the most ! Keep the good work guys !

2 Likes

Hello SimplyPhy, that link will get me a 404 error result.
What is it supposed to be ?
Thanks,

You need access to Unreal Engine source:

2 Likes

How much faster is the native version? Does compiling for MacOS native work now? Is Lumen and Nanite the same? And is it more stable?

I downloaded the latest source build (five days ago) , which includes the architecture changes you mention but when I run the editor, it still appears as “Intel” in Activity Monitor. It also fixed some weird Mac-only rendering bugs compared to 5.0.2 so thanks for inspiring me to try it but unless I’m missing something it doesn’t seem to actually be native arm64

You need to use the ue5-main branch. In this case, there will be a native version of the engine for apple silicon.

1 Like

Thanks but that is the branch I’m using. Maybe its something to do with the fact that I’m launching it from a project that predates the fix and I need to look through its config files. Maybe the project is still Intel so it forces the Editor to run in Intel mode or something? Not worth trying to fix right now as my office Mac is Intel based…

Also check that in Xcode the destination is set to “My Mac” and not “My Mac (Rosetta)”

By the way, I forgot to say that the native version of the engine is now much faster and more responsive. For comparison, my test project in the engine worked with a frame rate of about 55-60 frames per second and there were friezes periodically, and now 100 - 110 and very smoothly. At the same time, the processor load has significantly decreased.

I’m working on MacBook Pro 14 M1-Max (32 Core GPU) 64gb RAM

Many thanks to the Unreal Engine development team, good job! I can’t wait for UE 5.1 to be released.

1 Like

Thanks. I tried again, it turns out that I was doing everything right and it is indeed very impressive when I load my project via Xcode. Rider is another story for some reason. Not only does it drop back to intel, working with a source engine build is slow and causes memory problems. Is there any way to get a source build to work more like a non-source build?

You don’t need to use XCode after you have already compiled Unreal Engine. The executable file is located in the [Folder where you cloned the engine]/Engine/Binaries/Mac/UnrealEditor.app

You can also leave the application in the dock after you have launched it.

I hope I understood your question correctly :slight_smile:

1 Like

I don’t think you have. It’s a C++ project, it runs in Apple mode through xcode or when run by simply clicking on the editor. For some reason it runs in Intel mode when launched from Rider, which I switched to a few months ago. Something to do with some extra processing Rider does to configure its own plugin I think. I just noticed there’s an early access version of Rider which I guess I’ll try later when I’m back with my M1 Mac.

Finally, I can now pull the trigger on an M1 Mac!

Can you tell me if Nanite and Lumen are both working on M1 now? I think beforehand that one (or both) of them was not working on Mac.