Ue5 editor flashing on laptop

does anyone has same problem like this below



Hey there @_X_43! Welcome to the community! This visual artifacting is way more intense than I regularly see. I’ve seen some graphics drivers being outdated causing this to occur from time to time. So I’ll run the usual set of questions and see if we can find anything.

  1. May we to check the specs of the laptop?

  2. Are your video drivers updated?

  3. Try verifying the installation in the launcher
    image

1 Like

1.my laptop is hp omen laptop 15 ek1xxx
Intel(R) Core™ i7-10870H CPU @ 2.20GHz 2.21 GHz
32.0 GB
GeForceRTX 3070 laptopGPU
2.the video drivers is Geforce Game ready 516.94 08/09/2022.
3.I have tried verify many times .
4.flashing caused crash Gpu Crashed or d3d device removed,and i tried followed How to Fix a GPU Driver Crash When Using Unreal Engine | Unreal Engine 5.0 Documentation not work.
5.it`s flashing when the window to full screen. when the window is not full sceen it will happend some times .
6.and I have tried reload the system and drivers.

Hi @_X_43,

I’ve seen several people with laptop GPUs having these UE5 issues. It seems that running DX11 instead of 12 might fix it. (Project Settings → Default RHI → ‘DirectX 11’) But be aware that you will no longer be able to use Nanite.

If that does end up fixing this, please try and switch back to DX12 once 5.1 preview is released and let us know if this is still a problem.

Cheers

Something that I would also suggest is to get the Studio Drivers for your GPU, and also go to Nvidia Control Panel and make sure that you add a new rule for UnrealEditor.exe and set the power management to Maximum Performance. I remember I had similar issues when it wasn’t set to that, because the GPU would downclock thinking it’s not needed

both of this drivers are flasing so i switched back to the gameready

@Astrotronic it`s helped. thanks
when 5.1 preview is release I will reply under this qusetion

1 Like

@Astrotronic ,
When I use 5.1 preview using DX12 still flashing.

Thanks for following up. I submitted a bug report and the QA team is aware of this problem. It was not clear if this will be fixed for 5.1.0 release though. The advice for now is to keep GPU drivers up to date as this may be something that Nvidia needs to fix.

Hi,

I switched to Direct 11 in project settings which fixed this issue and then switched back to Direct12 with no further issues.

1 Like

Hi guys, this fix actually only lasted as long as the session. Two other possible fixes are to use an external monitor or try turning off GSync.