UE5 Brand new project can't properly create c++ files

I am trying to have a C++ blueprint function library with one function in my project. I created it in ue4 and everything worked no problem. Created a c++ file on my ue5 project and got a messege

“Project now includes sources, please close the editor and build from your IDE.”

followed shortly by

“Successfully added class ‘MyBlueprintFunctionLibrary’, however you must recompile the ‘TestC54’ module before it will appear in the Content Browser.
Would you like to edit the code now?”

closing the editor, going to sln compile every single file by hand, fail, can’t build with live coding on. Go to editor, turn live coding off, compile everything, success, not showing up in editor. Turn live coding back on. Alt+Ctrl+F11, Get a bunch of variation of this:
(myDirectory)\Intermediate\Build\Win64\UnrealEditor\Development\UnrealEd\SharedPCH.UnrealEd.ShadowErrors.h.obj. Error: 0x2

Mind you, I had this problem on an existing project, so I created a brand new one, literally first thing I do is create new c++ file to test this, still exactly the same, and again, all this worked on an UE4 project.
Last time I had C++ generation problems in UE4 it was only on my existing project but no on a new project, which lead me to discover the project folder must have the same name as the project itself (for some ungodly reason) so I made extra sure to pay attention to that part.

I am using visual studio 2022 with all recommend modules and more, from several different websites and videos of setting up visual studio for unreal, and have installed several different .net sdks installed for a problem I had before this one

I am at my wits end and my will to live is dwindling please god someone help me here what the actual crap is going on. In my experience I probably missed some tiny infuriating detail but I can’t figure it out for the life of me.

frustrating stuff. some people found it to be from antivirus software. eg