UE5 asks me to 'save level as' Every single I save all levels in Engine

Hoping I am doing something dumb cos I have no Idea why this happening-- help appreciated!

7 Likes

having same issue.

2 Likes

Typically we don’t save or modfiy files inside the engine folder. Make a copy (or use ‘save as’) to your project folder (content) and give another try.

I’ve moved this over to the World Creation subforum. It’s a better location to ask this type of question. :slight_smile:

1 Like

I got the same thing a couple of times. Looks like a bug. Here is a video.

2 Likes

Hey

Looks like this is a bug related to Auto Save in the engine.
In order to prevent this from happening - go to Edit => Editor Preferences => search at the top bar “Auto Save” and turn off the checkbox.

It should fix it.

Cheers

3 Likes

Having the exact same issues as well. Is there any other option then the auto-save idea?

1 Like

I’m getting this as well.

Same, driving me nuts. And when trying to unload the level (opening another level), the editor crashes.

Same problem with UE 5.0.3

1 Like

Will give this a try, thanks!

I managed to fix it like this:

  • I had a material on an actor, and the material was under the “Engine” folder.
  • I replaced the material on the actor with a new material, which was not under the “Engine” folder.

Probably meshes and other stuff under “Engine” cause the same behavior. I think we’re dealing with a genuine bug, but at least there’s a workaround (hopefully it will work for you too).

2 Likes

For me, it was just numbered autosaves. I simply deselect them (don’t save the autosaves) and move on.

1 Like

ITS NOT WORK

1 Like

I ran into the same issue after impoorting a metahuman. Does anybody had that too after importing a metahuman?

I solved this problem for myself.

I turned off the option in the engine settings to reduce the consumption of PC resources if the application is running in the background.

same annoying problem… each time i click on ‘Save all’ , have more and more maps :rage: it is related with autosave

1 Like

Same here. I’ts getting worse recently. Can’t understand why this is not solved in 5.2.1. It’s been more than a year :face_with_diagonal_mouth:

1 Like

I ‘think’ I resolved this, just activating Source Control (originally it was a project connected to github but, at that moment, the source control was not activated)

tried the above suggestions, didnt work for me.
what solved for me was deleting all the autosaves out of the autosaves folder:

your project/Saved/Autosaves/Temp/

I just deleted everything in there (didnt even have one from today). Reopened, moved a rock, save_all, no silly popups insisting I make a billion more levels.

1 Like