UE5.1 Landscape Physical Material Needs To Be Rebuilt

In a fresh project using UE5.1 after adding a landscape to the default third person map, I get this screen message popup when playing in standalone mode. It happens even if I build the landscape, build all, and add a physical material. Not using any additional content. Why is nobody else reporting this? It’s happening even in other projects in 5.1 with different landscape materials too. I saw 5 other threads that went unanswered. Is this just a 5.1 bug?

3 Likes

hi,
have you tried to build it here ?

cheers :vulcan_salute:

3 Likes

Yeah, I already stated that I did that. Are you sure you are using 5.1 and testing in standalone mode? Try it out and see what happens.

hi,
i have 5.1, added the landscape to my level (which is blank by default) made a simple material and added physics materials to the landscape layers and no error here


Are you testing in standalone game mode? I dont get the error message in regular play mode

hi, i am very sorry was on christmas vacation. tested it with stand alone build. will test it tomorrow again when in office, write you back soon :slight_smile:

cheers :vulcan_salute:

This rather seems like an UE5.1 issue, than a regular “did you build the phy material yet” case, when testing the standalone production client.
I also get the message to rebuild the landscape materials, which is not the case when testing it via the viewport PIE.

Removed the cached folders, build the entire necessary stuff, yet the message keeps posting.
An odd issue with UE, as always.

also got this error :confused:
any news ?

I get the same error too? Has anyone got the solution?

I have fixed the issue by changing engine code
follow is the solution

Lnadscape.cpp

you will find the code below

LastBakedTextureMaterialGuid = BakedTextureMaterialGuid;
LastSavedPhysicalMaterialHash = PhysicalMaterialHash;

this two valuable only set in giseditor, not with editor

Still no obvious solution to this issue. I am using Unreal 5.2

I cannot paint make Unreal landscapes - because I get these “Physical Material Needs To be rebuilt” errors. Rebuild Landscapes does not do anything. and setting all Tex Samplers in the Landscape material to Shared Wrap, did not solve it.

What is the Landscape Physical Material, and how do we get rid of these issues ?

2 Likes

The same with me.
I did a completely new installation of 5.0 / 5.1 / 5.2 and then created a blank project.
Then, I created a new level and generated a landscape.
With all three versions, I’m getting this error directly, and there seems to be no way to fix it.

How can this be happening?
Can someone else reproduce this as well?

not in 5.0/5.1/5.2 (never had it). but it is there in the 5.3 preview

1 Like

Getting the same issue and I am already using 5.3. DId someone find a way to solve this?

2 Likes

Same problem here with 5.3, tried rebuilding everything from Build menu few times and project started to crash at some point, for me it is still possible to go back to use 5.2.1 (had copy of the project, I will wait for 5.3.1 or work with 5.3 when starting a new project)

1 Like

I’m having the same issue with 5.3 as well.

Hello, same here with 5.3 on a blank project

2 Likes

I am having the same exact problem myself.

Also having the same problem in 5.3

I’ve created brand new project and then create a landscape with the default setting. I add a mesh then once its finishes it gives the error.

Same issue, I just started to learn unreal and within an hour i find a problem with no solution?? lolololol