Download

UE5.0 and UE5-main build ok but fail on startup

Hi,

i have re try to build ue5.0 and ue5-main today, my last build was from november.
Update my repository etc… and follow the steps to setup and generate the solution, then i build it with VS19 and all went success without error.
But when i fire the Unreal Editor.exe the programm start showing his splash and compiling stuff as usual and so on, but he fail and this message pop up.


Unreal looks like continue his start sequence and close itself event if i don’t answer the popup.

i have try to clean my repo and pull again and so on, but i get the same error.

Do someone have an idea how to solve this ?

Me too

I had something similar, if you go to that line in code and comment it out and recompile it’ll work! Assertions can be ignored.

Hi,

Commenting the line 365 allow Unreal to pass the startup stage and get the project creation menu.
But creating project by picking some template result in this error now.
And event if the project creation succeed the same message pop when try to play the template.

Just keep commenting out the assertions, that’s the error I had to comment out.

Hi,
well, thx for the turnaround.
Commenting the assertions errors allow me to at least can use and play with this Unreal sources and dont lose my little more than one hour of initial compilation time.

i hope they fix this errors because this assertions are normally here on purpose, commenting them it is a hack we should dont have to do.

from what i could tell the portion of code around line 365 is checking to see if a shader compile thread has finished ,
having same error on linux build …

[2022.01.03-10.52.05:536][ 0]LogCore: Error: appError called: Assertion failed: WaitingTask->IsCompleted() [File:Runtime/Core/Public/Tasks/TaskPrivate.h] [Line: 365]

[2022.01.03-10.52.05:830][ 0]LogCore: === Critical error: ===
Unhandled Exception: SIGSEGV: invalid attempt to write memory at address 0x0000000000000003

[2022.01.03-10.52.05:831][ 0]LogCore: Assertion failed: WaitingTask->IsCompleted() [File:Runtime/Core/Public/Tasks/TaskPrivate.h] [Line: 365]


given further up the log theres a number of threads that could cause this ie:-
[2022.01.03-10.51.57:260][ 0]LogMaterial: Display: Missing cached shadermap for HelpActorMaterial in VULKAN_SM5, Default, SM5 (DDC key hash: 6CD7DB2293D8FC8A4CE82440CD9D10CA7D406369), compiling.

i only skipped though the code to see what it appears to be doing , dont take my word as its been years since i did any c or c++ , but i would say it started the shader compile thread (with missing data ) and ether exited or suspended , the main thread not getting a exit or fail response for missing data

it leaves me to think the error arises as
1 files are failing to complete
2 the program fails to correctly note the fail
until it tries to test for the thread that it assumes is running but is no longer there
as in no exit success ,and exit fail does not look to be tested for and just tries to probe a none existent thread ( causing segfault )
given the name of some of those files like “HelpActorMaterial” ,“DefaultTextMaterialOpaque” to name but 2 of the 7 or 8 commenting them out looks to me like it will only move the issue or make it a bigger issue later and not solve the problem

… update , the files are there apparently under ~UnrealEngine5/Engine/Content/EditorMaterials , wrong place ? or some other issue ? would need debug message from the thread to see whats happening when processing them i guess

from reading the forum this seems to be / has been a issue on ue4 builds also in the past ,but no solution to it there that could help me solve it , :frowning:

the more i look at the code the more confused i get , but

comments in the code point to that section as being an “optional time out” ,

if the timeout its self is intended to cause the SIGSEGV then that may explain it

leaving the question if its intended to be an optional timeout , how do you set the compile to make it so and force it to wait longer ?

Hi,

Yes i am agree, we should do not have to modify the source code, this is just a turnaround to at least open Unreal and see what new in it.
I am definitely not confident to do something more serious with a build obligate me to comment part of the code, this can have snow ball effects etc…

So, what steps a did.
I build it on Windows, and i don’t do nothing special.
I do the same as i was doing on previous build in november and before.
It is the first time i get this errors.

Exemple from fresh git clone :

  • Run the Setup.bat file
  • Run the GenerateProjectFiles.bat file
  • Open the UE5.sln with VS19
  • I dont change nothing just right click on Engine → UE5 and select Generate

Wait the compilation which is success without warnings or errors.
Thast it, then run the Engine → Binaries → Win64 → UnrealEditor.exe

And i get the errors listed in this post.

Same error here, too, from fresh 5.0 branch build.

been trying for a few days to get a version of ue5 running
initaly i downloaded from https://github.com/EpicGames/UnrealEngine/releases/tag/5.0.0-early-access-1
it compiled but failed on opening a new project , since that repo is a source zip dated 26 May 2021 its safe to say its an older version

since that failed i did a git clone with -
git clone -b 5.0 https://github.com/EpicGames/UnrealEngine.git UnrealEngine5"
and get the errors as in this thread

while struggling with the first build from the zip file , and reading threads on the forum i do remember seeing an older thread discussing this error , but try as i may i cant find it again , from what i remember it was on about graphics drivers (needing updating ) , found out i needed to install vulkan , that got it to run as far as it did

also its fair to say i my current card does not meet min spec to run ue5 , waiting for a new one in the post , so not much i can do till it turns up ,

anyway , since the vulkan drivers are installed i would of expected the git version of the source to get as far as the older zip version did , the fact that there only seems to be a handful of us with the issue seems to reflect that it could be a driver issue ,(newer source written for newer drivers) also as it seems to be involved with the threads compiling the cached shadermaps on startup

all i can say is , update drivers ( to current latest )ensure you have the right driver extentions installed also , , check that your system meets min spec, and , try again
hope this helps , wont know myself for a few days till my new gpu arrives
have fun

Hi, achiestdragon

Thx for all the research you have done.
I dont know about the setup on Linux, but, it seem normal that you need vulkan on this platform.
I hope the driver update help you, cross finger for your new graphic card.

On Windows Unreal run with directx 11 and/or 12 on modern graphic card which is the case for mine.
The driver is up to date as always and my computer over meet the recommended spec.

As mention in my post i have build Unreal (5.0 and 5.1) from source several time in the last year and never get this error before.

I do not know if some one from Epic team can jump on this to clarify this case ?

hi llullu
done all my dev work on linux since 2005 so linux is a must for me
i have been mulling over a game idea for about 6 months now , after seeing the matrix awakens demo on the ps 5 seems this engine is the way to go , as UE5 is still pre release and the final dew in the next few months , i’m hoping to learn and get used to it before starting my main game code
so UE5 is a must for me at this point
as is getting console (ps5) development working (even if i need a windows box to bridge that )
plus setting up a CVS server for co-devs and ensuring they have platforms that work in the following months

anyway back to topic , since the error we are both having is the same it still points to the same underlying issue , a thought , since my MESA nvidia driver updated last a few days ago just before i did the git clone the first time , maybe its down to the driver being too new , not clue on the driver your using , but if true for you also, you could try reverting the driver while waiting for UE5 to update its code to it

guess the epic team will be back from xmas/new year break about now ( timezone dependant ), and sifting though the backlog of messages , hope they all had a good one

Hi,

In fact i have update the driver nvidia some days before trying to build Unreal.
Maybe it is a linked problem as you guess …
But this start to be confusing, because it imply a global problem with drivers from different graphic card constructor for different platform and different graphic sdk :slight_smile:

I have the same problem when building on Windows and Linux; using the 5-0, and ue5-main branches. The only success I have had so far was on Linux with the ue5-early-access branch (I haven’t tried building from ue5-early-access on Windows yet).

I can’t get 5.0 or ue5-main to run on Linux either; but try building from the ue5-early-access branch. This works for me. Its old; but newer than the Early Access 1 zip you linked earlier.
git clone -b ue5-early-access https://github.com/EpicGames/UnrealEngine.git UnrealEngine5

FYI everyone, this has now been fixed (for me, at least) with a commit to the 5.0 branch.

Hi,

Yep, as 69_Tensors have mention the problems look like fixed now.
I have rebuild UE5.0 for Windows and no more startup problem.
I hope it is also fixed for you guys on linux platform :slight_smile:

I was successfully able to run the 5.0 branch on Linux.

I am not sure which commit solved the issues; but the latest commit (in case it breaks again) I tested with is 92a910054adf0581263e840c4bd1ff116130cbad

not full success for me yet , but happy
the commit fixed the issues , and the program runs , lets me create a new project , but crashes on opening that
it has got a lot further than before though , so it looks promising
its far to say i think this is now down to the rather old quadro fx 1200 i’m using (stuck with atm), so not going to investigate it further given the gtx1080ti should be here tomorrow , hopefully things will run smoothly once thats fitted