Download

UE5.0 and UE5-main build ok but fail on startup

still have issues here , installed the new card ,
did git pull , setup.sh , generateprojectfiles.sh , build
it seems to build fine

run it ,
the console shows a error during this
Ensure condition failed: (ImageCreateInfo.usage & VK_IMAGE_USAGE_SAMPLED_BIT) == 0 [File:./Runtime/VulkanRHI/Private/VulkanTexture.cpp] [Line: 444]
but it continues and opens the project create menu ,

it lets me create a new project but once it tries to start , i get the same error

Ensure condition failed: (ImageCreateInfo.usage & VK_IMAGE_USAGE_SAMPLED_BIT) == 0 [File:./Runtime/VulkanRHI/Private/VulkanTexture.cpp] [Line: 444]

in the console output , long before it actually decides to stop and fail over it

so , since others here have solved the startup issues , i can only assume its a driver issue , of some sort

graphics card [geforce gtx 1080 ti]
cpu 2X xeon e5-2680 @2.7ghz (32 cores total)
ram 64mb
kernel version 5.15.12-1-default(64bit) (opensuse tumbleweed)
video drivers kernel module nouveau 21.3.1-295.4
opengl version 4.3 (compatibility profile) mesa 21.3.1
vulkan instance version 1.2.198

so …
do i need to install the nvidia drivers from nvidia or are the nouveau drivers ok

vulkan gives a warning (in sytem info) that lavapipe is not a conformant vulkan implementation , testing use only ,

i also get warnings of 3 missing files numerous times during the startup
Warning: Failed to read file ‘…/…/…/Engine/Content/Editor/Slate/Niagara/Icons/StaticPin_Connected.png’ error.
Warning: Failed to read file ‘…/…/…/Engine/Content/Editor/Slate/Niagara/Icons/StaticPin_Disconnected.png’ error.
Warning: Failed to read file ‘…/…/…/Engine/Content/Editor/Slate/Niagara/White.png’ error.

any clues as to what the issue is ?

seems changing from the nouveau drivers to nvidia drivers has resolved the editor start up , and the
Ensure condition failed: (ImageCreateInfo.usage & VK_IMAGE_USAGE_SAMPLED_BIT) == 0 [File:./Runtime/VulkanRHI/Private/VulkanTexture.cpp] [Line: 444]
error seems to have gone :slight_smile:

Hi, achiestdragon

Happy that you have find a working solution :slight_smile:

yea , would be nice to have a list of driver /lib dependencies would save a lot of searching and trying alternate ones /versins just to get it going

the editor now loads and seems fine mostly , other than i cant edit , move or select any object
or it fails with a segvfault , and again it seems i’m left looking for some other none existant lib/function , in some other non listed dependency

I’m trying to track down some library problems myself. There’s a built in tool that lists dependencies of shared libraries (*.so) called ldd. Searching the UE5 tree I found 15k shared libraries and amongst those there were about 350 unique “missing dependencies” As you point out a lot of those are to be expected as they could refer to other runtime environments. Anyway I though I’d share my process in case it help you.

`cd /Data/src/ue5/UnrealEngine-ue5-main/ # ue5 root dir #

find . | grep so$ > dynamiclibs.txt # grab a list of all the .so files #

cat dynamiclibs.txt | wc -l # about 15,000 #

cat dynamiclibs.txt | xargs ldd | grep -i found > dynamiclibs-fo.txt # use ldd and filter on missing deps #

cat dynamiclibs-fo.txt | sort | uniq > dynamiclibs-fo-sorted.txt # get a rough idea of “missing deps” #

`

Here’s one example that I need to chase:
`ldd Engine/Plugins/Importers/USDImporter/Source/ThirdParty/Linux/bin/x86_64-unknown-linux-gnu/./libndr.so

linux-vdso.so.1 (0x00007ffcad573000)
libm.so.6 => /lib/x86_64-linux-gnu/libm.so.6 (0x00007f73b1d4b000)
libc.so.6 => /lib/x86_64-linux-gnu/libc.so.6 (0x00007f73b1b23000)
libgcc_s.so.1 => /lib/x86_64-linux-gnu/libgcc_s.so.1 (0x00007f73b1b09000)
libutil.so.1 => /lib/x86_64-linux-gnu/libutil.so.1 (0x00007f73b1b04000)
libsdf.so => /Data/src/ue5/UnrealEngine-ue5-main/Engine/Plugins/Importers/USDImporter/Source/ThirdParty/Linux/bin/x86_64-unknown-linux-gnu/././libsdf.so (0x00007f73b15ba000)
libboost_python39.so.1.70.0 => /Data/src/ue5/UnrealEngine-ue5-main/Engine/Plugins/Importers/USDImporter/Source/ThirdParty/Linux/bin/x86_64-unknown-linux-gnu/././libboost_python39.so.1.70.0 (0x00007f73b0f27000)
libar.so => /Data/src/ue5/UnrealEngine-ue5-main/Engine/Plugins/Importers/USDImporter/Source/ThirdParty/Linux/bin/x86_64-unknown-linux-gnu/././libar.so (0x00007f73b0eed000)
libplug.so => /Data/src/ue5/UnrealEngine-ue5-main/Engine/Plugins/Importers/USDImporter/Source/ThirdParty/Linux/bin/x86_64-unknown-linux-gnu/././libplug.so (0x00007f73b0e9c000)
libwork.so => /Data/src/ue5/UnrealEngine-ue5-main/Engine/Plugins/Importers/USDImporter/Source/ThirdParty/Linux/bin/x86_64-unknown-linux-gnu/././libwork.so (0x00007f73b0e94000)
libvt.so => /Data/src/ue5/UnrealEngine-ue5-main/Engine/Plugins/Importers/USDImporter/Source/ThirdParty/Linux/bin/x86_64-unknown-linux-gnu/././libvt.so (0x00007f73b0ce8000)
libtrace.so => /Data/src/ue5/UnrealEngine-ue5-main/Engine/Plugins/Importers/USDImporter/Source/ThirdParty/Linux/bin/x86_64-unknown-linux-gnu/././libtrace.so (0x00007f73b0c81000)
libjs.so => /Data/src/ue5/UnrealEngine-ue5-main/Engine/Plugins/Importers/USDImporter/Source/ThirdParty/Linux/bin/x86_64-unknown-linux-gnu/././libjs.so (0x00007f73b0c5c000)
libgf.so => /Data/src/ue5/UnrealEngine-ue5-main/Engine/Plugins/Importers/USDImporter/Source/ThirdParty/Linux/bin/x86_64-unknown-linux-gnu/././libgf.so (0x00007f73b0bbe000)
libtf.so => /Data/src/ue5/UnrealEngine-ue5-main/Engine/Plugins/Importers/USDImporter/Source/ThirdParty/Linux/bin/x86_64-unknown-linux-gnu/././libtf.so (0x00007f73b0509000)
libtbb.so.2 => not found
libarch.so => /Data/src/ue5/UnrealEngine-ue5-main/Engine/Plugins/Importers/USDImporter/Source/ThirdParty/Linux/bin/x86_64-unknown-linux-gnu/././libarch.so (0x00007f73b03fb000)
libdl.so.2 => /lib/x86_64-linux-gnu/libdl.so.2 (0x00007f73b03f6000)
libpthread.so.0 => /lib/x86_64-linux-gnu/libpthread.so.0 (0x00007f73b03f1000)
/lib64/ld-linux-x86-64.so.2 (0x00007f73b1e78000)
libtbb.so.2 => not found
librt.so.1 => /lib/x86_64-linux-gnu/librt.so.1 (0x00007f73b03ec000)
libtbb.so.2 => not found
libtbb.so.2 => not found
libtbb.so.2 => not found
libtbb.so.2 => not found
libtbb.so.2 => not found
libtbb.so.2 => not found
libtbb.so.2 => not found
libtbb.so.2 => not found

`

After the previous post I decided to try adding the ue5 library location* to the system library search path:

sudo vim /etc/ld.so.conf.d/ue5.conf

$ cat /etc/ld.so.conf.d/ue5.conf
/Data/src/ue5/UnrealEngine-ue5-main/./Engine/Binaries/Linux/

sudo ldconfig

Now there’s only 90 “Missing Libraries” rather than 370 ish.

No idea if this is the right way to go… about to find out :slight_smile: