Download

UE4Editor constantly crashes and freezes using Linux

Hello everyone,
I have a same issue with UE 4.25 . Editor constantly crashes and freezes my pc. I also run on Ubuntu 18.04
The error reported is mainly related to Vulcan. The error is attached.
also with OpenGl, the editor doesn’t even run at all.
Upgrading the Ubuntu version presents problems for me. Anyone have a solution to this problem?
thanks.

Similar (same?) issue here, on Ubuntu 16.04. I’m trying to open a project I made in UE 4.16 in UE 4.24, and the editor crashes on startup, with the following diagnostic report:


Generating report for minidump

Application version 4.24.2.0
 ... built from changelist 0

OS version Linux 4.4.0-173-generic (network name: dan-H55M-S2)
Running 2 x86_64 processors (4 logical cores)
Exception was "SIGSEGV: invalid attempt to write memory at address 0x0000000000000003"

<SOURCE START>
<SOURCE END>

<CALLSTACK START>
libUE4Editor-Core.so!FGenericPlatformMisc::RaiseException(unsigned int) [/home/dan/UnrealEngine/Engine/Source/Runtime/Core/Private/GenericPlatform/GenericPlatformMisc.cpp:477]
libUE4Editor-Core.so!FOutputDevice::LogfImpl(char16_t const*, ...) [/home/dan/UnrealEngine/Engine/Source/Runtime/Core/Private/Misc/OutputDevice.cpp:71]
libUE4Editor-VulkanRHI.so!VulkanRHI::FDeviceMemoryManager::Alloc(bool, unsigned long, unsigned int, void*, float, char const*, unsigned int) [/home/dan/UnrealEngine/Engine/Source/Runtime/VulkanRHI/Private/VulkanMemory.cpp:279]
libUE4Editor-VulkanRHI.so!VulkanRHI::FOldResourceHeap::AllocateResource(VulkanRHI::FOldResourceHeap::EType, unsigned int, unsigned int, bool, bool, char const*, unsigned int) [/home/dan/UnrealEngine/Engine/Source/Runtime/VulkanRHI/Private/VulkanMemory.cpp:1159]
libUE4Editor-VulkanRHI.so!VulkanRHI::FResourceHeapManager::AllocateImageMemory(VkMemoryRequirements const&, unsigned int, char const*, unsigned int) [/home/dan/UnrealEngine/Engine/Source/Runtime/VulkanRHI/Public/VulkanMemory.h:812]
libUE4Editor-VulkanRHI.so!FVulkanSurface::FVulkanSurface(FVulkanDevice&, VkImageViewType, EPixelFormat, unsigned int, unsigned int, unsigned int, unsigned int, unsigned int, unsigned int, unsigned int, FRHIResourceCreateInfo const&) [/home/dan/UnrealEngine/Engine/Source/Runtime/VulkanRHI/Private/VulkanTexture.cpp:561]
libUE4Editor-VulkanRHI.so!FVulkanTextureBase::FVulkanTextureBase(FVulkanDevice&, VkImageViewType, EPixelFormat, unsigned int, unsigned int, unsigned int, unsigned int, unsigned int, unsigned int, unsigned int, FRHIResourceCreateInfo const&) [/home/dan/UnrealEngine/Engine/Source/Runtime/VulkanRHI/Private/VulkanTexture.cpp:1644]
libUE4Editor-VulkanRHI.so!FVulkanTexture2D::FVulkanTexture2D(FVulkanDevice&, EPixelFormat, unsigned int, unsigned int, unsigned int, unsigned int, unsigned int, FRHIResourceCreateInfo const&) [/home/dan/UnrealEngine/Engine/Source/Runtime/VulkanRHI/Private/VulkanTexture.cpp:1848]
libUE4Editor-VulkanRHI.so!FVulkanDynamicRHI::RHICreateTexture2D_RenderThread(FRHICommandListImmediate&, unsigned int, unsigned int, unsigned char, unsigned int, unsigned int, unsigned int, FRHIResourceCreateInfo&) [/home/dan/UnrealEngine/Engine/Source/Runtime/VulkanRHI/Public/VulkanDynamicRHI.h:272]
libUE4Editor-RenderCore.so!RHICreateTargetableShaderResource2D(unsigned int, unsigned int, unsigned char, unsigned int, unsigned int, unsigned int, bool, bool, FRHIResourceCreateInfo&, TRefCountPtr<FRHITexture2D>&, TRefCountPtr<FRHITexture2D>&, unsigned int) [/home/dan/UnrealEngine/Engine/Source/Runtime/RHI/Public/RHIUtilities.h:582]
libUE4Editor-RenderCore.so!FRenderTargetPool::FindFreeElement(FRHICommandList&, FPooledRenderTargetDesc const&, TRefCountPtr<IPooledRenderTarget>&, char16_t const*, bool, ERenderTargetTransience, bool) [/home/dan/UnrealEngine/Engine/Source/Runtime/RenderCore/Private/RenderTargetPool.cpp:357]
libUE4Editor-Renderer.so!FSceneRenderer::AllocateCSMDepthTargets(FRHICommandListImmediate&, TArray<FProjectedShadowInfo*, TMemStackAllocator<0u> > const&) [/home/dan/UnrealEngine/Engine/Source/Runtime/Renderer/Private/ShadowSetup.cpp:3865]
libUE4Editor-Renderer.so!FSceneRenderer::AllocateShadowDepthTargets(FRHICommandListImmediate&) [/home/dan/UnrealEngine/Engine/Source/Runtime/Renderer/Private/ShadowSetup.cpp:3614]
libUE4Editor-Renderer.so!FSceneRenderer::InitDynamicShadows(FRHICommandListImmediate&, FGlobalDynamicIndexBuffer&, FGlobalDynamicVertexBuffer&, FGlobalDynamicReadBuffer&) [/home/dan/UnrealEngine/Engine/Source/Runtime/Renderer/Private/ShadowSetup.cpp:4241]
libUE4Editor-Renderer.so!FDeferredShadingSceneRenderer::InitViewsPossiblyAfterPrepass(FRHICommandListImmediate&, FILCUpdatePrimTaskData&, TArray<TRefCountPtr<FGraphEvent>, TInlineAllocator<4u, TSizedDefaultAllocator<32> > >&) [/home/dan/UnrealEngine/Engine/Source/Runtime/Renderer/Private/SceneVisibility.cpp:4364]
libUE4Editor-Renderer.so!FDeferredShadingSceneRenderer::InitViews(FRHICommandListImmediate&, FExclusiveDepthStencil::Type, FILCUpdatePrimTaskData&, TArray<TRefCountPtr<FGraphEvent>, TInlineAllocator<4u, TSizedDefaultAllocator<32> > >&) [/home/dan/UnrealEngine/Engine/Source/Runtime/Renderer/Private/SceneVisibility.cpp:4261]
libUE4Editor-Renderer.so!FDeferredShadingSceneRenderer::Render(FRHICommandListImmediate&) [/home/dan/UnrealEngine/Engine/Source/Runtime/Renderer/Private/DeferredShadingRenderer.cpp:1106]
libUE4Editor-Renderer.so!RenderViewFamily_RenderThread(FRHICommandListImmediate&, FSceneRenderer*) [/home/dan/UnrealEngine/Engine/Source/Runtime/Renderer/Private/SceneRendering.cpp:3473]
libUE4Editor-Renderer.so!TEnqueueUniqueRenderCommandType<FRendererModule::BeginRenderingViewFamily(FCanvas*, FSceneViewFamily*)::FDrawSceneCommandName, FRendererModule::BeginRenderingViewFamily(FCanvas*, FSceneViewFamily*)::$_91>::DoTask(ENamedThreads::Type, TRefCountPtr<FGraphEvent> const&) [/home/dan/UnrealEngine/Engine/Source/Runtime/RenderCore/Public/RenderingThread.h:198]
libUE4Editor-Renderer.so!TGraphTask<TEnqueueUniqueRenderCommandType<FRendererModule::BeginRenderingViewFamily(FCanvas*, FSceneViewFamily*)::FDrawSceneCommandName, FRendererModule::BeginRenderingViewFamily(FCanvas*, FSceneViewFamily*)::$_91> >::ExecuteTask(TArray<FBaseGraphTask*, TSizedDefaultAllocator<32> >&, ENamedThreads::Type) [/home/dan/UnrealEngine/Engine/Source/Runtime/Core/Public/Async/TaskGraphInterfaces.h:847]
libUE4Editor-Core.so!FNamedTaskThread::ProcessTasksNamedThread(int, bool) [/home/dan/UnrealEngine/Engine/Source/Runtime/Core/Private/Async/TaskGraph.cpp:686]
libUE4Editor-Core.so!FNamedTaskThread::ProcessTasksUntilQuit(int) [/home/dan/UnrealEngine/Engine/Source/Runtime/Core/Private/Async/TaskGraph.cpp:582]
libUE4Editor-RenderCore.so!RenderingThreadMain(FEvent*) [/home/dan/UnrealEngine/Engine/Source/Runtime/RenderCore/Private/RenderingThread.cpp:339]
libUE4Editor-RenderCore.so!FRenderingThread::Run() [/home/dan/UnrealEngine/Engine/Source/Runtime/RenderCore/Private/RenderingThread.cpp:488]
libUE4Editor-Core.so!FRunnableThreadPThread::Run() [/home/dan/UnrealEngine/Engine/Source/Runtime/Core/Private/HAL/PThreadRunnableThread.cpp:25]
libUE4Editor-Core.so!FRunnableThreadPThread::_ThreadProc(void*) [/home/dan/UnrealEngine/Engine/Source/Runtime/Core/Private/HAL/PThreadRunnableThread.h:177]
libpthread.so.0!UnknownFunction(0x76b9)
libc.so.6!clone(+0x6c)

<CALLSTACK END>

0 loaded modules

Report end!

Edit: I tried opening the project on Ubuntu 18.04, and this time, the editor asked to convert the project to UE 4.24 before opening it. I clicked yes, and the converted project opens without issues, but crashes randomly all the time, with the same diagnostic report as before.

Edit 2: I tried opening the project on Ubuntu 19.10, same issue. I also tried it in Windows 7, with 0 crashes so far, so it rules out this being a hardware issue.

Hi,

I have a similar pb with UE4 v 4.24.3 when I use a ‘E’ key to rotate objects.

In first time I used Ubuntu 18.04 with mesa and now I’m runing Ubuntu 19.10. The bug is the same in all case.

I have a AMD GPU and my driver is mesa 20. I install Vulkan packages with this command ‘sudo apt-get install libvulkan1 mesa-vulkan-drivers vulkan-utils’

Some body know the solution ?

I just submit this bug here : Unreal Engine Community
Please, submit your bug

Hi,

Same issue than @MisterLeRigolo

Tested on Arch Linux with latest vulkan and amdgpu drivers taken from repos, and a Ryzen 3600x CPU and and Ati RX 580 4Go GPU.

I compiled the 4.23 engine version, all seems to run well, but the editor crashes when using the scale tools (E key) with an actor selected.
Tested with personal, blank or template projects, C++ or BP: same issue

The issue doesn’t occur it the engine is launched with open GL forced (I added -opengl4 to the command line). But there are other issues in that case (lighting artifacts for instance)

I’m currently trying several solutions (4.24 and/or 4.25 engine version, compiling vulkan from latest sources…)

I’ve reported the bug too

@MisterLeRigolo : please, post a reply if you find a solution. I’ll do the same

@MisterLeRigolo

Good news !

It seems that’s I’ve found a solution

My 4.23 editor no longer crash when using the scale tool.

This are the steps I’ve done:

  • installing the vulkan-tools (not sure it’s necessary) . Command for arch linux

pacman -Syuu vulkan-tools

  • removing the vulkan radeon mesa driver. Command for arch linux

pacman -R vulkan-radeon

  • installing the AMD’s standalone vulkan driver. Command for arch linux

pacman -Syuu amdvlk

I’m making more tests to be sure that’s the issue has gone

thanks for your solution on your distro.

On Ubuntu I think that several solutions is possible : Mesa 20.1-dev RADV vs. RADV+ACO vs. AMDVLK vs. AMDGPU-PRO Vulkan Radeon Linux Gaming Performance - Phoronix

  • Mesa + RADV
  • AMDVLK
  • AMD GPU Pro

1] AMD GPU Pro solution

Firstly, I try to install AMD GPU Pro driver on Ubuntu 18.04 to see if this bug is fixing.
During the compilation of this driver I get an error because I have not a good kernel version.

On Ubuntu only Mesa and Nvidia drivers are in configuration management .
Under Ubuntu, for AMD GPU pro, it is not a good idea to install AMD GPU pro drivers :frowning:

2] AMDVLK

AMDVLK installation on Ubuntu is different than AMD GPU pro.

It’s a simple .deb package : Releases · GPUOpen-Drivers/AMDVLK · GitHub

The install instruction is the next :



sudo dpkg -r amdvlk   /* If old version is installed on the machine, remove it first */
sudo dpkg -i amdvlk_x.x.x_amd64.deb
sudo apt-get -f install  

https://github.com/GPUOpen-Drivers/A…e-built-driver

For the moment I don’t try this.

3] Mesa + RADV

This solution don’t work for UE4 Editor (see my last post)


sudo apt-get install libvulkan1 mesa-vulkan-drivers vulkan-utils

https://linuxconfig.org/install-and-…ulkan-on-linux

Conclusion

I try to see with Mesa RADV community if that’s possible to fix this pb because I would like to keept my OS with basic configuration.
I hope Epic will fix this bug…

Has anyone tested the 2nd (AMDVLK) solution on Ubuntu ?

I’m experiencing a similar Vulkan-related crash, and I’m using an Nvidia graphics card, so I don’t think this issue is card-specific.

If you use Ubuntu you can try to use Nvidia Driver.

go to ‘system parameter’ and ‘additional Driver’. Wait a moment and select ‘tested Nvidia Driver’.

I don’t know if that the solution because I don’t use Nvida GPU but I’m interested of the result of this.

I already have. I’ve tested several Nvidia drivers available in Ubuntu, with the same result. First of all, the UE4 editor doesn’t open because it can’t find Vulkan, so I have to install vulkan-utils/libvulkan1 manually from the cli - shouldn’t this come with the Nvidia driver? After Vulkan is installed, when I open the UE4 Editor, it either crashes at startup, or soon after, depending on the project.

I suggest you to send bug report here : Unreal Engine Community
I think that important that UE4 editor run on Mesa driver because it is a standard driver on Linux.

Can you post a screenshot of the error message with Mesa ?

Thanks, I’ll send a bug report.

You mean the Vulkan Mesa driver? I tried it, but UE4 editor still crashes (can’t fit all the text into a screenshot):


Fatal error: [File:/home/dan/UnrealEngine/Engine/Source/Runtime/VulkanRHI/Private/VulkanUtil.cpp] [Line: 772] VulkanRHI::vkCreateSwapchainKHR(Device.GetInstanceHandle(), &SwapChainInfo, VULKAN_CPU_ALLOCATOR, &SwapChain) failed, VkResult=-3 at /home/dan/UnrealEngine/Engine/Source/Runtime/VulkanRHI/Private/VulkanSwapChain.cpp:463 with error VK_ERROR_INITIALIZATION_FAILED << callstack too long >>

libUE4Editor-Core.so!FGenericPlatformMisc::RaiseException(unsigned int) [/home/dan/UnrealEngine/Engine/Source/Runtime/Core/Private/GenericPlatform/GenericPlatformMisc.cpp:477]
libUE4Editor-Core.so!FOutputDevice::LogfImpl(char16_t const*, ...) [/home/dan/UnrealEngine/Engine/Source/Runtime/Core/Private/Misc/OutputDevice.cpp:71]
libUE4Editor-VulkanRHI.so!VulkanRHI::VerifyVulkanResult(VkResult, char const*, char const*, unsigned int) [/home/dan/UnrealEngine/Engine/Source/Runtime/VulkanRHI/Private/VulkanUtil.cpp:771]
libUE4Editor-VulkanRHI.so!FVulkanSwapChain::FVulkanSwapChain(VkInstance_T*, FVulkanDevice&, void*, EPixelFormat&, unsigned int, unsigned int, unsigned int*, TArray<VkImage_T*, TSizedDefaultAllocator<32> >&, signed char, FVulkanSwapChainRecreateInfo*) [/home/dan/UnrealEngine/Engine/Source/Runtime/VulkanRHI/Private/VulkanSwapChain.cpp:463]
libUE4Editor-VulkanRHI.so!FVulkanViewport::CreateSwapchain(FVulkanSwapChainRecreateInfo*) [/home/dan/UnrealEngine/Engine/Source/Runtime/VulkanRHI/Private/VulkanViewport.cpp:608]
libUE4Editor-VulkanRHI.so!FVulkanViewport::FVulkanViewport(FVulkanDynamicRHI*, FVulkanDevice*, void*, unsigned int, unsigned int, bool, EPixelFormat) [/home/dan/UnrealEngine/Engine/Source/Runtime/VulkanRHI/Private/VulkanViewport.cpp:146]
libUE4Editor-VulkanRHI.so!FVulkanDynamicRHI::RHICreateViewport(void*, unsigned int, unsigned int, bool, EPixelFormat) [/home/dan/UnrealEngine/Engine/Source/Runtime/VulkanRHI/Private/VulkanViewport.cpp:963]
libUE4Editor-SlateRHIRenderer.so!FSlateRHIRenderer::CreateViewport(TSharedRef<SWindow, (ESPMode)0>) [/home/dan/UnrealEngine/Engine/Source/Runtime/SlateRHIRenderer/Private/SlateRHIRenderer.cpp:333]
libUE4Editor-SlateCore.so!SWindow::ShowWindow() [/home/dan/UnrealEngine/Engine/Source/Runtime/SlateCore/Private/Widgets/SWindow.cpp:1387]
libUE4Editor-Slate.so!FSlateApplication::AddWindowAsNativeChild(TSharedRef<SWindow, (ESPMode)0>, TSharedRef<SWindow, (ESPMode)0>, bool) [/home/dan/UnrealEngine/Engine/Source/Runtime/Slate/Private/Framework/Application/SlateApplication.cpp:1949]
libUE4Editor-Slate.so!FTabManager::RestoreArea_Helper(TSharedRef<FTabManager::FLayoutNode, (ESPMode)0> const&, TSharedPtr<SWindow, (ESPMode)0> const&, bool, EOutputCanBeNullptr) [/home/dan/UnrealEngine/Engine/Source/Runtime/Slate/Private/Framework/Docking/TabManager.cpp:1474]
libUE4Editor-Slate.so!FTabManager::RestoreArea(TSharedRef<FTabManager::FArea, (ESPMode)0> const&, TSharedPtr<SWindow, (ESPMode)0> const&, bool, EOutputCanBeNullptr) [/home/dan/UnrealEngine/Engine/Source/Runtime/Slate/Private/Framework/Docking/TabManager.cpp:1339]
libUE4Editor-Slate.so!FTabManager::FindPotentiallyClosedTab(FTabId const&) [/home/dan/UnrealEngine/Engine/Source/Runtime/Slate/Private/Framework/Docking/TabManager.cpp:1255]
libUE4Editor-Slate.so!FTabManager::OpenUnmanagedTab(FName, FTabManager::FSearchPreference const&, TSharedRef<SDockTab, (ESPMode)0> const&) [/home/dan/UnrealEngine/Engine/Source/Runtime/Slate/Private/Framework/Docking/TabManager.cpp:1307]
libUE4Editor-Slate.so!FGlobalTabmanager::OpenUnmanagedTab(FName, FTabManager::FSearchPreference const&, TSharedRef<SDockTab, (ESPMode)0> const&) [/home/dan/UnrealEngine/Engine/Source/Runtime/Slate/Private/Framework/Docking/TabManager.cpp:2437]
libUE4Editor-Slate.so!FTabManager::InsertDocumentTab(FName, FTabManager::FSearchPreference const&, TSharedRef<SDockTab, (ESPMode)0> const&, bool) [/home/dan/UnrealEngine/Engine/Source/Runtime/Slate/Private/Framework/Docking/TabManager.cpp:1287]
libUE4Editor-UnrealEd.so!FAssetEditorToolkit::InitAssetEditor(EToolkitMode::Type, TSharedPtr<IToolkitHost, (ESPMode)0> const&, FName, TSharedRef<FTabManager::FLayout, (ESPMode)0> const&, bool, bool, TArray<UObject*, TSizedDefaultAllocator<32> > const&, bool, bool) [/home/dan/UnrealEngine/Engine/Source/Editor/UnrealEd/Private/Toolkits/AssetEditorToolkit.cpp:172]
libUE4Editor-Kismet.so!FBlueprintEditor::InitBlueprintEditor(EToolkitMode::Type, TSharedPtr<IToolkitHost, (ESPMode)0> const&, TArray<UBlueprint*, TSizedDefaultAllocator<32> > const&, bool) [/home/dan/UnrealEngine/Engine/Source/Editor/Kismet/Private/BlueprintEditor.cpp:1845]
libUE4Editor-Kismet.so!FBlueprintEditorModule::CreateBlueprintEditor(EToolkitMode::Type, TSharedPtr<IToolkitHost, (ESPMode)0> const&, UBlueprint*, bool) [/home/dan/UnrealEngine/Engine/Source/Editor/Kismet/Private/BlueprintEditorModule.cpp:265]
libUE4Editor-AssetTools.so!FAssetTypeActions_Blueprint::OpenAssetEditor(TArray<UObject*, TSizedDefaultAllocator<32> > const&, TSharedPtr<IToolkitHost, (ESPMode)0>) [/home/dan/UnrealEngine/Engine/Source/Developer/AssetTools/Private/AssetTypeActions/AssetTypeActions_Blueprint.cpp:93]
libUE4Editor-UnrealEd.so!UAssetEditorSubsystem::OpenEditorForAsset(UObject*, EToolkitMode::Type, TSharedPtr<IToolkitHost, (ESPMode)0>, bool) [/home/dan/UnrealEngine/Engine/Source/Editor/UnrealEd/Private/Subsystems/AssetEditorSubsystem.cpp:339]
libUE4Editor-UnrealEd.so!UEditorEngine::EditObject(UObject*) [/home/dan/UnrealEngine/Engine/Source/Editor/UnrealEd/Private/EditorEngine.cpp:3143]
libUE4Editor-UnrealEd.so!FEditorClassUtils::GetSourceLinkFormatted(UClass const*, TWeakObjectPtr<UObject, FWeakObjectPtr>, FText const&, FText const&)::Local::OnEditBlueprintClicked(TWeakObjectPtr<UBlueprint, FWeakObjectPtr>, TWeakObjectPtr<UObject, FWeakObjectPtr>) [/home/dan/UnrealEngine/Engine/Source/Editor/UnrealEd/Private/EditorClassUtils.cpp:108]
libUE4Editor-UnrealEd.so!TBaseStaticDelegateInstance<void (), TWeakObjectPtr<UBlueprint, FWeakObjectPtr>, TWeakObjectPtr<UObject, FWeakObjectPtr> >::ExecuteIfSafe() const [/home/dan/UnrealEngine/Engine/Source/Runtime/Core/Public/Delegates/DelegateInstancesImpl.h:852]
libUE4Editor-UnrealEd.so!SHyperlink::Hyperlink_OnClicked() [/home/dan/UnrealEngine/Engine/Source/Runtime/Slate/Public/Widgets/Input/SHyperlink.h:99]
libUE4Editor-UnrealEd.so!TBaseSPMethodDelegateInstance<false, SHyperlink, (ESPMode)0, FReply ()>::Execute() const [/home/dan/UnrealEngine/Engine/Source/Runtime/Core/Public/Delegates/DelegateInstancesImpl.h:293]
libUE4Editor-Slate.so!SButton::ExecuteOnClick() [/home/dan/UnrealEngine/Engine/Source/Runtime/Slate/Private/Widgets/Input/SButton.cpp:385]
libUE4Editor-Slate.so!SButton::OnMouseButtonUp(FGeometry const&, FPointerEvent const&) [/home/dan/UnrealEngine/Engine/Source/Runtime/Slate/Private/Widgets/Input/SButton.cpp:304]
libUE4Editor-Slate.so!FSlateApplication::RoutePointerUpEvent(FWidgetPath const&, FPointerEvent const&) [/home/dan/UnrealEngine/Engine/Source/Runtime/Slate/Private/Framework/Application/SlateApplication.cpp:4618]
libUE4Editor-Slate.so!FSlateApplication::ProcessMouseButtonUpEvent(FPointerEvent const&) [/home/dan/UnrealEngine/Engine/Source/Runtime/Slate/Private/Framework/Application/SlateApplication.cpp:5140]
libUE4Editor-Slate.so!FSlateApplication::OnMouseUp(EMouseButtons::Type, FVector2D) [/home/dan/UnrealEngine/Engine/Source/Runtime/Slate/Private/Framework/Application/SlateApplication.cpp:5108]
libUE4Editor-ApplicationCore.so!FLinuxApplication::ProcessDeferredMessage(SDL_Event) [/home/dan/UnrealEngine/Engine/Source/Runtime/ApplicationCore/Private/Linux/LinuxApplication.cpp:358]
libUE4Editor-ApplicationCore.so!FLinuxPlatformApplicationMisc::PumpMessages(bool) [/home/dan/UnrealEngine/Engine/Source/Runtime/ApplicationCore/Private/Linux/LinuxPlatformApplicationMisc.cpp:415]
UE4Editor!FEngineLoop::Tick() [/home/dan/UnrealEngine/Engine/Source/Runtime/Launch/Private/LaunchEngineLoop.cpp:4397]
UE4Editor!GuardedMain(char16_t const*) [/home/dan/UnrealEngine/Engine/Source/Runtime/Launch/Private/Launch.cpp:175]
libUE4Editor-UnixCommonStartup.so!CommonUnixMain(int, char**, int (*)(char16_t const*), void (*)()) [/home/dan/UnrealEngine/Engine/Source/Runtime/Unix/UnixCommonStartup/Private/UnixCommonStartup.cpp:264]
libc.so.6!__libc_start_main(+0xef)
UE4Editor!_start()



I haven’t, but why is it necessary to install Vulkan at all? It should be installed with the Nvidia driver: Vulkan Driver Support | NVIDIA Developer

Then does Vulkan SDK have to be installed on the system when building UE4? It sounds like installing it after could introduce conflicts with UE4’s bundled version.

[UE4_InstallPath]/Engine/Config/BaseEngine.ini

In this configuration file

Comment out

+TargetedRHIs=SF_VULKAN_SM5

add a semicolon “;” at the beginning of the line.

and then

Remove the semicolon “;” from the beginning of the line

; +TargetedRHIs=GLSL_430

and uncomment it.

There is no need to pass the

-opengl4

option to the

[UE4_InstallPath]/Engine/Binaries/Linux/UE4Editor

command line.

message

Warning: OpenGL is deprecated, please use Vulkan.

Click “Ok”.

This way you can avoid freezing and crashing Unreal Engine 4 for Linux.

$ vulkaninfo | grep apiVersion
apiVersion = 0x401066 (1.1.102)

My GPU supports Vulkan 1.1.102
This is a bug in Unreal Engine 4 for Linux.
Even if it’s deprecated,
EPIC GAMES should default to
+TargetedRHIs=GLSL_430
during freeze and crashed versions of Unreal Engine 4 for Linux.

Japanese translation
日本語訳

[UE4_InstallPath]/Engine/Config/BaseEngine.ini

この設定ファイルの

+TargetedRHIs=SF_VULKAN_SM5

の行の行頭にセミコロン「;」を付けてコメントアウトします。

そしてそれから

; +TargetedRHIs=GLSL_430

の行の行頭からセミコロン「;」を外しコメントアウトを解除します。

[UE4_InstallPath]/Engine/Binaries/Linux/UE4Editor

のコマンドラインに

-opengl4

のオプションを渡す必用はありません。

メッセージ

Warning: OpenGL is deprecated, please use Vulkan.

「Ok」をクリックする。

この方法でLinux版Unreal Engine 4のフリーズとクラッシュを回避できます。

$ vulkaninfo | grep apiVersion
apiVersion = 0x401066 (1.1.102)

私のGPUはVulkan 1.1.102をサポートしています。
これはLinux版Unreal Engine 4のバグです。
deprecated(非推奨)だとしても
EPIC GAMESさんはフリーズとクラッシュしている間のバージョンのLinux版Unreal Engine 4につきましては
+TargetedRHIs=GLSL_430
をデフォルトにすべきです。

Thanks. I tried this and it worked, though on my PC, it took UE4 Editor about 30 minutes to compile the shaders, for some reason.

Hi,

Good news.

This week I recive e-mail from Epic Game about my bug submission :

So I tested the 4.25 build on Linux Ub 18.04 with Mesa and all is ok now.

I finally got it working by downloading the recommended NVIDIA drivers for Ubuntu as it allowed for 3d acceleration I have no crashes, and mine would crash as soon as the editor opened. This is the tutorial I followed for downloading the NVIDIA drivers -https://linuxconfig.org/how-to-install-the-nvidia-drivers-on-ubuntu-18-04-bionic-beaver-linux

I always downloaded the Vulkan drivers with this:


sudo apt-get install mesa-vulkan-drivers mesa-vulkan-drivers:i386

I hope this helps someone else.

1 Like

For my Geforce 970m , ubuntu 18.04 ue4.26
been running great for a day now, before it was crashing after the project would load.
Hope this helps .

sudo apt install vulkan-sdk-runtime
sudo apt install vulkan-tools
sudo apt-get install mesa-vulkan-drivers mesa-vulkan-drivers:i386

Changed my /UnrealEngine/Engine/Config/BaseEngine.ini , to this
bSupportsVulkan=true
bSupportsVulkanSM5=true
bDetectVulkanByDefault=true