Download

Ue4 scene is lit without lights in scene help needed

Hi my scene is being lit without any lights in my scene and i can not figure out why as I do not want this I want it to be completely blank so i can add my own lighting in.

I have tried deleting all the lights, fog and sky sphere and the directional lighting but there scene is still being lit and can not find out how. I used the default scene to create a my scene.

Scene lit with no changes made

2463264b0c5acb8dd2ba6959d9c23b4603e67efb.jpeg

Scene after everything has been turned off but is still lit
cd86548f4fc126059d416f72959700fc32d6bac9.jpeg

Can some please help me with this thanks need to fix this asap for my uni module.

Hi I had this a while ago. What gave me the results I wanted: Click the settings button above the scene viewport. Click World Settings. Under Lightmass, set Environment Intensity to 0 or a lower value. (Also, rebuild lighting after if nothing appears different.)

Hi minderaser thanks for the tip but unfortunately it did not work just resulted into the following:
Cgane envrionemnt intsesity.JPG

Might be worth a try to disallow static lighting in the projects rendering settings, rebuild lighting, and then enable it again.

Hi Mikand79 I can not find the settings you have mentioned under world settings or I might be going to the wrong place not completely used to ue4 and i am using 4.4 if that makes any difference.

thanks

Its in the Edit menu, Project Settings, then the Rendering category left, Lighting box right, called “Allow static lighting”.

Rebuild lighting after you disabled that and look if it gets dark.

Thanks for the help but still not working

managed to get it working fro some reason the settings for the directional light changed without me even changing them once i had reset them and deleted the light and rebuilt the lighting the scene went black.

Thanks for the all help anyway

Custom light and fog.JPG

Hi! I think I have the exact same problem with my scene, can you be please be more specific how you fixed it :slight_smile:

Here is my problem in more detail:
https://answers.unrealengine.com/questions/349609/scene-still-lit-even-though-all-the-lights-are-off.html

I had the same problem and had to delete the light and rebuild scene then add the light back.

Hi there,
If someone still have the same problem, you may try this:
Turn the sky light from Stationary to Static. It solved the problem for me.

The issue was the Directional Light had been baked, which remains after the actor is deleted until lighting is rebuilt. In the first screenshot, the shadows show the preview text, which means it was casting whole-scene shadows and was not set to use CSMs, meaning it was a Static/Stationary Directional Light. But in the second screenshot, the light had been removed so the preview/dynamic shadows were no longer there, but the static/pre-baked lighting and shadows remained.

If you want to get rid of baked information, you can do a quick light bake with World Settings > Force No Precomputed Lighting enabled. Once it’s checked, you can rebake which will remove all Lightmap information. All Static/Stationary lights will appear disabled, but if you click on them and disable/enable they will appear as unbaked and dynamic until the next light bake or you change the mobility. Uncheck the Force No Precomputed Lighting option before you bake again.

I was thinking this thread may be applicable to my issue but not sure. I was having a whole different issue where my sky background was almost pitch black no matter what I did. I then created a new level/ map in the project using the Default Project Template that already has the skysphere blueprint, direct lighting and skylight in it properly. I then selected all meshes in the previous level/ map and copied and pasted into the new level/map. Now the sky is correct but the lighting is seriously blown out in my interior where before on the other level it was not. I found this thread and did some of the things mentioned in here to no avail. I turned off ALL lights including emissive objects along with the skyshpere. I also DELETED the skylight and directional light. Nothing changed in a new light build. Still seriously blown out. How is that even possible???

Well, I solved the problem without understanding why which is very frustrating. All of my lights I had set up in my interior on the level/ map that was not showing the skysphere lighting properly was working perfectly fine. Just the sky light was acting up. I then make a new level and that issue disappears only to now have the interior lighting totally blown out. I tried deleting/ turning lights off and doing new light builds but the blown out scene remained. I then reduce all of the intensity levels of the lights to super low and left them on with a new light build and that worked. Absolutely none of this makes sense. How is the light intensity good on one level but so drastically different on another level without changing settings after copying all assets to the new level? It just doesn’t add up but I need to get things done so I guess I’ll just move on without really understanding what happened.

If someone figured this out. I have this problem too, doesn’t make any sense. I’m trying some VR archviz. Following some exercises, with different models to try different set-up. But there is a model that when i import (migrate), however, in a blank project, or VR template, low res, highres… which ever. The map load with lights blown out. I can’t figure out the difference between this one and the other maps that don’t do this.

Thank you ! that worked for me. Pitch black… :slight_smile: