Download

UE4 Running Painfully Slow

I have no idea why but everything in UE4 is very sluggish and almost impossible to work with.

PC Specs:
i7 6700k
32GB DDR4
4095MB GTX 980

I’m pretty sure my pc can run this program flawlessly.

Any help would be great.

maybe your os is too lag

you need clean it

If it wasnt like that before,run some cleaner program to search if the pc is doing some bitcoin mining.(i reccomend malwarebytes)

When I first switched from cryengine to UE4 I felt the same. But after a while I got used to it.

What kind of framerate are you getting? Is it feeling sluggish in the UI itself, or just the framerate that’s low? There are some programs that sometimes interfere with the UE4, such as a few versions of EVGA Precision. Try closing background processes and see if it helps.

Maybe try launching a project in windows safe mode without opening any other programs and testing performance? Make sure you have the latest video drivers.

I’m up to date on everything and it’s practically a clean install of windows. Malwarebytes says I am fine. Although it seems as though after 8 hours it’s running perfectly now. Thanks.

That’s odd, I have a GTX 980 and it works fine

Now it has come back but it seems as though whenever I put my mouse over a folder or click on and of the menu buttons it slows everything down on my pc. Audio becomes laggy, videos and graphics are sluggish.

I found this video that someone else made that has the exact same problem as me. Note the fps while going over the UI.

https://youtube.com/watch?v=FtYhuVDgE08

Have you tried closing all browser windows?

I haven’t actually used UE4 for a while but I have either the same or a similar issue and closing browser windows did the trick for me, IIRC it might have been something to do with browsers (or perhaps other software) using hardware acceleration.
Specifically things like youtube etc.

I’ll have to try that, although sometimes it works and sometimes it doesn’t. It’s really a 50/50 and I’ll just close and reopen till it works or Just verify the install and that usually does the trick. But it is still annoying.

There seems to be no real reason for the ue4 editor to run like it is on a 486 cpu. When I started with unreal engine 4.0 I had a dual core, it ran fine. Then about 4.8 I had to upgrade my video card and my cpu to quad core and a gtx 650, it ran fine. Now I have just upgraded to a gtx 1050 and a 8 core 4.0 MHZ with turbo and it is running like I am on a 386, it doesn’t even dent the cpu or ram… Throughout the last 3 years I have asked this very question and there simply has been no answer but “Send me your dxdiag” then no response. I don’t think optimizing their toolset is really a big priority.

I can confirm that the CPU is not the problem because I have the i7 6700k an it is running perfectly.

Thing is ’ you guys make video games but!!!

But you guys cant even solve the most logical problem. What could slow Unreal engine … idk maybe your Old Hard disk drive… Try upgrading to an ssd. See the pain is gone.

[SOLVED] It appears that DirectX 12 needs to be used but isn’t being launched/used/whatever when the UE editor is launched. My solution was to find the shortcut that launches the *.exe and add *-DX12 *to the target properties.

I navigated to the exe’s shortcut by opening the start menu, finding the button, right clicking on it and selecting More> Open File Location. This took me to the folder where the shortcut is located. Optionally you might be able to find it in your Programs folder located in the Start Menu directory. Mine was located here:

  • …Users > me > AppData > Roaming > Microsoft > Windows > Start Menu > Programs > UE4.18.0

Right click on this shortcut > General > Target

Inside this Target cell is the location of the targeted exe. All I did was add a space then *-DX12 *to the end of it. That’s all. I now maintain a healthy fps no matter what part of the UI the mouse hovers over.

Original post follows ++++++++++++++++++++++++++++++++++++++++++++++++++++++++++

I’m having the same issue. The FPS is awesome until I hover over the UI. That’s when it drops to 1.8fps. Has anyone found a reason why this is happening? I’m wondering if there’s a pref setting being missed or something. It’s happening on both versions installed on my machine:

  • UE4.18.0
  • UE4.14.3

Workstation specs:

  • Windows 10 64-bit
  • Intel i7-6950x @ 3GHz
  • 128GB DDR4 SDRAM
  • Nvidia Titan-X (Pascal)

Thanks in advance.

Uh can someone confirm this? It seems like such an odd bug and oversight that DX12 isn’t started by the engine.

What version are you running?
I have run from 4.8 to 4.18 and i have yet to notice any slowness.
Is there some details you can provide, like, specifically when its slow?
when its not slow?
system specs?
size of project?

Did the post before yours with the resolution not help you?

Hi, I have the same problem, If I right click on the editor the frames will go crazy then If I right click outside unreal all go back to normal.

I’m also running a GTX 1080 on a i7 6700k and this is UE 4.18.2 with a new “Third Person Project”

https://youtu.be/zWTuquqCZ60

I don’t have this problem on a similiar machine with a GTX 1070 and i7 6700 ( not K version )

I was having the same issue - slow when windows aren’t maximized, slow when popping up tooltips etc. I have an i7-7700K and GTX 1070, Windows 10.

In my case, the problem turned out to be the NVIDIA GeForce Experience overlay. After turning it off, editor runs buttery smooth 100% of the time.