Download

UE4 previous versions - Low FPS with version 4.1

Hi,

is there anyway to go back to previous versions of the engine?, I got 4.1 and its unusable, in 4.0.2 with realtime and show FPS turned on I was getting about 80 FPS in the viewport so it ran perfectly smooth but with 4.1 I am only getting about 2.5 FPS witch is ridiculously bad (that 2.5 FPS is in tappychicken, I used to get 30 FPS playing in the shooter demo but as I only get 2.5 in tappy the shooter clearly wont run now).

You can pick the previous version from the launcher.

thanks jacky, didn’t see that (probably just too annoyed right now:p)

I don’t know what’s wrong with 4.1 though, I just tried opening the same project in 4.0.2 and 4.1, I found that the project was running at 54 FPS in 4.0.2 and only 2.4 FPS in 4.1 (that’s in viewport but not playing), that’s strange right?

Yeah, and i’ve already seen a couple of people having FPS issues(not me), don’t know whats up with that. It may be a driver issue.

I thought it might be a driver issue or the graphics card itself because its slightly outdated but I found another strange thing, when my project is running in 4.0.2 my CPU is at 26-30% (UE4 using 15-18%) but in 4.1 my CPU is at 100% (UE4 is using everything not being used), I think it may be a bug or something.

How long have you kept 4.1 running so far? It may be compiling shaders in the background if you havent waited long. You should post this on Answerhub with your dxdiag log if you’re sure that’s not the issue though.

left it 10-20 mins and my CPU dropped to 97%, UE4 using a rough average of 90% of my Cpu or at least that’s what the task manager says so I dunno. I would post it on the answerhub but I hate that place, I’ll just stick to using 4.0.2.

anyway thanks for the help:)

The performance issues for me seem to be related to either Slate or the editor, plus in-game performance drops from about 40 fps to about 3 with everything on low (granted it’s on a laptop, but the performance of 4.0.2 was at least playable).

I say they could be related to the editor because even hovering over icons in the project browser without an actual project open (so no 3D environment to render) seems to take around 3 seconds for the on hover effect to register.

I was planning on looking into the code to see if any obvious integrations could have caused the issues, so I’ll just post an issue on Github if I find anything.

I am using a laptop as well but all the other versions of UE4 I’ve had so far have ran just fine, its a very weird thing to start happening:p.

Well I guess we have to wait for new drivers to come out, but 4.1.0 seems to run fine on my side. which CPU are you guys running? mine is only running around 20% cpu usage and I am running a i7 950 3.3ghz

Hi smokey13,

Can you please let us know which graphics card you are using?

Thanks

I think I just found the problem, 4.1 is not using the dedicated graphics card even though its set to high performance in the catalyst control centre witch means its using the integrated graphics, 4.0.2 is set to high performance as well but does use the dedicated GPU, I am going to see if there are newer drivers and post back in a min.

ok that did nothing, I did notice that when I start 4.1 I get a blip of power to the GPU but then it turns off.

Can you enable stats in the editor viewport (in the menu under the first arrow button in the viewport) then type in “stat scenerendering” into the command box in the top right corner of the editor then post that screenshot? It would also be helpful if you would also screenshot the results of “stat slate” as well. You can type in the same command again to turn off the stat.

Also, does your performance improve dramatically when you disable realtime?

I saw in the release notes that you can apparently choose which graphics card the engine is using, have you tinkered with that option yet? It will choose automatically unless you manually change it, it may have indeed chosen your integrated.

4.1.0 have some problems

my computer can’t handle now UE4, i have my cpu at 80-90% with a default third person map without hit ‘play’.

4.0.2 was fine.

that release have any bug. 4.1.0 ins’t usable, lagged and not only ‘playing’

i have 7790.

Yea your not the only one, i run UE 4.0.2 fine and at good speed on my i5 1.6ghz, 8 gb ram with intel hd 4400, now i can’t run 4.1 period it take forever to load then none my input works for 10 min then it just freeze and freeze forever. i had to use my task manager to close exe.

and i remove 4.0.2 :frowning:

add “get class” in a blueprint and then try the return node freeze UE more :confused:

Those are really low specs to be honest. I’m seeing others post issues with 4.1 framerate too though, with higher end graphics cards. Mine is for the most part the same, although visually the reflections are looking very grainy and my environment is reflecting my character at very far distances. I’ll probably be sticking to 4.0.2 til some of these things are resolved.