UE4 Nvida Waveworks - Bounds Scale

Hi there,

I am experiencing a problem with a very large scene and Nvidia Waveworks. When I move away from the sample waveworks_gdc_map island the waveworks plane flickers on and off. It works fine when i am near the island everything works fine. i tried changing bounds scale but nothing seems to stop it from flickering on and off the whole mesh.

Any help would be greatly appreciated!

Thank you!

When the camera faces down the plane disappears…

We’re having the same issue, we think it has to do with some kind of optimization where the wave plane is not rendered when out of a certain range and not within the field of view (as it happens at the edges of the sky dome, but not when looking a the island).

exactly… bounds scale has no effect… so it seems it’s hard coded into wave works. I have tried enabling World Origin Rebasing as my scene is using world composition but also has no effect.

Found the solution. Edit the blueprint and add a cube into the blueprint. Drag it to the top and make it the parent. Then in bounds scale of the cube change that to something really big like 5000000… then change the bound scale settings for the children below to use parent’s scale and voila!

Camika, please see answer below if you’re still experiencing this problem.