UE4 lighting rendering in purple

So I’ve just installed Unreal Engine 4 (via GitHub) and, after having to set it to use opengl3, I tried to use one of the pre-made projects and it came up looking like this:

After messing around a bit and trying to fix the problem, I realised that the problem went away when I set the display to ‘unlit’.
I’m new to this so it could easily be something really obvious.

Thanks in advance

Nah, I get this in every template and it’s been like it since I loaded it up.

According to everything I can find online, It seems like my graphics chip (AMD 8570D) can support up to openGL 4.5 but I can’t find a driver that’ll give me the correct openGL version.

This is all the information I can get about my openGL version and drivers and such from the terminal:
OpenGL vendor string: X.Org
OpenGL renderer string: Gallium 0.4 on AMD ARUBA (DRM 2.46.0 / 4.8.0-54-generic, LLVM 5.0.0)
OpenGL core profile version string: 4.1 (Core Profile) Mesa 17.2.0-devel - padoka PPA
OpenGL core profile shading language version string: 4.10
OpenGL core profile context flags: (none)
OpenGL core profile profile mask: core profile
OpenGL core profile extensions:
OpenGL version string: 3.0 Mesa 17.2.0-devel - padoka PPA
OpenGL shading language version string: 1.30
OpenGL context flags: (none)
OpenGL extensions:
OpenGL ES profile version string: OpenGL ES 3.0 Mesa 17.2.0-devel - padoka PPA
OpenGL ES profile shading language version string: OpenGL ES GLSL ES 3.00
OpenGL ES profile extensions:

Yeah, I think I’m just going to have to hold off until I can get something more reliable. Thanks for the help though.

Do you get the same thing in other templates too or just this one? Or did you check the postprocess setting, maybe accidently changed while playing with parameters?

What drivers and what hardware are you using?

Your drivers are most likely to blame. It is not a good sign that you had to use OpenGL3 in the first place, unless your hardware does not support OpenGL4 (which is very unlikely these days).

Thanks for the info. I am afraid the problem is your drivers. You may try to work around it by disabling post processing (“show postprocess” toggle in console), but if you want to narrow it further down you will have to dive into the realm of RenderDoc and graphics debugging in general.