UE4 launcher cant install, fail at Directx install

I have windows 8.1, and I just bought my subscription. After clicking the install link from the dashboard, the MSI file will begin installing as usual,but it will fail everytime when it gets to the directx installation. I know for a fact that my directx is up to date via running dxdiag. I made sure that everything I could think of was updated, like my geforce cards, etc. but still no completion. I’me very confused at this point. I was able to install the launcher on my other pc, which is win 7, without the smallest hiccup. After following as many posts on here as I could find, I think I might have this " code -9 " that has been mentioned regarding directx, BUT in win 8.1 you cant just remove DX and reinstall, that I’m aware of. and I followed the tutorials for fixing “-9” but to no result :frowning:

Hi Iamtheoblique,

I’m sorry to hear that you are experiencing this issue. I am bringing in an engineer to try to help troubleshoot the case.

There is some information you could provide to potentially help us out. Please provide the latest log located in: C:\Users\USER.NAME\AppData\Local\UnrealEngineLauncher\Saved\Logs

And also please upload your system’s Dxdiag report.

All reports can be placed in a .zip or .rar file and attached in a message.

Thanks

Have you also tried running the installer as Administrator?

I’m not sure if my dxdiag report got uploaded or not, as I do not see it here I will post another one when I get home. Yes, I have tried to install as admin, but in win8.1 when installing an msi file there is no option to run as administrator. Like I said previously, I have poured through the forums and have tried ever thing I can think of.

Can you be more specific about what is ‘failing’? For example, does the installer just disappear or do you see a prompt that says the installer failed? We’ll be able to help further if we get your installer logs. From that we’ll be able to see exactly where it is failing and try to figure out why. You probably saw a few threads describing the process of getting an installer log but if not, you can try the steps outlined in the MSI (Windows only) installation issues section of this Link

Thank you for your reply, the install package for the launcher starts and copies files, then hangs when it gets to the directx portion, then pauses and gives an error message about companies, then “rolls back” and then finishes with a message saying that the installer finished “prematurely.” I believe I might be getting the directx “error code -9” that others have described. I have done my best to pursue that particular end but haven’t had any luck. I will post my installer log as soon as I can

ok, now that i am home and sitting at the computer in question, I followed the link provided to generate an installer log. The command (msiexec /i C:\UnrealEngineInstaller-1.4.1-2110405/L*V C:\UnrealEngineInstallerLog.txt) only generates a small properties window with the following text:

**Windows ® Installer. V 5.0.9600.16384
msiexec /Option [Optional Parameter]
Install Options

Display Options

Restart Options

Logging Options

Update Options

Repair Options

Setting Public Properties

Consult the Windows ® Installer SDK for additional documentation on the
command line syntax.
Copyright © Microsoft Corporation. All rights reserved.
Portions of this software are based in part on the work of the Independent JPEG Group.**

Also, NO log is generated at the location specified, JUST this generic properties window. I had to cut out some of the text to fit in this reply, but I’m sure you can tell with properties window I’m speaking of.

link text

also i placed the installer msi in the root on my hdd (C:) and got the same message, “There is a problem with this windows installer package. A program run as part of the setup did not finish as expected. Contact your support personnel or package vendor.” Once you click OK, the installer starts to roll back.

Looks like there is a slight issue with the command you entered to get the installer log. If the installer is on your root drive, the command should looks something like this:

msiexec /i C:\UnrealEngineInstaller-1.4.1-2110405.msi /L*V C:\UnrealEngineInstallerLog.txt

so no ideas so far on this one?

Sorry, I should have been more clear. We can’t help further until we get your installer log. The info your provided was not the actual log. See my previous message because it looks like you may have run msiexec command incorrectly.

unfortunately, even that command will not return a log, just an error. i’m trying to research how to generate logs in windows 8.1, and I can get logs for other things, but not this. :frowning: I’m just lost as to what to do at this point. I think i’m going to have to just give up on the unreal 4 engine and go back to Unity :(…

is there anyway to run the installer without checking/updating directx?

i have finally gotten a different error message in trying to generate a log, and it still says that there’s no valid installer package. is there anyway to install the launcher NOT as an msi??

If I can make a suggestion, download the source code, follow those instructions. I had no problems going that route.

  1. grab the two Required.zips and the latest 4.2.1 zip
  2. Unzip them wherever you want the editor built from.
  3. Make sure other requirements are met, specifically Windows Kit
  4. Follow instructions further…

I had no issues getting everything up this way.

As Telimaktar mentioned, you do have full source access to the engine versions but the only way to install the launcher is by using the Windows Installer msi file. I would like to help with the issue you are running into. I’ll try to outline some more detailed steps for getting the log file (I’ll try to target Windows 8.1 but I suspect many of the steps will be the same on all windows versions). If you still run into issues, perhaps you can show me some screenshots of where the .msi file is located on your system, screenshots of the commands you entered, and the results of those commands so I can help further. If you would prefer to go at it alone, there are a ton of online references for Msiexec and the arguments it expects: Link, Link

Here are some windows 8.1 friendly steps to get the installer log:

  1. Create a temporary folder on the C drive called MyTemp (C:\MyTemp)

  2. Move the msi file you download to C:\MyTemp

  3. Start a cmd prompt as administrator (There are a ton of ways to do this in win8.1, pick one from here: Link)

  4. Make sure the command prompt says ‘Administrator’ in the title bar

  5. Enter the following command into the command prompt(Make sure to replace UnrealEngineInstaller.msi with the actual msi file name):

    msiexec /i C:\MyTemp\UnrealEngineInstaller.msi /L*V C:\MyTemp\Log.txt

Once you have a log, zip it up and post it here so we can have a look. If you run into an issue, include some screenshots and we’ll help.

Ok, after following step by step, I think i see what I was doing wrong in getting my logs. I finally got a log, i hope i have what you are looking for :slight_smile:link text

Thanks for providing the log! Using that, I was able to confirm your speculation that DXSETUP.exe, which is packaged in the installer, is having an issue installing. According to the log the return code is -9. This means your issue is the same as the one in this thread: Link

Unfortunately I don’t have a workaround for you at the moment but there were changes made to the installer recently that will allow you to get past this issue. Those changes will be available in the next launcher release. Once that is available I’ll update this thread with more info.

well, there’s a new installer package available, and still the same hang in DXsetup.exe :frowning: Hopefully 4.3 will address this so that i dont have to cancel my subscription :frowning:

The latest installer has support for a command line parameter that will allow you to switch off the install of the DirectX dependencies. If you are still running into the issue where the DirectX portion of the Unreal Engine Installer is failing with code -9, try this:

  1. Manually download and install DirectX from here(DO NOT SKIP THIS STEP): Link

  2. Download the latest Unreal Engine Installer

  3. Run the installer using the following commandline(replace C:\UnrealEngineInstaller.msi with the path and name of your downloaded installer):

    msiexec /i “C:\UnrealEngineInstaller.msi” SKIP_DIRECTX=“1”

unfortunately, this command gives an error :frowning:

Did i perhaps miss type something?

msiexec /i “C:\UnrealEngineInstaller-1.5.1-2214492” SKIP_DIRECTX=“1”