UE4 - How to activate Niagara VFX while using Sequencer for Cinematics?

Hi, it´been imposible to actívate a Niagara VFX inside the Level Sequencer, no option to switch actívate ON and OFF, like you do with Legacy Particle System, where you simply choose “Deactivate, Activate”

How to make it work?

Facing the same issue. It’s obviously possible to key the visibility but then it still has to compute the effect in the background, so it’s not ideal. Anyone knows the proper way to do it?

what happens when you render output movie with ‘simulate’ on ?

There’s a System Life Cycle track under NiagaraComponent. You can use that to activate and deactivate niagara particles from sequencer.

There seems to be a limitation though in that only one life cycle track is allowed per Niagara component. Which means it’s not possible to toggle one system on and off.

​Yeah, it looks like you can have only one life cycle per Niagara system. But it is still possible to activate and deactivate it with it. When you right click on the life cycle and look into the properties, there are some life cycle settings, so you can set it to be active only during that life cycle and deactivate it automatically when it ends. You can also select different modes of activation and deactivation based on what you’re looking for. So basically it will be active during the “red” Life Cycle track, and it will automatically turn it off afterwards.

https://forums.unrealengine.com/core/image/gif;base64
NiagaraSequencer.png

1 Like

Yea tried those. Still no luck activating a system that has been deactivated on the same track. Does it work for you?

It looks like for whatever reason Unreal doesn’t allow that. There are two workarounds for it though. One of them is expose spawn rate from Niagara as a user variable and than you can control it with the sequencer - so you could set it to 0 when you want to turn off the particle and to whatever number you want when you want to activate it. The other way would be to have that particle system as spawnable in Niagara and respawn it, or spawn multiple systems.

3 Likes

Okay, I found a solution for it. It’s still a bit of a workaround but it should work exactly how you want. Just add event track under your particle system and add trigger event. Add a keyframe, right click on it and under the Event select either Activate (NiagaraComponent) or deactivate (NiagaraComponent):


https://forums.unrealengine.com/core/image/gif;base64
​​​

By default that event will be called only in the game but if you right click on it, under properties there’s an option Call in Editor, so just tick that and it should work exactly like you want.

8 Likes

It’s working, thanks SouryGame! Those parameters should just be exposed directly. Well maybe in the future.

1 Like

Just in case someone finds it useful:

4 Likes

Thank you very much #9 SouryGame right answer helpful。thankx again。

I made a fire using a Niagara system and I’m using the “Point Lights Component Renderer” to make the fire’s light cast shadows on the wall. It works well in simulation but can’t see it in exported PNGs. Wondering how can I make this “Point Lights Component Renderer” be active while exporting? Thanks!

Exposing the SpawnRate user variable and setting it to the value or zero was perfect, thank you friend!

I know its an old thread but still haven’t found a working solution whereby editor viewport resident particles can be see in render output [either Movie Render Queue or legacy Sequencer Movie Capture] in UE5.0.1

camera is in bounds of particle actor, auto activate is off, and attach to parent bounds on.
tried numerous permutation in sequencer track adding event trigger to control niagara activation as suggested here; as well as using the system life cycle to try to do the same…but no dice…

why i this such a mystery!?:wink:



A

1 Like

I’m pulling my hair out with this same issue. I have the Niagara system in the sequencer and I’m key framing the spawn emitter. When I play the sequence the particles spawn perfectly, but when I render the cinematic using the Movie Capture they don’t show up. What’s crazy is that sometimes the do show up the first time or two I render, then at some point not at all. I’ve tried all the things in this thread, and nothing works.

Noob here – can you be more specific about “simulate on”? Where is this setting? I’m having this same issue that the Niagara system doesn’t activate in the render.