UE4_HeroTPP Animation Issues ((Help))

I have found an issue with the UE4 Hero TPP mannequin or animations. I am using the HeroTPP and when he jumps, he is running/jogging. I look in the anim BP and it shows the regular jumping, but that’s not what plays. I haven’t changed a thing since adding it to my game beside choose it for the anim to use for the main character. Is this a bug? Here are some screenshots to show I haven’t messed with anything. Thanks for any help…

Hey there, i didnt really understand the issue, can you explain a little bit more in detail?

Yes sure, I am using the Side Scroller Template.
The Anim class it had as default was ThirdPerson_AnimBP.
I downloaded the UE4ASP_Hero from Unreal market and it has a UE4ASP_HeroTPP_AnimBP that fits better with my game.
But when I jump, it walks while in air instead of playing the Jump animation.
I looked in the State Machine and the animation it shows is a Jumping anim not Running.
Why is it running in the air and not playing the animation it says it should?

Yes it is the Animation Starter Pack. I will add a gif to help show my issue.


What is the actual name of the pack in the Unreal Marketplace? Is it the Animation Starter Pack? I’m saying this because it would be easy if test it out myself to find the problem. If you could send a project with that issue isolated that would be ideal.

My guess is that the transition rule to go to jog is if the speed is > 0, so maybe what is happening is that since you are jumping you are still having Z velocity which also counts as speed. If that is the case then you need to set the Z velocity component to 0 when you are calculating the speed so it doesn’t influentiate.

I’m sorry, but I am lost on what you are talking about. Can you explain a little more? The transition rule to go to jog speed is > 10. Should I change it to 0? Thanks

I’m sorry if I am now going to be annoying, but I am not very good at setting up anim BP’s that’s why I was hoping to just add the pack and done. I don’t know how to set GetVelocity up or see it already applied. I can’t find Is Falling in the Movement Comp. I am looking for tuts on get velocity with vector… Thanks

The speed variable in the animation blueprint has the vector length value of the GetVelocity of your character. If you jump in place then your Velocity will be (0,0, a value greater than zero) so speed will probably be bigger than 10 so that what’s probably causing the state change to go to jog instead of jump. What you need to do is either add an extra condition to go to jog and make sure that the character is in the ground (you can get this by checking Is Falling on the character movement component), or you have to change the way you compute speed so it ignores the Z velocity, just multiply Get Velocity with Vector (1,1,0) and do the vector length from that to set speed and you should be good to go.

If you go to the event graph of the animation blueprint and find where speed is being set and do this:

Okay, I did that. Now when in idle and jump it jumps with no animation. jog/run still runs while jumping. There are no other set speed vars.

How do I get the Jump animation to play instead of nothing?

I’m not sure if it is/was ever set…?
This is all the Jump connections.

Kind of no, the only 2 spots it is even used is in CanJump as an output addition and to be called in the event graph. Searched Jumping for reference, none exist.

I am assuming it should be? If so where?

Can you show me where the Jumping variable is being set there?

That is not the variable i’m talking about. In the animation blueprint you have a variable called Jumping, check if it’s set in the event graph.

If right now, enable jump is set to true when you press jump and to false when it lands, then from Idle to Jump the only transition rule you need is Enable Jump connected to the transition. Can you show me the transition rule for jog?

I mislead you, the jump transition should be Enable Jump connected to a not, because when you press the jump button Enable Jump is set to false.