Download

UE4 freezes my PC

I can’t use Unreal Engine at all as the editor freezes my whole computer. Not even the task manager is able to kill the process nor you can do anything. I had to hard reset my computer which is odd. It happens all the time when you launch UE4. I have the following hardware configuration:

ASUS Zephyrus S GX531GX_GX531GX

  • Processor: Intel(R) Core™ i7-8750H CPU @ 2.20GHz 2.21 GHz
  • OS: Windows 10 64-bit
  • RAM: 24GB DDR4 2666MHz SDRAM
  • Storage: 1 TB M.2 PCIe 3.0 SSD
  • VGA: NVIDIA® GeForce™ RTX 2080 8GB GDDR6
  • Display: 15.6" FullHD (1920 x 1080) Wide View IPS
  • Refresh Rate: 144 Hz

I managed to create a dump file from the frozen process and it shows the following:

# Child-SP RetAddr Call Site

00 000000f52b97b408 00007ffeb3dca34e ntdll!NtWaitForSingleObject+0x14
01 000000f52b97b410 00007ffe62e5ae9c KERNELBASE!WaitForSingleObjectEx+0x8e
02 000000f52b97b4b0 00007ffe8a0a301d UE4Editor_Core!FWindowsPlatformMisc::VerifyWindowsVersion+0x2fc
03 000000f52b97b600 00007ffe8a0e28cd UE4Editor_RenderCore!FInputLatencyTimer::GameThreadTick+0x61d
04 000000f52b97b790 00007ff6ac50cc71 UE4Editor_RenderCore!FRenderCommandFence::Wait+0x2d
05 000000f52b97b7c0 00007ff6ac52113c UE4Editor+0xcc71
06 000000f52b97dac0 00007ff6ac52121a UE4Editor+0x2113c
07 000000f52b97ec10 00007ff6ac53527d UE4Editor!GuardedMainWrapper+0x1a
08 000000f52b97ec50 00007ff6ac537faa UE4Editor!InitializeModule+0x23d
09 000000f52b97fcb0 00007ffeb60d7034 UE4Editor!InitializeModule+0x2f6a
0a 000000f52b97fcf0 00007ffeb66bd0d1 kernel32!BaseThreadInitThunk+0x14
0b 000000f52b97fd20 0000000000000000 ntdll!RtlUserThreadStart+0x21

I noticed that UE4 freezes faster if the raytracing is enabled.

Update: I changed renderer settings between Vulkan and DX12 but it makes no difference, the issue seems to occur after several minutes. If the issue happens, you cannot do anything as the computer freezes and only hard reset is the only option.

Please contact me if you need additional information.

Best regards,

Rajmund Kail

NtWaitForSingleObject simply means the thread isn’t running, but instead waiting for a driver or some other thread to complete some work. This could for example be waiting on the graphics driver, or hard disk driver, or something else. In this case, because RenderCommandFence is in there, it looks very much like a graphics driver issue.

I had a very similar problem with my Threadripper 1950X / GTX 1080 computer a while back, which may or may not shed some light on the process you might use to solve the problem.

This is not a problem with the engine, but a problem with one of:

  • the graphics drivers
  • the graphics card, installation, or cooling
  • the OS CPU drivers (yes, there is such a thing! but it’s kind-of hidden and automatically part of OS version updates)
  • the CPU, installation, or cooling
  • the BIOS support for all the above

For me, it would be even worse than just locking up the computer; it would hard-power-off the system! The problem turned out to be something related to CPU and probably AVX instructions or thermal protection, because after updating BIOS and re-pasting/re-attaching my CPU cooler the second time, it stopped doing it. I think it was BIOS – the first time I did it, nothing worked; when I did it again a year later, it solved the problem. The only other program that would cause this problem was Prime95 – all games would run just fine, as would memtest86, but not UE, and not Prime95!

Debugging these kinds of problems can be super frustrating, because there’s no good way to get signals about “what could be going wrong?” other than changing one thing at a time, and see if it helps. And, like in my BIOS case, if there’s no real solution available yet, then you’re Short On Luck and can’t make forward progress :frowning:

So, make sure you have the latest BIOS, make sure you have the latest graphics card drivers, and make sure you have the latest version of the OS. If all of that is tip top, there’s not a whole lot more you can do, unless you want to start tearing the system apart and looking for loose cables or poorly seated heat sinks/blowers.

Do you have hide taskbar turned on? There is a windows bug with it that causes system freezes with UE4.

Another thing, if you get freezes, there is a windows hotkey to restart your gpu driver: win+ctrl+shift+B

Well it makes sense but still I cannot put a finger on why only UE4 editor? If it is really a thirdparty issue, then other applications or games should produce similar anomalies too, right? For me, everything seems functional, except UE4. And the weird thing is there was no driver update nor Windows update at all. I’ve never encountered any UE4 freeze or crash until now.

Yes, it was turned on. I disabled this option for now and let’s see what happens.

Thanks for the kind advice guys. I’ll check everything you mentioned and let’s keep fingers crossed. It’s quite annoying for sure and I hope it gets resolved soon.

Different tools tweak the system in slightly different ways. I could run FEM simulations in CAD and video renders and games of all kinds, but the UE4 editor and a certain setting on the Prime95 program would crash (almost all Prime95 benchmarks worked, except a certain particular cache size, IIRC.)
It’s just the way it is. Computers are made by humans, and humans are fallible.

I have the a very similar problem and cannot seem to report it on neither the official Unreal Engine bug report form or the crash report window.

Please Note
This is not a normal crash/bug report since i can’t seem to report it in the official Unreal Engine bug report form. The situation is very dire and I really need to solve this issue quickly. This is why I posted the report here.

Another thing to note is that when the crash occurs, the traditional crash report window also freezes and is completely unresponsive. This means that I cannot send the crash report automatically to Unreal staff.

Problem:

I installed the UE 4.26 some time ago and would like to use it for a new project I had in mind. However, every time I create a new project and click anything in the UI, the whole engine freezes. The program is shown as “not responding” in windows task manager and when I try to kill the program from there, my whole windows crashes completely. At this point, nothing can be done and forced reset of the computer is necessary.

Reproduce:

Make a new project in Unreal Engine. Set Graphics settings to scalable 2d/3d and disable starter content. Use the default First Person kit. When the project loads up, click anything in the user interface.

Additional info:

I already tried reinstalling Unreal Engine and Epic Games launcher but the problem still occurs every time I try to create a new project. I haven’t been able to launch a single project succesfully since the problem occured first time. I tried to resolve the problem by searching for similar crash reports from google but wasn’t able to fix it. I have also switched my nvidia gpu from game driver to studio a driver but that didn’t help.

Link to project file (Including crash logs):

https://drive.google.com/drive/folde…wn?usp=sharing

PC specs:

GPU: Geforce GTX 1660Ti
CPU: AMD Ryzen 7 2700x
Ram: 16 Gb DDR4
System: Windows 10 Professional

This is not a problem with Unreal Editor. There is nothing Unreal Editor can do different. The problem is with your computer hardware, or the sottware/drivers/BIOS on the computer.
See above for a partial list of the things that could be going wrong in your computer to cause this kind of problem.

Same has been hapenning here, across different computers - No reason found.
Only on unreal :confused:

RTX 3090
Ryzen 3900X
64 Gb DDR4

I also have the same issue. Oh my ghost.

Same here.

I have my drivers up to date (try a few different WHQL Nvidia drivers for my GTX 1080 Ti), my bios too, windows 10 was updated yesterday, as for the cooling system, one can’t say that I’m at the top, but I can ventilate and open the tower and it doesn’t change anything.
I’m also on other game engines and I finished a few heavy games without ever having encountered this problem elsewhere.

Now, I’m sorry I didn’t find any way to reproduce the freeze.
Sometimes it happens after a few hours of work, sometimes after only a few minutes.

The last time it happened, I had my temperatures displayed we were on 45°C CPU, GPU 68°C, 55°C SSD.

But I must admit that after performing the hard reset, I had difficulty to recover the display! Everything remained black, I had to restart 3 times and under a single screen. So maybe it has something to do with my hardware. Who knows?

i have the same problem. i can launch the unreal and use it for a short time or a longer time. then it freezes and I have to restart my pc.

i have 1660 super
16 GB ram
win 10 home.

This should work since I managed to use dx 12 and raytracing on my 1080 ti.

since raytracing GPU light mass is the only one that gives perfect light I don’t want to have to go back to CPU lightness