Download

UE4 editor regularly crashing when testing VR projects [4.17.1]

Is it only me or someone else is also experiencing this? I am getting pretty regular crashes when testing VR projects in the editor (version 4.17.1). The crashes usually occur after ending the VR Preview mode and as soon as I edit something in the Blueprints. It is rather consistent. Just wanted to double check before I file it as a bug. Tnx!

Cheers,
Marco.

Hey @vr_marco, i`m also getting this issue after many times turn on/off VR Preview for testing bunch of stuff inside… I think this is nothing about new version because i get same issue with 4.16 as well. Crash depends on complexity of scene, i hope @epic staff can do something about it in future, more stable i mean. Cheers

Thanks @syhdesign . Definitely it is not linked to the complexity of the scene. I was working with a very simple project (basic level with only default materials) with almost no content beside a quite convoluted Blueprint for an actor… Definitely they need to work to improve the stability. I have forwarded the logs after each crash, so I assume they have plenty of evidences to work by now.

Cheers,
Marco.

i have the same. But it dissappears after building. Usually it happends to me when i change something in the LevelBp, compile it, and then delete it again. And save,… and then preview the game. Then when i hit Esc to go back to the editor it freezes. But after building of the level it’s okay.

I’ve had this happen countless times in 4.16, but since 4.17 I havent had it yet.

Happens for me randomly as well. both in 4.16 and 4.17 with the same project when I press ESC from VR Preview.

Indeed. Often it doesn’t crash right away though. It does as soon as you start editing something in a BP.

guys any1 found a workaround for this ?! its getting really annoying … everytime I run my project after 3rd/4th VR Preview I surely get crashed!

@alllesss I am working on an Asus and by uninstalling Sonic Suite 2 (and any other software that may be messing up with the DirectX pipeline, like post processing/screen capture) I was able to reduce the number of crashes after after VR Preview. To me it looks like a conflict in handling the DirectX SwapChain, but not sure where that comes from originally.

I’m getting frequent crashes in 4.18 while using VR Preview too. I think that for me it’s a fault with my project, but I’m unable to track down the actual reason. It’s like flipping a coin and there’s a 50% chance that it will either crash or work flawlessly.

One thing that sticks out to me in the log is this:

[2017.10.31-18.09.15:141][790]LogHMD: Initializing OVRPlugin session
[2017.10.31-18.09.15:176][790]LogOnline: Display: Oculus: FOnlineSubsystemOculus::Shutdown()
[2017.10.31-18.09.15:195][790]LogOnline: Display: Oculus: FOnlineSubsystemOculus::InitWithWindowsPlatform()
[2017.10.31-18.09.15:431][790]LogOnline: Warning: Oculus: Failed Oculus login. Not currently logged into Oculus. Make sure Oculus is running and you are entitled to the app.

But it seems to continue after that. There’s like 10 more lines about it loading, and changing match state to InProgress and all, and then the last one is:

[2017.10.31-18.09.15:985][791]LogWindows: Windows GetLastError: The operation completed successfully. (0)

still existing in 4.21.1

still existing in 4.21.2

@vr_marco : does it still exist in your setup?

I reinstalled OculusSDk and Codeworks 1r7. Did all the tricks and tips I could find on forums. Problem still exists. Filed a ticket at Oculus.

In my case the problem starts at loading a UE4 project in the editor. The output log states : LogOnlineIdentity: Error: Oculus: Failed the entitlement check: Missing entitlement

My OculusAppID is correct, I swapped Oculus for RistAppId. Did not do the trick.

@martin_vr did you tried to put the 2 parameters in your config:
OculusAppId
RiftAppId

once I had problems for entitlement and putting the 2 solve my problem.