UE4 crashes in material editor

I am Running Ue4 4.11 and everytime I try to import and add a texture in the material editor it crashes. I have the latest Drivers, last time I cheched it was April/23/2016.
I would love to fix this issue, It has been bugging me for quite a while now.
Thanks -Odyssious, Hezarou

Does it crash when you import a texture in the content browser?
Does it crash when you drag and drop the texture into the material editor?
Is it only one particular texture or all textures?
Could you post the text from the popup window which shows up on a crash?

It crashes when I place any texture into the material editor, and there’s no popup. It just sayes: " Uneal Editor has stoped working.".

Hi Odyssious,

  • Does this occur in a clean, blank project with no additional content or is it limited to one project?
  • Can you post your dxdiag here so I can take a look?
  • Can you post your crash logs and callstack here as well?
  • What steps can I take to reproduce this error on my end?
  • Have you tried verifying your engine build by going to Launcher>Library>Engine Version dropdown context menu>verify? This will check to see if any files are missing/damaged in your engine build and repair/replace them as needed.
  1. It happens in all projects clean or old. I have tested different settings, still no progress.
  2. Yes I can, I have the file here. How or what do I have to paste?
  3. Where can I find the log?
  4. I am not sure, The engine worked alright in the past. This is new for me.
  5. Yes I have.

if you get the dxdiag.txt, crash logs (which can be found at \Unreal Projects\PROJECTNAME\saved\logs) and put them into a ., you can upload the . here.

link text

What are the exact steps you are taking before the crash occurs? After looking at your dxdiag, it appears your computer is running an integrated graphics card and 6 gb of RAM. This is below our recommended specs and may be playing a role in the crash. If you have any steps I can try I may be able to eliminate or confirm this as the primary cause of the crash you are experiencing.

Well I import a .PNG file, all good. And when I place it inside the material editor it crashes. Yes I know 6GB of RAM is lower than the recomended, but I can assure you I have been able to run at max grafics at 30-50FPS and the rendering doesn’t take long.
I have tried using Png, JPG, Tga,Pbm and a few more.
The editor don’t like outside files…

Does this occur with any other files or is it limited to a particular material/texture that you are importing through various filetypes. What is the size of the file in question? For instance, is a 256x256?

The size is 512x512 mabie that’s the issue??
I’m not sure what is giving that crash, should I use a different size?

no, 512x512 is a power of 2 and a smaller image size. Can you send me the file? I’ll be happy to try the specific asset on my end and see if I can reproduce this on my end.

try importing this into a previous engine version, do you see the same error? I attempted to import and add this to a material and did not experience any errors or crashes on my end.

I do not have a previous game engine. I had to disinstall all game files and launcher since I had a problem with the instalation.

That’s fine. Try this. Open a brand new, blank project with no additional content in it. Try to import and use the material there. Do you see the same crash?

Ok, it imported fine. I got It into the material editor. It crashed when it tried to render the material

Unfortunately I still have not been able to reproduce this on my end. Do you have any other steps I can take to recreate this error?

Hi Odyssious,

We have not heard from you in several days. I am marking this as answered for tracking purposes. If you are still experiencing this error, please comment with the requested information.

I am sorry I haven’t replied in days, my computer has a literal meltdown. It works no longer. I am sorry I havent updated.