Download

Ue4 Animation blueprint character distortion error

All was fine until I changed an animation in locomotion to a corresponding one, it won´t go back, and I already saved the blueprint.Compliler says all is running perfect. I’ve checked everything on the anim and event graphs and cant seem to figure it out. Anyone have any ideas?


Heres the video.

Look at the scale of the grid of your character when retargeting, that doesn’t look right. It looks like your character is too small.

Nah, Its a bit smaller, but that doesnt affect the result, all the animations retarget fine. And as i commented before I did it before manually and it was all functioning correctly until I changed a necessary animation.

Fixed it by reimporting a couple times, error was from the original Anim blueprint, but now i’m getting this…Character rotation error - UE4 AnswerHub

Probably a mismatch between some bone orientations between your skeleton and the mannequin and a hardcoded value in the anim BP. You should make a copy of the anim BP and disable stuff until it’s working properly (and isolate the problem function), then take a screenshot of that and upload here.

If its not the Anim BP, It might be something to do with the Code in the Blueprint responsible for the camera rotation.

Nah, it’s the anim blueprint, because I use the same character blueprint for both, it works perfect with the mannequin blueprint, but when I duplicate it and retarget to my mesh skeleton that happens. I’m %100 sure that its the animBP

The bone orientation is correct, I had it working to a certain point when I did it manually. Its gotta be one of the nodes or node configuration.
I’ve made a copy and am looking into it now. Any ideas are welcome.

These are the turn in place and set character rotation functions, it might have something to do with this, but I honestly have no clue as to what to alter.

These are the eventgraph, Set Rotation, Set Character Rotation, Set root offset, and state1 and set rotation from that state( manage character rotation)

  1. In the video when trying to turn the character, the character’s mesh was flipping over and over with the wrong axis point…
    Was the mesh imported into the engine using the Unreal Axis settings?

  2. Is this a Blender mesh?

  3. Go into the Skeleton Editor and click Show Bone Hireachy, and send a screenshot
    if the bones are not looking the same as the Mannequin, and your character’s bones
    look more like a spider then the bones are getting all distorted and stretched and that twists
    and warps the mesh also.

Incorrect bone matching during the targeting will cause the bones to mess all up and warp the mesh.
but If the targeting is correct, then it could be the skeletal mesh itself is corupt. If the mesh was exported
from Blender, its known to have a bug to stretch out the bones or twist them when moving
the armature bones around when in object mode. It willl show up in the Skeleton Editor when you turn
the bones hireachy on when you export it out from Blender and then import in the mesh. The bones
will be rotated out of position or looked stretched.

if its a Blender Rig, reset the armature and export out again. And reimport, and see if the bones
are still stretched.

BUT IF ITS THE ANIM Blueprint like you say, then the Anim Blueprint itself or the animations might have
become corrupted. When it becomes corrupted, you have to delete the corrupt animation asset and reimport it, or
may have to delete the anim blueprint altogether and make a new one. If there’s no change and its still corrupted, then
the project it is in is probably corrupted as well, and you have to migrate to a new blank project. Otherwise check the mesh to
make sure that the Armature has not become corrupted.

The problem with hardcording as this engine likes to hard code everything, is that when you go back later on to try to make changes
or adjustments to it after its been all hardcoded in the engine the blueprints can start to slowly corrupt themselves. That’s why
it has to be hard coded and then just left alone. This engine is not like your Text Editor where you just can go back all the time
to make changes the engine dosen’t like its code being changed and adjusted around all the time.

I mean that you could be using a different axis than the mannequin skeleton. For example you’re using a lot of Break Rotator and only using Z for example. Are you sure that Z is the one that should rotate? You should compare the axes by going into skeleton mode, selecting a bone that’s used in the calculations, rotate it in some ways (X/Y/Z) and compare how the values change when you do the same thing on your skeleton.

Alright, thanks for everything, you guys mentioned the root bone and so I tried redirecting it, but it didn’t work. So I Just ended up exporting the Mannequin skeleton into 3ds max and skinning it on to my character mesh. Imported it directly on to the mannequin skeleton associated with the anim blueprint and it works near perfectly. Except now i’m getting an error with the feet. they get all twisted when they look fine in 3ds max when I skin it. Any advice?
This is how it looks

And heres the vid: - YouTube

I don’t have 3ds max, only Blender, but I know nothing about rigging or skinning a 3d mesh… I had to rely on Mixamo to rig my models but now that’s service is gone so i can’t do rigging or 'animations anymore now at least I don’t think. But it didn’t weight them right so they look weird…So its not good for my game…

You should beable to just untwist the feet by going into the Skeleton Editor and then clicking on the left foot bone and just rotate the foot around with the rotation tool, it
should then untwist the feet…

Nah, you can rotate but it still looks deformed, cuz the rotator in the editor is nowhere near as precise as 3ds maxs. theres got to be a way for that foot to be imported correctly. infact, it should be the norm, seeing as I did everything correctly. there should be no reason for that to be happening.

Oh wait a minute Mixamo is still online… Hmm Does Unreal measure the axis points and location in the world using the Skysphere? because even the numbers don’t always add up, like I can copy the scaling numbers of static BSP out of one project only to find sometimes when i copy te numbers into the location and rotation boxes, and so on sometimes some of the BSP are using different world scaling. And both projects are using the same skyspheres. So sometimes when I copy scaling values, it comes out smaller than in the original even though the scaling numbers are the same when I recreate it. I found that a bit weird. Personally I think the engine is a bit buggy.

You’re changing the Import Uniform Scale on import which is a bad idea, instead you should set up 3DSMax to use centimeters instead of inches. You should export with scale 1. Not sure if that’s causing the error though, it could be that you’re selecting another skeleton instead of using the one that’s exported.

how is the foot getting twisted in like that?
What about the import transform settings ?

not the transform settings, theyre all on 0

and there should be no problem selecting the mannequin skeleton, seeing as its the sme one I used on the character.