Download

UE4 and Visual Studio 2015

EDIT: The latest Unreal Engine versions now support VS 2015. The information below in this post is now outdated.

Hi everyone,

Now that Microsoft has released Visual Studio 2015, and they are encouraging people to use their latest version, I wanted to take a moment to remind everyone that Unreal Engine 4 does not currently support Visual Studio 2015. Yet. We are working on finalizing support for Visual Studio 2015, and it will be coming soon in a future release version. For now, please continue to use Visual Studio 2013 as we will not be able to provide support for Visual Studio 2015 until the Engine officially supports it.

If you need to download Visual Studio 2013, you can do so from this page. Click “Visual Studio 2013” on the left side of the page, and make sure Community is the selected option (or whichever version you are looking for). Choose your language and format from the options, and click Download. One quick note about the “Web (Online)” format option: The file that was downloaded for me here in a couple instances did not have an extension. Adding a .exe extension allows you to then run the installer.

We will make sure to let you know when Visual Studio 2015 is supported by the Engine.

Tim

Update: With the release of 4.9 yesterday, support for Visual Studio 2015 has been partially implemented. It is currently only available when building the 4.9 Engine from source code. In order to be able to use Visual Studio 2015 with 4.9, you must run the GenerateProjectFiles.bat file with the “-2015” argument. This will create a Visual Studio 2015 solution for the Engine. Omitting the -2015 argument will result in a Visual Studio 2013 solution.

Visual Studio 2015 support is still considered to be in Beta, so we do not recommend using it for active project development at this point. If you experience any problems with using Visual Studio 2015 with the Engine, please let us know on the AnswerHub.

Tim

Thank you :slight_smile:

I was able to compile 4.10 Preview using VS2015. However, creating a C++ project still defaults to VS2013? How do I make new projects use VS2015 by default?

Hi Chyros,

This was an issue when building 4.9 with Visual Studio 2015, but I have not seen it occurring in 4.10 Preview 1. Do you get the same results if you try with 4.10 Preview 2?

Tim

Yes, I was using 4.10 Preview 1. Here’s exactly what I did:

  • Checkout 4.10 Preview 1 via GitHub
  • Setup dependencies with --include=Android param
  • Generated project files with -2015 flag
  • Built code using VS2015 Community Edition
  • Started UE4 without debugging
  • Created a new project: New Project -> C++ -> Third Person (Desktop / Console, Maximum Quality, With Starter Content)

Then VS2013 Community Edition starts up by default. Opening .sln project with VS2015 shows “{insert-project-name-here} (Visual Studio 2013)” in Solution Explorer.

Was it because I have VS2013 on top of VS2015?

EDIT: Above was done on 4.10 Preview 1. I’ll check if it still does in Preview 2.

UPDATE: Still occurring on Preview 2.

UPDATE #2: Workaround for now - Create GenerateProjectFiles.bat and save it on the project folder you want to generate project files with:


@echo off

set UE4_PATH=C:/YourUnrealEnginePath

echo Generating project files in %cd%...
for /f %%i in ('dir *.uproject /B 2^>nul') do (
	call "%UE4_PATH%/Engine/Binaries/DotNET/UnrealBuildTool.exe" -2015 -projectfiles -project="%cd%/%%i" -game -engine -progress
	goto end
)

:no_uproject_file_found
echo ERROR: No .uproject file found
exit /B 1

:end
echo Done!
exit /B 0

Just modify the UE4_PATH for the script to find the UnrealBuildTool file.

I think Android development is still unsupported by vs2015. That what GenerateProjectFiles tell when it’s run.

Greetings, first, I really appreciate the effort to upgrade to VS2015. However I’m failing to get intellisense working for my solution. Is there documentation anywhere for this specific setup of Unreal 4.10 and VS2015 in regards to intellisense?

Thanks in advance.

PS. (First post!)

Hi McDirty,

Could you please make a post about this on the AnswerHub (if you haven’t already done so)? There should be nothing special needed for intellisense to work with the Engine source code, but if you post on the AnswerHub someone should be able to help narrow down what is happening a little better.

Tim

I just Started today can you help me.

I just wanted to provide everyone with an update on the status of using Visual Studio 2015 with UE4. With the recent release of 4.10, Visual Studio 2015 is now the default Windows IDE. If you are building the Engine from source code, you can still use Visual Studio 2013 by using the -2013 command line argument.

We do plan on phasing out support for Visual Studio 2013 at some point, but that is still waiting for a few outstanding issues to be resolved.

What about this?
http://blogs.msdn.com/b/visualstudio/archive/2015/12/15/installing-the-unreal-engine-in-visual-studio.aspx

Is valid for VS 2015 Community version? I updated with SP1 but i can’t find the UE4 template.

Hi ZioYuri78,

I am trying to get some more information about this feature of Visual Studio. I looked in Professional, and I only see Cocos and Unity installation options. I suspect that this is because I already have Unreal Engine 4 installed on my computer, but I am waiting for confirmation of that.

Tim

Could be and make sense, thank for looking around :slight_smile:

EDIT:

Confirmed, it not show up if UE4 is already installed
http://blogs.msdn.com/b/visualstudio/archive/2015/12/15/installing-the-unreal-engine-in-visual-studio.aspx#10660732

Can you explain how to use this command line arg? It doesn’t work for me when I launch like so:

D:\Program Files (x86)\Epic Games\Launcher\Portal\Binaries\Win64\EpicGamesLauncher.exe -2013

-or-

D:\Program Files (x86)\Epic Games\4.10\Engine\Binaries\Win64\UE4Editor.exe -2013

Neither of these lets UE4 see my VS Express 2013 for Desktop

Hello Tyguy7,

This command to allow the use of Visual Studio 2015 will only work for when the engine is built from Source. To use it, you need to place it inside of the GenerateProjectFiles.bat.

As far as where you place it, I’ll give an example with the .bat file from one of my source builds:

@echo off

cmd.exe /v /c “%~dp0Engine\Build\BatchFiles\CopyVisualizers.bat”

if not exist “%~dp0Engine\Build\BatchFiles\GenerateProjectFiles.bat” goto Error_BatchFileInWrongLocation
call “%~dp0Engine\Build\BatchFiles\GenerateProjectFiles.bat” -2013%*
exit /B %ERRORLEVEL%

:Error_BatchFileInWrongLocation
echo GenerateProjectFiles ERROR: The batch file does not appear to be located in the root UE4 directory. This script must be run from within that directory.
pause
exit /B 1

I’ve bolded the command and the spot that it needs to be placed in. For clarity’s sake, this also works for forcing -2015 usage with 4.9 source builds.

Hi,

I have the problem of ‘cannot find windows.h’ during compilation, about which I have found a lot of questions, but only a few answers, of which none applies to my setup, mostly because they regard VS 2013 issues.

I use: Windows 7 - UE 4.10.2 - VS2015

I can use VS 2015 on its own without problems. Also I can use Blueprint templates in UE.
But when I tried the beginners tutorial on c++ programming on the UE community site, i got the following error:

I tried reinstalling everything (VS2015, Windows SDK, UE) several times, but the problem persists. I also tried to revert to VS2013 as I read a few posts of people having made it to work, but the current release of Unreal Editor requires VS2015.

Has anyone a receipt for a working setup on Windows 7

Thanks,

Marius

I also have problems with UE 4.10.2 and VS2015 on Windows 7.

I need to use external libraries in my application, so I need to set additional include paths, library paths and libraries.
It’s usually done in C/C++ and Linker setting in project configuration.
It works for non-unreal projects: there are items in project Configuration Properties:
General
Debugging
VC++ Directories
C/C++
Linker

In projects generated by Unreal Editor I see only
General
Debugging
VC++ Directories
NMAKE

and that’s all.

There are no C/C++ and Linker properties.
Is this intentional ? How can we add external dependencies ?

Thanks for help,
Robert

:mad: Installing Visual Studio 2015 takes very very long time, always stop in some install steps, for example: creating restore point, build tools … ! this problem appear only on Windows 10, the same version worked will on other OS like 7,8 and 8.1, How can I fix that ?

Okay, I have access to 2013 VS Ultimate IDE… In —>New Projects—>Templates—>Games(games templates is missing)…
But, when I installed 2015 community edition… The game’s template was there.

Unity, Unreal Engine & one other kind of template I forgot the name… I was able to successfully download and install unreal engine from the 2015 community edition.

Updated Unreal Engine to 4.10, I tried to click on a new C++ project to create a “Basic Code”…

This is a screenshot of the error message I received:

ScreenShot_20160313074504.jpeg

Noticed you guys are using some commandline arguments at the end of the executable file?

If anyone knows, could you please let me know how to make unreal engine recognized and utilized my 2013 VS Ultimate IDE installation…

Thank you for your time…