UE4.6.1 "Externally Referenced" on basic map

I have a basic map with a landscape and a very simple material applied to it (Base Color with a Constant3Vector). The editor complains about external references when I do a Map Check, and any time I deploy to a device or other actions. The material I’m talking about here is a brand new material I created in my project, and it’s path is /Game/Materials/M_BasicColor

  • If I remove the material from the
    landscape - the landscape warning
    goes away.
  • If I duplicate the material in Content Browser, assign the duplicated material to the landscape WITHOUT SAVING, the warning goes away. However, as soon as I click “Save All” - the warning comes back.

Warning Landscape_0 Landscape /Game/Maps/Marl.Marl:PersistentLevel.Landscape_0 : Externally referenced

Hi schetle,

I haven’t been able to reproduce what you are seeing. Could you create a test project with the error and post a link here to download it here?

The warnings aren’t present when I migrate the map. The warnings also aren’t present when I copy the entire project to a different directory. Corrupted somehow?

It’s possible. A project corrupting like that is pretty rare but it has happened. It sounds like it could be some sort of referencing error, which are generally hard to track down and fix. If copying the project to a new directory works, I would suggest going with that workaround.

If it happens again or if you receive a similar error, please post back here and let us know.



Simply rename the folder, run the project, rename folder to previous name again, done.

Thanks a lot man, that fixed it for me.

Worked for me too

I can’t seem to get this to work. Do you mean to rename the project folder or the map folder? Do I open up the faulty map when I open up the project? Nothing I do seems to work.

Hi Benjiko99,

Would you have time to go into a little more detail on your answer to help DamirH and other users?

FYI, it seems to be the project folder. That’s what fixed it for me.

Wow really… This was what it suggest when posting this bug AGAIN… However this is the problem I have and why that option is not by any stretch a fix or work around. A: I hate clutter in my content directory and it is just sloppy and unprofessional to have every asset from the marketplace hanging out leaving its trash all over the place. So I rename said content and move it. If I can’t rename the content and put it where I want (which is a chore by itself) there is no point in using the engine… Its abilities are great and mighty but basic functionality is simply not being there or getting corrected. This is really getting old after a year and a half of version after version having the same broke content browser…

Why are we moving on from 4.8 to 4.9 if 4.4. 4.5, 4.6, 4.7 and 4.8 all have the same basic functional issues in the content browser flaws? Maybe you are moving to fast. This engine blows away just about everything out there… You can take your time and get it right you know.

You are quite right about that. Content renaming, redirectors, deleting assets and things like that are extremely fragile in ue4. These are things that should be fast, easy and bugless. This is basic functionnality and it is extremely bad in this engine.

Nailed it. How bizarre. In my case I renamed the project directory. Opened the project. Saved it. Closed it down. Changed the project directory name back to what it used to be.

Yes, that did it (WTF).

I had the “externally referenced” warnings today, and the fix of closing the Editor, changing the project folder name, opening the project, closing the Editor , then changing the project folder name back, and reopening the project; worked to fix the issue.

The procedure that JonathanADaley mentioned, worked for me too. What I can add is that I had upgraded to 4.9.2 from 4.8.3 using the “open a copy” method as recommended by Epic. The assets the editor were moaning about were a StaticMeshComponent, a SkyLightComponent and an AbstractNavData (the level is basically just a cube with a couple of lights and a playerstart).

This worked for me as well. Moved from 4.8 to 4.9.2.

I got these warnings when moving from 4.8 to 4.9 and now again after I converted a copy of my project to 4.10P2… Will I now have to do the project folder renaming after each engine update? Will there be a fix for that at some point?

Hey John,

This is a known error if you are cloning your project and then converting that cloned project in place. Is that the workflow that you are using?

Instead try to open the project with the new engine version and then choose ‘Open a Copy’. This is the suggested workflow.

To get this error you must convert a project in a way that we do not recommend, so this error does not have a planned fix.

I just found renaming the folder, opening and saving worked for me. I sometimes find these things annoying, then remind myself that UE is open source, if I was that frustrated by anything I could go into the source and change it - then the act of thinking of what I would have to do to fix them makes me feel that the work-arounds are just fine :slight_smile: I’ve been doing the upgrade “in-place”. From now on I’ll do it on a copy then just delete the original once I’m happy it converted properly.