ue4.5 running worse with oculus dk2


anyone else having this problem? i’m losing about 10 frames per second in 4.5…just enough to make everything all jittery again. it seems maybe the distance field ao or something? some of the new raytrace rendering? i’m not sure. i have a game that is indoors and outdoors. when i’m indoors, if the floor is shiny, i get about 60FPS and jitter. in the old version i had a very solid 75FPS. when i go outdoors it’s also about a 10 FPS loss and even more jitter than before when i move my head around. (and yes i’m closing the editor and just launching the game in standalone mode by right clicking on the project and doing “Launch game”
any settings I can put to get a better experience?
these are the current console commands i’m executing via level blueprint:
stat FPS
hmd sp 100
sg ResolutionQuality 55
sg ViewDistanceQuality0.3
sg AntiAliasingQuality 0
sg PostProcessQuality 0
sg ShadowQuality 0
sg TextureQuality 1
sg EffectsQuality 1

i have a GTX750 ti that i got just so i could develop. it’s been pretty frustrating how much graphics i’m constantly having to sacrifice to get rid of that jitter when i move my head around. i hope the VR enhancements get worked out. there are a more and more votes for it on trello.

thanks so much for any help

Looks like you are setting up a number of the key effectors for performance. I am wondering if your smoothed framerate got switched back or AA settings got switched. I have a video that walks you through checking most of the settings here if it helps:

oh wow thank you so much. i do things in previous versions and then promptly forget how and what i did! i rechecked smooth frame rate in the project settings and also set it between 20-70 FPS (a new feature i think?). it’s working much better now!

i’m going to go through your video now. looks like there are a lot of other things i can be doing too. seems like a great video that is very much needed for a lot of us. thanks for all the help and knowledge sharing!

Hey Tree, I’ve had similar thoughts. I’m fairly familair with all the usual steps of getting things to run well in the DK2 and I have an overpowered machine as well. I just built a fairly uncomplex scene in 4.5 and I’m getting the judder when I turn my head as well. I’ve been using the VR template like always, but now it seems shadows definitely are the culprit, where as they weren’t an issue before. Curious if anyone else is experiencing this as well?

i haven’t any issue yet, indeed now two things that weren’t working for me now do: restart game by console command and foliage.

Really glad to help and glad it is working better. I had a difficult time getting all the stuff figured out as well and I saw many people asking the same questions so I wanted to create a video to discuss them and show how to set them up to make your VR development easier.