Download

UE4 4.25 Steam Issue

Hi Guys,

not sure 100% is this is where to stick this post, but ive been creating a plugin for steam (yes another one :D) and just upgraded to 4.25
I have updated project to 4.25 and any link to steamworks to 147.

i run my sample project in standalone and i no longer get steam or the overlay for steam, shift and tab till i break my keyboard

I have checked all the online subsystem steam stuff is checked in plugins and my configs havent changed?

I created a new project and added the config items to engine.ini and enabled subsystem steam in the plugin settings and same thing!

Am I missing something obvious with this latest release?

kind regards

Edit

Found this in the Log

LogSteamShared: Display: Loading Steam SDK 1.47
LogSteamShared: Steam SDK Loaded!
LogOnline: OSS: Creating online subsystem instance for: Steam
LogOnline: Warning: STEAM: Steam API disabled!
LogOnline: Display: STEAM: OnlineSubsystemSteam::Shutdown()
LogOnline: OSS: Unable to create OnlineSubsystem module Steam
LogOnline: OSS: Creating online subsystem instance for: NULL
LogInit: WinSock: version 1.1 (2.2), MaxSocks=32767, MaxUdp=65467
LogOnline: OSS: TryLoadSubsystemAndSetDefault: Loaded subsystem for module [NULL]

Did you work this issue out I get the same thing?

unfortunately not, currently waiting for responses/ideas, I have also added the question to the transition guide post

as soon as I can get an answer i update the opposite thread. The only thing i can think of is they added a new config variable to initialise steam that i cant find.
Or in changing steam version there was a misstep and it doesn’t load properly.

I might dip into the source code later and see if i can determine where/why it doesn’t load. It is not something I have done much of for UE4 so might take some time

kind regards

Ah ill have a pop around to seems odd they would miss something so large in the preview builds.

Looking at the code in
/release/Engine/Plugins/Online/OnlineSubsystemSteam/Source/Private/OnlineSubsystemSteam.cpp

, it will only shutdown like that with LogOnline: Display: STEAM: OnlineSubsystemSteam::Shutdown()

if either if (bClientInitSuccess && bServerInitSuccess) fails on line 440

so i take it, that the problem lies somewhere in the Init function at 416 to line 440

the only thing that seems to have changed was the addition of “Fixing Steam OSS initializing a server when starting a client build (97859d95fbbbcb7a243f4f847375812eb1899ceb)”
not sure that that would cause it though and i did try bInitServerOnClient=true in my config and no difference.

so without debugging i can only assume that InitSteamworksClient(bRelaunchInSteam, RelaunchAppId) is returning false so where?
anyone able to debug that, not got it set up, just looking at the code on git hub?

not sure if im chasing a red herring here though, but given the log says its shut down and the over lay isnt there then the overlay i think gets added in that InitSteamworksClient function but not 100%

kind regards

Some people are reporting no issues using steam on 4.25 which is strange.

very odd :S in the new “CLEAN” projects created from 4.25 this is what i have enabled (plus trying anything said above)

could anyone try the below and see what I am missing, if it works for some people id imagine its something obvious?

Steam works fine when packaged just doesn’t work in the editor and I’m pretty sure its because of the play option changes.

Issue has been logged

For those wondering, it is still possible to run steam without needing to package. The Standalone Game no longer runs the Steam overlay, but here’s at least 3 other ways to do it:

  1. Run the game from Visual Studio using debug/development config or debug/development editor config with “-game” as extra command argument in the debugging section of your project properties.

  2. Run the game using the project launcher in editor. You can either use the Launch option directly or make your custom launching profile for the platform you are trying to run the game on. Unfortunately, this requires cooking the content which may take some time.

  3. Run the game from command line.

It’s slower than just using the Standalone button, but it’s at least an alternative.

I had a quick look at the release notes for v4.25 and this showed up. Can someone who knows what they are doing help me with what I have to do?

it is worked by using “-game” as extra command argument

Well this certainly explains the last five hours of tearing my hair out.

Edit: Another workaround is right-clicking the .uproject file and hitting “Launch Game” from there, uses the editor binaries looks like so no build time.

From the release note

so go to your DefaultEngine.ini and add

and try launch game by right click on (.uproject) file.

When I right-click and Launch Game off of my .uproject per roxa’s tip, I can get the Steam overlay to come up, no problems there. But if I package it as a dev or shipping build, I get nothing at all - unlike OverRated’s experience. (And nothing from the editor, same as everybody else). It doesn’t work trying from an elevated command prompt either. I’m a little confused about where to put the “-game” switch… Are you guys talking about in a shortcut to test in the editor, or on an actual build? I’d like to get Steam running off a packaged game where I can send it to others to help test multiplayer, and not just playing / launching from the editor binaries… that’s a giant mess.

Everyone with the same problem please vote to be fixed: Unreal Engine Issues and Bug Tracker (UE-92985)

Sigh, just updated to 4.25.3 kinda hoped this would be fixed by now, please vote the above

I’m having this same issue on 4.25.3.
Could this have anything to do with the new feature where you can launch more than a single StandAlone game from the editor?

Hey there, same problem here, 4.25.3.
Just voted to fix the issue and wanted to add my voice to this thread.
Can’t use in standalone and packaged game crashes when trying to create a session.
The last few versions of the engine have really been broken as hell, and migrating is becoming more of a nightmare every time now <sigh>
Anyone know if 4.25.4 is on the road or do we have to wait for 4.26 ?
Cedric

I had your same issue, I think I solved it by moving the steam plugins from the UE Engine folder to a Plugins folder in the project directory. I’m not sure if the same would apply to you.

I can’t find anywhere any info on how we are supposed to setup the Steam plugins, so I’m not entirely sure that I did something that makes any sense, but it seems to work!