Download

UE4 4.25 Steam Issue

You can get the SteamCore:: plugin, it includes a fix for 4.25 that enables you to use steam in Standalone.

I think paying 80+ euros to have this fix is a bit too much. Useless advice, honestly.

I also encounter this problem; cannot bring up steam overlay using hotkey Shift + Tab. Found this: UE 4.25 Dedicated Server Steam Sessions Not Working - UE4 AnswerHub

Scroll down to bottom. Link suggests adding game to steam library. This worked for me, I can bring up steam overlay.

Using 4.25.3. Built game as Shipping. Have subsystem and substeamSteam plugins enabled. And DefaultEngine.ini has the code that the documentation offers.

I’d like to add my experience with the steam overlay as of 4.25.3. I had to switch to fullscreen, after that, the steam overlay was working fine again.

Can you please elaborate on what folders you moved to the project? :slight_smile:

Doesn’t seem to be a lot of good news in the 4.26 release notes regarding improvements here. Anybody try it yet?

1 Like

Im getting the exact same symptoms. Im not sure where to go from here. Has this been resolved? If so, how ?

There is no method that could help me. Maybe I did something wrong.
But if you still have problems with getting Steam-overlay working in Standalone, you can use my free simple editor plugin that fixes that
Just place it in Plugins folder of your project (If it doesn’t exist, then create new one)
Download link

1I2Hawk is true couse if you will go to unreal projects by default its in documents and unreal projects my project folder and then myproject.uproject right click it and then click lauch game and it works perfectly

second CENCOR_1337 its true but the update made it already true so you dont need to worry about that so ya there is no issues

cya

This is still broken in 4.26…sigh

1 Like

BRO SAME!!! They’re not telling ya where to put those things and I have the same problem.
It works fine on right-click → launch game on .uproject.

It is very annoying.

1 Like

Seems like Unreal Engine version 4.27 has a fix integrated in from the official github fix commit resolving the issue UE-92985 discussed above.

Issue: Unreal Engine Issues and Bug Tracker (UE-92985)

Fix commit: Reenable Steam when running Single Process PIE, but disable Steam Soc… · EpicGames/UnrealEngine@7b3e2a0 (github.com)

On the project I am working on right now (UE 4.26), I am dealing with this exact issue and I don’t think I can upgrade to a new Unreal Engine feature version right now as it might break certain assets we are using. I’m hoping this change gets integrated into a 4.26.4 update down the line because those updates are meant to include fixes only and don’t break compatibility which is what I am afraid of when upgrading to 4.27…

So far I am using the workaround suggested by @ANameTooLongToFi by adding the -game command arguments in visual studio and it works totally fine if I’m logged into Steam.

Another band-aid fix I found that works is creating a shortcut that launches the UE editor on the uproject with the -game flag.

Modify target in the screenshot to be: “C:\Program Files\Epic Games\UE_4.26\Engine\Binaries\Win64\UE4Editor.exe” “C:\PathToProjectDirectory\ProjectName.uproject” -game

Start in: “C:\Program Files\Epic Games\UE_4.26\Engine\Binaries\Win64”

Hope this helps some folks out!