UE4 4.13 Black Screen on Certain Phones

We updated to UE4 4.13. Everything seems to work perfectly on the Galaxy S6 phones, but certain S7 phones are showing a black screen ( audio still plays ).

I created a simple project with a single map ( the standard default level with a plane and a starting point ) and have the same problem.

When comparing the hardware, the significant difference we found was that the black screen phones were using a Qualcomm Snapdragon 820 processor while the other phones used a Exynos 7 or 8 processor.

I tried turning on OpenGL 3.1 support but that didn’t seem to make a difference.
I also tried running an arm64 build (instead of the armv7). That displayed, but that didn’t run in VR mode; just a full screen monoscopic display.

Thanks for your help!


If this happens only on Gear VR, please also report it to Oculus on their dev forums.

Oculus is aware of the problem, and is currently looking at a solution, which we hope to patch into 4.13.1

Great. Thanks Nick!

Do you know when we might see 4.13.1? I’m eager to try out the new media texture features but I’m stuck on this issue.

Any news on this thing?

Hi Nick, is there any applicable workaround in the meantime? what is the cause of the problem?

The issue is fixed in the latest version of GearVR, which you’ll need to update, and you’ll need the code in 4.13.1 to go with it. That’s being released soon. The issue required a fix in the Oculus MobileOVR SDK to fix a race condition that was caused by the way UE4 initializes the renderer.

If you want the fix early, you can grab this commit: , as well as making sure you update your GearVR runtimes on your phone to the latest.


I am having this prob with my Note 4 (snapdragon). I have latest unreal 4.13.1 and the note 4 is up to date.

Any ideas?

I’m using UE4.14
I have same problem with my package on SAMSUNG S7(black screen)
But it runs well on my SAMSUNG S6
It’s so confusing

Same problem here~
It’s only happen on the S7 which with the certain CPU(Snapdragon 820)…Cause there are two different CPU on S7, so everything works on S7 which use Exynos…
And this issue still shows on UE4.14,please give an updata about this.

Is anyone here running into black screens with S7’s but not S6’s setting the screen percentage to something other than 100%? We’ve found a bug which would result in a black screen on Adreno S7’s when screen percentage is being changed. If so I can point you towards a possible fix.

Yes, we are seeing this issue - a fix would be really welcome as our app keep failing Oculus’ Technical Review due to black screen on Adreno S7.


When I set the screen percentage to 75%, black screen is gone,
my project runs 30+/fps on Samsung S7.


On Samsung S6 it runs 59/fps smoothly under screen percentage to 80%.
It’s not reasonable, is Samsung S7 even worse than S6 ?

I recall that Gear VR apps run with 100% screen size at all times. At least that’s what it used to be and it was locked to 100%.