UE4.27, nDisplay root actor and Player Pawn

Something major changed in nDisplay with 4.27, and I haven’t been able to find any doc on it or any mention about this anywhere. In short: nDisplay’s root actor isn’t “attached” to the player pawn anymore. It was not the case in 4.26.

You can easily check that for yourself with the nDisplay template project. In both engine version (26, 27), in PIE, you can control the default player pawn and move around in the small scene.

If you start this project in nDisplay 4.26, you will also control the player pawn, and any movement you make will also move the root actor, and therefore the cluster displays will all reflect the change in point of view.

However, if you start this same template project in nDisplay 4.27, any movement you make on the default player pawn will not move the nDisplay root actor, which will stay at its static default position.

Is this a new feature? Is this known? Is this a bug? I don’t know. I just know that it breaks a lot of things on our side. I also think it’s weird to have different behavior whether you’re in PIE or nDisplay (e.g. viewpoint moving or not).

Anyone has more information on that?

PS: Is this even the right place to discuss nDisplay things?

There were a number of changes to nDisplay in 4.27

Much of that was improvements to configure screen layouts and controls.
I’m not sure of your specific issues.

Thank you for your reply. I’m very aware of the changes to nDisplay in 4.27, but as I mentioned, nowhere in the documentation is it expressed that the view origin isn’t tied to the default player pawn anymore. So I don’t know if this is a new feature, in which case they might want to explicitly say so, because having different behavior in PIE and nDisplay would be non-obvious for most users. Or if it’s a bug, it which case it would need to be logged as such and fixed.

Right now I don’t know if I need to find a permanent workaround for this new feature, or if I just wait for a fix for this bug.

Open the config editor for the root actor, go under class defaults, go under the Configuration category, and check “Follow Local Player Camera”.

Does that give you the behavior you want?


It most certainly does!

Thank you so much for your help, you’re amazing. I should have thought of checking the class defaults, that’s also on me.

1 Like

Hi !
I am also facing the same issue. I am relatively new to UE and nDisplay. I was able to move around the environment with 4.26, but with 4.27 I am not able to do so. I am using the default ndisplay demo project. I edited the NDC_Basic and checked the “Follow Local Player Camera” option, saved and compiled it. Still when I start ndisplay I am still not able to move.

It worked. Instead of selecting the .ndisplay file, selected .uasset file in switchboard and I was able to move now.
Thanks .

I’ve tried the methods listed out here and it seems to work in PIE perfectly fine but using ndisplay over multiuser, it seems nothing will take control of the root actor component.